在线检测未来函数

大智慧rsi优化版指标公式

来源:Internet,编辑:股旁网,2011-03-02

LC := REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
A3:=BARSLAST(ref(cross(RSI1,RSI2),1));
B3:=ref(c,A3+1)>c and ref(RSI1,A3+1)<RSI1 and cross(RSI1,RSI2);
RSI底背离:FILTER(B3>0,5),linethick0,COLORCYAN;
STICKLINE(FILTER(B3>0,5),0,20,3,0),COLORCYAN;
DRAWTEXT(FILTER(B3>0,5),20,'RSI底背离'),COLORCYAN;
C3:=BARSLAST(ref(cross(RSI2,RSI1),1));
{股旁网-股票公式网站 www.GupaNg.com}
D3:=ref(c,C3+1)<c and ref(RSI1,C3+1)>RSI1 and cross(RSI2,RSI1);
DRAWTEXT(FILTER(D3>0,5),80,'RSI顶背离'),COLORMAGENTA;
R:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;;
MAR:=MA(R,3);
F:=100*(C-REF(C,1))/REF(C,1);
HHH:=EMA(R,25)+6;
买:(REF(R,2)>REF(R,3) AND REF(R,2)>REF(R,1) AND R>REF(R,1)
AND MAR>REF(MAR,1)+1 AND REF(MAR,2)-REF(MAR,1)>-1
AND REF(R,1)<REF(MAR,1) AND REF(R,2)-REF(MAR,2)>-3
AND REF(R,1)<38 AND R<HHH AND F<8),LINETHICK0;
DRAWICON(买,RSI1,7),ALIGN1,LAYER0;
秒进:if(H=O AND C=H AND H=L AND O>(REF(C,1)*1.04),100,0),LINETHICK0;
VERTLINE(秒进,1);
MID:=MA(RSI1,20);
上轨:MID + 2*STD(RSI1,20),COLOR993300;
下轨:MID - 2*STD(RSI1,20),COLOR993300;
中轨:((上轨-下轨)/2)+下轨,COLOR993300;
抄:CROSS(RSI1,下轨) AND RSI1>REF(RSI1,1),LINETHICK0;
DRAWTEXT(抄,下轨,'抄'),COLOR00FF00;

大智慧rsi优化版指标公式

 

相关文章