在线检测未来函数

通达信系统黑马指标公式

来源:Internet,编辑:股旁网,2011-03-03

{以下设置"顶天立地"指标的"出击选股"}
VAR1F:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR21:=SMA(VAR1F,3,1);
趋势:=SMA(VAR21,3,1),COLOR0000FF,LINETHICK2;
人气:=SMA(趋势,3,1),COLORYELLOW,LINETHICK2;
顶天立地:IF(CROSS(趋势,人气) AND (趋势<30),50,0),COLOR0000FF,LINETHICK2;
DRAWTEXT(CROSS(趋势,人气) AND (趋势<30),60,'顶天立地'),COLOR0000FF;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); {选股设JC=10即可}
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),COLORSTICK;
A:=IF(CROSS(0,DEA),1,0);
A1:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0);
SS:=IF(A,SUM(A1,0),0);
SSB:=HHV(SS,0);
SSS:=SUM(A1,0);
笑傲江湖:IF(SSS-SSB=2 AND SSS>REF(SSS,1),50,0),COLORWHITE;
{以下设置"黑马起步"指标}
VAR11:=EMA(CLOSE,8);
VAR22:=EMA(VAR11,20);
VAR33:=CROSS(VAR11,VAR22);
VAR44:=VAR11< EMA(CLOSE,120);
{股旁网-股票公式网站 www.GupaNg.com}
黑马起步: IF(VAR33 AND VAR44,50,0), , COLORGREEN;
乖离率BIAS买入:CROSS(-6,(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100),STICK,LINETHICK2,COLORRED;
心理线PSY买入:CROSS(10,PSY(12,1)),STICK,LINETHICK2,COLORGREEN;
WVR := SUM((IF(CLOSE>OPEN,VOL,0)+IF(CLOSE=OPEN,VOL/2,0)),26)/SUM((IF(CLOSE<OPEN,VOL,0)+IF(CLOSE=OPEN,VOL/2,0)),26)*100;
VOL变异率VR买入:CROSS(70,WVR),STICK,LINETHICK2,COLORMAGENTA;
WRSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
相对强弱RSI买入:CROSS(WRSI,20),STICK,LINETHICK2,COLORYELLOW;
BIAS买入:STICKLINE(CROSS(-6,(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100),0,70,0,0),LINETHICK2,COLORRED;
PSY买入:STICKLINE(CROSS(10,PSY(12,1)),0,70,0,0),LINETHICK2,COLORGREEN;
VR买入:STICKLINE(CROSS(70,WVR),0,70,0,0),LINETHICK2,COLORMAGENTA;
RSI买入:STICKLINE(CROSS(WRSI,20),0,70,0,0),LINETHICK2,COLORYELLOW;
{以下设置"主力进场"指标}
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED,NODRAW;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2,1 ),COLORRED;
洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,NODRAW;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2,1),COLORGREEN;

通达信系统黑马指标公式

 

相关文章