在线检测未来函数

通达信优化RSI指标公式

来源:Internet,编辑:股旁网,2011-03-07

N:=14; N1:=3 ; N2:=34 ; K:= 3;
DRAWBAND(0,RGB(100,100,0),100,RGB(100,100,0));
LC := REF(CLOSE,1);
RSI:SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100,,COLORRED,LINETHICK2;
压力: HHV(MA(RSI,3),13),COLORGREEN;
支撑:LLV(MA(RSI,3),13),COLORYELLOW;
AA:=REF(RSI,N1)=HHV(RSI,2*N1+1);
BB:=BACKSET(AA,N1+1);
CC:=FILTER(BB,N1) AND RSI=HHV(RSI,N1+1);
A1:=BARSLAST(REF(CC,1));
背离:=REF(CLOSE,A1+1)<CLOSE AND REF(RSI,A1+1)>RSI AND CC;
DRAWTEXT(顶背离,RSI*1.2,'顶背离'),COLORMAGENTA;
STICKLINE(FILTER(顶背离>0,5),支撑,RSI,2,0),COLORMAGENTA;
DRAWLINE(CC,RSI,FILTER(顶背离>0,5),RSI,0),COLORWHITE;
DRAWICON(顶背离,RSI*1.1,2);
AA2:=REF(RSI,N1)=LLV(RSI,2*N1+1);
BB2:=BACKSET(AA2,N1+1);
CC2:=FILTER(BB2,N1) AND RSI=LLV(RSI,N1+1);
A2:=BARSLAST(REF(CC2,1));
底背离:=REF(CLOSE,A2+1)>CLOSE AND REF(RSI,A2+1)<RSI AND CC2;
{股旁网-股票公式网站 www.GupaNg.com}
DRAWTEXT(底背离,RSI*1.2,'底背离'),COLORMAGENTA;
STICKLINE(FILTER(底背离>0,5),压力,RSI,2,0),COLORMAGENTA;
DRAWLINE(CC2,RSI,FILTER(底背离>0,5),RSI,0),COLORWHITE;
DRAWICON(底背离,RSI*0.98,1);
个股:EMA(100*(CLOSE-LLV(LOW,N2))/(HHV(HIGH,N2)-LLV(LOW,N2)),K),COLORCYAN,LINETHICK2;
大盘:EMA(100*(INDEXC-LLV(INDEXL,N2))/(HHV(INDEXH,N2)-LLV(INDEXL,N2)),K),COLORBLUE,LINETHICK2;
35,COLORGRAY;
50,COLORGRAY;
75,COLORGRAY;

通达信优化RSI指标公式

 

相关文章