在线检测未来函数

通达信三重MACD指标公式

来源:Internet,编辑:股旁网,2011-03-08

DIFF8 := EMA(CLOSE,25) - EMA(CLOSE,65),POINTDOT,LINETHICK2;
DEA8 := EMA(DIFF8,45),POINTDOT,LINETHICK2;
MACD8 := 2*(DIFF8-DEA8), COLORSTICK;
STICKLINE(DIFF8>=DEA8,DIFF8,DEA8,4,0),COLOR006CCC;
STICKLINE(DIFF8<DEA8,DIFF8,DEA8,4,0)COLORBLUE;
STICKLINE(DIFF8<REF(DIFF8,1) AND MACD8>0,DIFF8,DEA8,4,0),COLOR003C76;
DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26),COLORYELLOW,LINETHICK2;
DEA := EMA(DIFF,9)COLORGREEN,LINETHICK2;
MACD : 2*(DIFF-DEA), COLORSTICK,LINETHICK1;
STICKLINE(MACD<REF(MACD,1) AND DIFF>DEA,MACD,0,0.1,0),COLORRED;
STICKLINE(MACD>REF(MACD,1) AND DIFF>DEA,MACD,0,3,0),COLORRED;
STICKLINE(MACD>REF(MACD,1) AND DIFF>DEA,MACD,0,0.1,0),COLORYELLOW;
{股旁网-股票公式网站 www.GupaNg.com}
STICKLINE(DIFF>DEA AND MACD<REF(MACD,1) ,MACD,0,3,0),COLORE500DD;
STICKLINE(DIFF>DEA AND MACD<REF(MACD,1),MACD,0,0.1,0),COLORYELLOW;
STICKLINE(DIFF<DEA ,MACD,0,3,0),COLOR005B0C;
{STICKLINE(DIFF<DEA ,MACD,0,1,0),COLOR848284;}
STICKLINE(DIFF<DEA AND MACD>REF(MACD,1) ,MACD,0,3,0),COLOR7BA600;
{STICKLINE(DIFF<DEA AND MACD>REF(MACD,1),MACD,0,1,0),COLORDDDDDD;}
DIFFS : EMA(CLOSE,5) - EMA(CLOSE,12)COLORWHITE,LINETHICK1;
DEAS : EMA(DIFFS,4)COLORGREEN,LINETHICK1;
MACDS := 2*(DIFFS-DEAS), COLORSTICK,LINETHICK1;
DRAWICON(CROSS(DEA8,DIFF8),DEA8,3);
DRAWICON(CROSS(DIFF8,DEA8),DEA8,1);
DRAWTEXT(CROSS(DIFF,DEA) AND MACD8>0 AND DIFFS>DEAS,DEA,'--卧槽马');

通达信三重MACD指标公式

 

相关文章