在线检测未来函数

通达信DMI多头指标公式

来源:Internet,编辑:股旁网,2011-04-05

N:=14;M:=6;
TRTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/TRTR,COLORRED;
MDI: DMM*100/TRTR,COLORLIBLUE;
{股旁网-股票公式网站 www.GupaNG.com}
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M),COLORYELLOW;
{ADXR:EXPMEMA(ADX,M);};
XX1:=EXIST(CROSS(PDI,MDI),2);
XX2:=EXIST(CROSS(ADX,MDI),2);
DRAWICON(XX1 AND XX2,ADX,1);
STICKLINE(CROSS(PDI,MDI) AND CROSS(PDI,ADX),ADX*0.5,ADX*1.5,2,0),COLORRED;
PDI是多头:pdi,NODRAW;
10,POINTDOT,COLORLIBLUE;
75,POINTDOT,COLORRED;
XG:IF(ADX>55 AND ADX<65 AND C<REF(C,1) AND C>O,50,0);

通达信DMI多头指标公式

 

相关文章