在线检测未来函数

通达信DMI改进指标公式

来源:Internet,编辑:股旁网,2011-04-06

N:=14;M:=3;
TRTR:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/TRTR,COLORRED;
MDI:DMM*100/TRTR,COLORGREEN;
{股旁网-股票公式网站 www.GupaNG.com}
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORYELLOW;
ADXR:=SMA(ADX,M,1);
MA62:=MA(CLOSE,5);
MA20:=MA(CLOSE,4);
MA10:=MA(CLOSE,3);
VOL5:=MA(VOL,5);
DMR:=MA62>MA20 AND SLOPE(MA62,5)<0 AND SLOPE(MA20,4)<0 AND SLOPE(MA10,3) AND REF(MA20>MA10,1) AND CROSS(MA10,MA20) AND VOL>VOL5;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
VAR1:= EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
16;
30;
MR1:STICKLINE(LONGCROSS(PDI,MDI,2) AND LONGCROSS(PDI,ADX,2),28,15,1,0),COLORWHITE;
MR2:=(CROSS(PDI, MDI)AND CROSS(PDI, ADX)AND CROSS(PDI, ADXR))AND CLOSE>OPEN
AND C/REF(C,1)>0.5 AND VOL>MA(VOL,5)*1.5,COLORRED,LINETHICK3;
DRAWICON(MR2,16,9),LINETHICK3;
DRAWICON(DMR,17,15),LINETHICK3;
JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
DRAWICON(CROSS(84,JH),31,10);
DRAWICON( FILTER(CROSS(3.5,VAR1),20),29,16);

通达信DMI改进指标公式

 

相关文章