在线检测未来函数

通达信量趋势指标公式

来源:Internet,编辑:股旁网,2011-04-10

量:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,量*(HIGH-LOW),IF(CLOSE<OPEN,量*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖量:=(IF(CLOSE>OPEN,0-量*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-量*(HIGH-LOW),0-VOL/2)))*-1;
总量:买量+卖量,LINETHICK0;
净量:买量-卖量,LINETHICK0;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
{卖盘:-IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),COLORCYAN,POINTDOT;}
卖盘:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;
震动调整:=(买盘 + 卖盘);
STICKLINE((震动调整 < 1),1,震动调整,3,0),COLOR70DB93;
买卖量差%:((买盘)+(卖盘))/100000,COLORFF00FF;
STICKLINE((买卖量差% < 0),0,买卖量差%,3,0),COLORWHITE,LINETHICK0;
{成交量}买比%:买盘/VOL*100,COLORWHITE,NODRAW;
MA5:MA(VOL,5),COLORRED;
MA35:MA(VOL,35),COLORGREEN;
DRAWTEXT(CROSS(MA5,MA35),(V *1.05),'★'),COLORRED;
{股旁网-股票公式网站 www.GupaNG.com}
MAA:=MA( CLOSE ,2) ;
STICKLINE(C>MAA,总量,1,4,1 ),COLOR00FFFF;
STICKLINE(C<MAA,总量,1,4,1 ),COLORFF00FF;
STICKLINE(净量<0,1,总量,4,1),COLORFFFF00;
STICKLINE(C<MAA AND 净量>0,净量,1,4,1 ),COLOR0000FF;
STICKLINE(V>=2*REF(V,1),1,总量,4,1),COLOR0000FF;
STICKLINE(总量>1,总量,0,3,0),COLORFF3300;
STICKLINE(总量>1,总量,0,2,0),COLORFF7700;
STICKLINE(总量>1,总量,0,1,0),COLORFFAA00;
STICKLINE(总量>1,总量,0,0.1,0),COLORFFFF00;
STICKLINE(买量>0,0,买量,3,0),COLOR000099;
STICKLINE(买量>0,0,买量,2,0),COLOR0000AA;
STICKLINE(买量>0,0,买量,1,0),COLOR0000FF;
STICKLINE(买量>0,0,买量,0.1,0),COLORCC00FF;
STICKLINE(净量>0,0,净量,3,0),COLOR0033FF;
STICKLINE(净量>0,0,净量,2,0),COLOR0077FF;
STICKLINE(净量>0,0,净量,1,0),COLOR00BBFF;
STICKLINE(净量>0,0,净量,0.1,0),COLOR00FFFF;
STICKLINE(净量<0,1,净量,4,1),COLORFFFF00;
STICKLINE(净量<0,0,净量,3,0),COLOR005500;
STICKLINE(净量<0,0,净量,2,0),COLOR009900;
STICKLINE(净量<0,0,净量,1,0),COLOR00BB00;
STICKLINE(净量<0,0,净量,0.1,0),COLOR00FF00;
STICKLINE(C<MAA AND 净量>0,净量,0,3,0 ),COLOR777777;
STICKLINE(C<MAA AND 净量>0,净量,0,2,0 ),COLOR999999;
STICKLINE(C<MAA AND 净量>0,净量,0,1,0 ),COLORBBBBBB;
STICKLINE(C<MAA AND 净量>0,净量,0,0.1,0 ),COLORFFFFFF;
{倍量成交拐点横线}
STICKLINE(V>=3*REF(V,1),V/3,V/3,3.9,0),COLORWHITE;
STICKLINE(V>=2*REF(V,1),V/2,V/2,3.9,0),COLORYELLOW;
MA5,COLORYELLOW ;
MA35,COLORRED;

通达信量趋势指标公式

 

相关文章