在线检测未来函数

飞狐MACD金叉指标公式

来源:Internet,编辑:股旁网,2011-04-14

SQX:=(C-MA(CLOSE,13))*100;
DIFF:EMA(MA(SQX,7),1),COLORWHITE;
DEA:EMA(DIFF,7),COLORYELLOW;
MACD:(DIFF-DEA)*2,COLORSTICK;
PARTLINE(CROSS(DIFF,DEA) AND DIFF<-0.1,15),COLORYELLOW,LINETHICK4,CROSSDOT;
低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,15,0),COLORYELLOW,LINETHICK0;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
PARTLINE(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28),COLORFF00FF,LINETHICK4,CROSSDOT;
二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28,0),COLORFF00FF,LINETHICK0;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
PARTLINE(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),40),COLORRED,LINETHICK4,CROSSDOT;
背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),40,0),COLORRED,LINETHICK0;
{股旁网-股票公式网站 www.GupaNG.com}
势: DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORGREEN;{,COLORRED;}
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
PARTLINE(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),66),COLORF08000,LINETHICK4,CROSSDOT;
顶背离_:IF(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),66,0),COLORF08000,LINETHICK0;
压: DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFFBB99;
A3:=CROSS(DIFF,DEA) AND DEA<0;
PARTLINE(FILTER(COUNT(A3,21)=2,10),53),COLORWHITE,LINETHICK4,CROSSDOT;
零下二次金叉_:IF(FILTER(COUNT(A3,21)=2,10),53,0),COLORWHITE,LINETHICK0;
DRAWICON(CROSS(DIFF,DEA) ,DIFF,7),ALIGN1;
DRAWICON(CROSS(DEA,DIFF) , DEA,8),ALIGN1;
金叉:if(CROSS(DIFF,DEA),diff,0),color00ff00,stick,linethick1;
{死叉:if(CROSS(DEA,DIFF),diff,0),colorff0099,stick,linethick1;}
选股:二次金叉>0 or 低位金叉>0 or 底背离>0;
0,colorgray;
DRAWICON(二次金叉>0 or 低位金叉>0 or 底背离>0,1,10)

飞狐MACD金叉指标公式

 

相关文章