在线检测未来函数

通达信MACD增强指标公式

来源:Internet,编辑:股旁网,2011-04-15

SHORT:=12;LONG:=26;MID:=9;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD>0 AND REF(MACD,1)>MACD,MACD,0,0,-1),COLORCYAN;
{股旁网-股票公式网站 www.GupaNG.com}
STICKLINE(MACD<0 AND REF(MACD,1)<MACD,MACD,0,0,-1),COLORRED;
COND:= DIF < REF(DIF,1);
COND1:= DIF > REF(DIF,1) AND REF(DIF,1) < REF(DIF,2);
COND2:= DIF < REF(DIF,1) AND REF(DIF,1) > REF(DIF,2);
IF(COND,DIF,DRAWNULL),COLORRED;
IF(COND,DRAWNULL,DIF),COLORGREEN;
DRAWLINE(1,DIF,COND1,DIF,0),COLORYELLOW,LINETHICK3;
DRAWLINE(1,DIF,COND2,DIF,0),COLORRED,LINETHICK3;

通达信MACD增强指标公式

 

相关文章