在线检测未来函数

同花顺K线二分位主图指标公式

来源:Internet,编辑:股旁网,2011-04-21

LL1:LLV(CLOSE,20),LINETHICK2,coloryellow;
HH1:HHV(CLOSE,21),LINETHICK2,coloryellow;
ll2:LLV(CLOSE,9),LINETHICK1,colorwhite;
(HH1+LL1)/2 ,LINETHICK0,colorgreen;
二分位:(H+L)/2 ,LINETHICK3,colorbrown,POINTDOT;
VAR1:=MA(CLOSE,5);
FF:=VAR1>REF(VAR1,1);
PARTLINE(Var1,FF,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK2;
RSV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
X:=REF(J,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
STICKLINE(X,L ,L,20,0),COLOR008888;
STICKLINE(X,L ,H,0,0),COLORFF00FF;
STICKLINE(X,C ,O,5,0),COLORFF00FF;
aa:=CLOSE > REF(CLOSE, 1) AND REF(CLOSE, 1) > REF(CLOSE, 2) AND REF(CLOSE, 1) < REF(CLOSE, 3) AND IF(REF(CLOSE, 3) < REF(CLOSE, 4), 1, IF(REF(CLOSE, 4) < REF(CLOSE, 5),REF(CLOSE, 1) < REF(CLOSE, 4) OR( REF(CLOSE, 2) < REF(CLOSE, 4) AND REF(CLOSE, 3) >= REF(CLOSE, 5) ),IF(REF(CLOSE, 5) < REF(CLOSE, 6), 1,REF(CLOSE, 6) < REF(CLOSE, 7))));
bb:=CLOSE < REF(CLOSE, 1) AND REF(CLOSE, 1) < REF(CLOSE, 2) AND REF(CLOSE, 1) > REF(CLOSE, 3) AND IF(REF(CLOSE, 3) > REF(CLOSE, 4), 1, IF(REF(CLOSE, 4) > REF(CLOSE, 5),REF(CLOSE, 1) > REF(CLOSE, 4) OR( REF(CLOSE, 2) > REF(CLOSE, 4) AND REF(CLOSE, 3) <= REF(CLOSE, 5) ),IF(REF(CLOSE, 5) > REF(CLOSE, 6), 1,REF(CLOSE, 6) > REF(CLOSE, 7))));
DRAWTEXT(aa AND CLOSE>REF(OPEN,2),LOW,'三平底'),color,COLORFF00FF;
DRAWTEXT(bb AND CLOSE<REF(CLOSE,2),HIGH,'三平顶'),color00ff00;
WR:="W&R"(14);
DRAWICON(FILTER(CROSS(WR,(0 - 81)),10),L,4);//威廉买点↑ ↓
DRAWICON(FILTER(CROSS((0 -19),WR),10),H*1.01,5);//威廉卖点
DRAWTEXT(FILTER(CROSS(WR,(0 - 81)),21),L*0.99,'威廉买'),ALIGN0,colorred;//威廉买点
DRAWTEXT(FILTER(CROSS(0 -19,WR),21),H*1.01,'威廉卖'),ALIGN2,colorgreen;//威廉卖点
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
买入线:=IF(CROSS(K,15),100,0);
DRAWTEXT(买入线,L,'←KD底'),colorff00ff;
买出线:=IF(CROSS(K,80),100,0);
DRAWTEXT(买出线,H,'←KD顶'), colorwhite ;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
买入线:=IF(CROSS(RSI1,20),100,0);
DRAWTEXT(买入线,L,'←RSI底'), colorred ;
买出线:=IF(CROSS(RSI1,80),100,0);
DRAWTEXT(买出线,H,'←RSI顶'),colorcyan;

同花顺K线二分位主图指标公式

 

相关文章