在线检测未来函数

飞狐MACD面积指标公式

来源:Internet,编辑:股旁网,2011-04-21

N:=10;
DRAWGBK(c>0,colorrgb(0,0,0),colorrgb(0,0,0),1);
cs:=0.01;
macd:1.5*N/10*slOPE(c,N),colorstick;
STICKLINE(MACD<=REF(MACD,1)AND MACD>0,0,MACD,3,0 ),COLOR00AAFF;
STICKLINE(macd<=REF(macd,1)AND macd>0,0,macd,1.8,0 ),COLOR00BBFF;
STICKLINE(macd<=REF(macd,1)AND macd>0,0,macd,1.3,0 ),COLOR00CCFF;
STICKLINE(macd<=REF(macd,1)AND macd>0,0,macd,1.2,0 ),COLOR00DDFF;
{股旁网-股票公式网站 www.GUpang.com}
STICKLINE(macd<=REF(macd,1)AND macd>0,0,macd,1,0 ),COLOR00EEFF;
STICKLINE(macd<=REF(macd,1)AND macd>0,0,macd,0.5,0 ),COLOR00FFFF;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,3.4,0 ),COLOR0000AA;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,3.2,0),COLOR0011BB;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,3,0),COLOR0022CC;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,2,0),COLOR0033DD;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,1,0),COLOR0044EE;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,0.5,0),COLOR0055FF;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,3.4,0),COLORAA00BB;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,3.2,0),COLORBB11BB;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,3,0),COLORCC22BB;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,2,0 ),COLORDD33BB;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,1,0),COLOREE44BB;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,0.5,0 ),COLORFF55BB;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,3,0 ),COLORFF7700;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,1.5 ,0 ),COLORFF8811;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,1.2,0 ),COLORFFAA22;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,1.0 ,0 ),COLORFFBB33;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,0.8 ,0 ),COLORFFDD44;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,0.5 ,0 ),COLORFFFF55;
BV:=SUM(MACD/cs,0);
BA:=IF(MAX(BV,REF(BV,2))<REF(BV,1) OR MIN(BV,REF(BV,2))>REF(BV,1),1,0);
BC:=BARSLAST(BA)+1;
SMACD:=BV-REF(BV,BC);
var3:=if(macd>0,HHV(abs(macd),bc),LLV(macd,bc));
var4:=(macd)/20;{图形比例缩小1/20,可修改}
var5:=SMACD;
//背离线//
DIFF : EMA(CLOSE,N*12/10) - EMA(CLOSE,N*26/10);
DEA : EMA(DIFF,N*9/10);
drawnumber(ref(var4,1)>0 and var4<=0 ,ref(var3,1),ref(var5,1),0);
drawnumber(ref(var4,1)<0 and var4>=0 ,ref(var3,1),ref(abs(var5),1),0),coloryellow;
drawnumber(islastbar and var4<0,ref(var3,1),abs(var5),0),align2,colorred{,pxup40};
drawnumber(islastbar and var4>0,ref(var3,1),var5,0),align2,colorgreen{,pxdn100};

飞狐MACD面积指标公式

 

相关文章