在线检测未来函数

通达信牛股预测指标公式

来源:Internet,编辑:股旁网,2011-04-29

VAR11:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR11*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR11*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR11*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
AA3:=( EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10);
BB:=AA3>REF(HHV(AA3,60),1);
CC:=HHV(AA3,60);
大底:=FILTER(AA3>10 ,1) ;
预警:STICKLINE(大底>0 AND C<O,30,10,1,0),COLORYELLOW;
{VA1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买1:=IF(CLOSE>OPEN,VA1*(HIGH-LOW),IF(CLOSE<OPEN,VA1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主卖1:=IF(CLOSE>OPEN,0-VA1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VA1*(HIGH-LOW),0-VOL/2));
AA6:=(主买1-(-主卖1))/主买1;};
{第二段 拉升}
ZKK:="KD.K#WEEK"(9,3,3),COLORRED;
ZKD:="KD.D#WEEK"(9,3,3),COLORYELLOW;
KCD:=FILTER(CROSS(ZKK,ZKD) AND REF(ZKD,1)<30,13);
XG1:=KCD;
STICKLINE(XG1,80,10,1,0),COLOR000099;
{股旁网-股票公式网站 www.GUpang.com}
{第三段 旭日东升}
VAR12:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;
VAR13:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100>16;
VAR14:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));
XG2:=VAR12 AND VAR13 AND CROSS(VAR14,79) AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)<0.05 AND VOL>MA(VOL,23);
旭日东升:STICKLINE(XG2,50,10,1,0),COLORFFFFFF;

通达信牛股预测指标公式

 

相关文章