在线检测未来函数

通达信K线解盘主图指标公式

来源:Internet,编辑:股旁网,2011-04-27

M1:=5;M2:=10;M3:=20;M4:=30;
十字星:=CLOSE=OPEN;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
{股旁网-股票公式网站 www.GUpang.com}
出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND
REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(十字星 ,HIGH,'←十字星'),LINETHICK2, COLORYELLOW;
DRAWTEXT(多方炮 ,HIGH,'←多方炮底升中升顶见顶'),LINETHICK2, COLORYELLOW;
DRAWTEXT(出水芙蓉 ,HIGH,'←出水芙蓉'),LINETHICK2, COLORYELLOW;
DRAWTEXT(上升三部曲 ,HIGH,'←上升三部曲'),LINETHICK2, COLORYELLOW;
DRAWTEXT(曙光初现 ,HIGH,'←曙光初现'),LINETHICK2, COLORYELLOW;
MA5:MA(CLOSE,M1),LINETHICK2;
MA10:MA(CLOSE,M2),LINETHICK2;
MA20:MA(CLOSE,M3),LINETHICK2;
MA30:MA(CLOSE,M4),LINETHICK2;
IF(MA5>=REF(MA5,1) AND MA5>=MA10,MA5,DRAWNULL),COLORRED,LINETHICK2;
IF(MA10>=REF(MA10,1) AND MA10>=MA20,MA10,DRAWNULL),COLORRED,LINETHICK2;
IF(MA20>=REF(MA20,1) AND MA20>=MA30,MA20,DRAWNULL),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(MA5,MA10),MA5,'○'),LINETHICK2, COLORYELLOW;
DRAWTEXT(CROSS(MA10,MA20),MA10,'◎'),LINETHICK2, COLORYELLOW;
DRAWTEXT(CROSS(MA20,MA30),MA20,'●'),LINETHICK2, COLORYELLOW;

通达信K线解盘主图指标公式

 

相关文章