在线检测未来函数

大智慧逃顶天王指标公式

来源:Internet,编辑:股旁网,2011-05-02

P1:=34;P2:=55;N:=21;N1:=3;
Var1jo:=IF(DATE<1500830 AND DATE>900101,1,0);
Var2jo:=LLV(LOW,10);
Var3jo:=HHV(HIGH,25);
警戒线:= 2.8*Var1jo;
减仓线:= 3.2*Var1jo;
动力线:=EMA((CLOSE-Var2jo)/(Var3jo-Var2jo)*4,4)*Var1jo;
警戒:if(CROSS(动力线,警戒线),50,60),color000fff;
RC:=C/REF(C,13);
ARC:=SMA(REF(RC,1),13,1);
ARC1:=SMA(REF(RC,1),47,1)+0.04;
卖出1:CROSS(ARC,ARC1)*40,COLOR00ff00,LINETHICK2;
Var3o:=REF(CLOSE,1);
Var4o:=SMA(MAX(CLOSE-Var3o,0),6,1)/SMA(ABS(CLOSE-Var3o),6,1)*100;
卖出a:=CROSS(80,Var4o){,stick};
卖出:if(卖出a,50,2),coloryellow,linethick2;
Z001:=SMA(Vol,5,1);
Z002:=(Z001-llv(Z001,10))/(hhv(Z001,10)-llv(Z001,10))*100;
Z003:=SMA(Z002,3,1);
Z004:=100-Z003;
Z005:=REF(Z004,1)>REF(Z004,2) AND Z004<34;
Z006:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
Z007:=FILTER(Z005,3);
巫山1:=SMA(Z006,3,1){,LINESTICK, COLORBLUE};
山顶1:if(Z007 AND 巫山1>60,30,0),stick,COLORred,LINEThICK7;
cjl10:=if((ma(v,5)/capital)/(ma(v,20)/capital)>1.618,2,1);
cjl20:=if((ma(v,10)/capital)/(ma(v,30)/capital)>1.618,2,1);
cjl40:=if((ma(v,20)/capital)/(ma(v,60)/capital)>2.618,2,1);
cjl60:=if((ma(v,20)/capital)/(ma(v,90)/capital)>3.191,2,1);
cjl120:=if((ma(v,20)/capital)/(ma(v,120)/capital)>3.618,2,1);
cjl250:=if((ma(v,20)/capital)/(ma(v,250)/capital)>4.382,2,1);
cjl1:=cjl10;
cjl2:=cjl10*cjl20;
cjl3:=cjl10*cjl20*cjl40;
cjl4:=cjl10*cjl20*cjl40*cjl60;
cjl5:=cjl10*cjl20*cjl40*cjl60*cjl120;
cjl6:=cjl10*cjl20*cjl40*cjl60*cjl120*cjl250;
price10:=if(c=hhv(c,10),2,1);
price20:=if(hhv(c,5)=hhv(c,20),2,1);
price40:=if(hhv(c,5)=hhv(c,40),2,1);
price60:=if(hhv(c,5)=hhv(c,60),2,1);
price120:=if(hhv(c,5)=hhv(c,120),2,1);
price250:=if(hhv(c,5)=hhv(c,250),2,1);
price1:=price10;
price2:=price10*price20;
price3:=price10*price20*price40;
price4:=price10*price20*price40*price60;
price5:=price10*price20*price40*price60*price120;
price6:=price10*price20*price40*price60*price120*price250;
zhangfu10:=if(c>ma(c,5),2,1);
zhangfu20:=if(c>ma(c,20),2,1);
zhangfu40:=if(c>ma(c,40),2,1);
zhangfu60:=if(c>ma(c,60),2,1);
zhangfu120:=if(c>ma(c,120),2,1);
zhangfu250:=if(c>ma(c,250),2,1);
zhangfu1:=(zhangfu10);
zhangfu2:=(zhangfu10*zhangfu20);
zhangfu3:=(zhangfu10*zhangfu20*zhangfu40);
zhangfu4:=(zhangfu10*zhangfu20*zhangfu40*zhangfu60);
zhangfu5:=(zhangfu10*zhangfu20*zhangfu40*zhangfu60*zhangfu120);
zhangfu6:=(zhangfu10*zhangfu20*zhangfu40*zhangfu60*zhangfu120*zhangfu250);
卖出2:cjl5*price5*zhangfu5/100,colorf0f000,LINETHICK1;
追顶神剑1:="RSI.RSI1"(6,12,24)>78 AND "ROC.ROC"(12,6)<REF("ROC.ROC"(12,6),1) OR "BIAS.BIAS3"(6,12,24)>20{,coloryellow};
追顶神剑:if(追顶神剑1,40,2),linethick2,colorf00ff0;
i:=MA(BARSLAST(HIGH=HHV(HIGH,16))*IF(CLOSE<OPEN,VOL,1),3);
r:=MA(BARSLAST(LOW=LLV(LOW,18))*IF(CLOSE>OPEN,VOL,1),4);
短线逃顶1:=IF(i,0,1){,colorgreen};
短线逃顶:if(短线逃顶1,30,60),linethick2,colorblue;
卖出线:=99;
阶段卖:=90{,COLORCYAN};
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1){,COLORYELLOW};
底部:=10;
警报2: IF(趋势>=90,50,60),COLORf0f000,LINETHICK2;
Vari:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
巫山:=SMA(Vari,5,1)-8{,colorcyan,linethick2};
Varii:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
登山者:=SMA(varii,5,1)-16{,circledot,coloryellow};
山顶2:if(cross(巫山,登山者) and 登山者>=55 and 登山者<70,40,0),stick,colorgreen,LINETHICK7;
山顶3:if(filter(cross(巫山,80),20)=1,50,0),stick,colorwhite,LINETHICK7;
DRAWTEXTABS(5,5,'股旁网 www.gupang.com'),linethick1,COLOR00EEff;
Var1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
Var2:=SMA(Var1,9,1)+100;
Var3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
Var4:=SMA(Var3,3,1);
Var5:=SMA(Var4,3,1)+100;
Var6:=Var5-Var2;
警报1:IF(Var6>100,Var6-100,0),color88b7ea,LINETHICK2;
if(REF(警报1,1)<警报1,警报1,0),pointdot,linethick4,COLOR3399FF;
if(REF(警报1,1)>警报1,REF(警报1,1),0),pointdot,linethick4,COLOR9900ff;
Var1j:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
Var2j:=SMA(Var1j,3,1);
Var3j:=SMA(Var2j,3,1);
Var4j:=Var1j*1.05;
Var6j:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
Var7j:=SMA(Var6j,5,1);
Var9j:=MA(VOL/CAPITAL,30)*MA(VOL,60)/10000+MA(CLOSE,30);
顶:CROSS(Var2j,Var4j) AND Var3j>60 AND Var7j<Var9j+10,colorffcccc,linethick2;
{DRAWICON(顶,20,2)};

大智慧逃顶天王指标公式

 

相关文章