在线检测未来函数

飞狐CCI画线指标公式

来源:Internet,编辑:股旁网,2011-05-02

input:n1(14),n(3),m(8,6,100,1);
LC := REF(CLOSE,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),linethick1;
ty:=cci;
A1:=REF(ty,N)=HHV(ty,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);{高}
A2:=REF(ty,N)=LLV(ty,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);{低}
H1:=(D1 AND NOT(D2)) OR BARSTATUS=2 OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1)); H2:=D1 AND NOT(D2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
R1:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
T1:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}
压一:DRAWLINE(S2,ty,S1,ty,1),COLOR007B00,linethick2; {★压力1:}
撑一:DRAWLINE(U2,ty,U1,ty,1),POINTDOT,COLORFF71FF,linethick2;{★支撑1:}
压二:DRAWLINE(S3,ty,S2,ty,1),COLORFFFF09,linethick2; {★压力2:}
撑二:DRAWLINE(U3,ty,U2,ty,1),POINTDOT,COLORYellow,linethick2;{★支撑2:}
压三:DRAWLINE(S4,ty,S3,ty,1),COLORFF5959,linethick2;{★压力3:}
撑三:DRAWLINE(U4,ty,U3,ty,1),POINTDOT,COLOR4D87FF,linethick2;{★支撑3:};
{CCI画线}
//短期压力:DRAWLINE(CCI>=HHV(CCI,10),CCI,CCI& lt;=LLV(CCI,3),HHV(CCI,3),1),COLORFFACAC;{淡蓝线飞狐不过,下面代替}
//短期支撑:DRAWLINE(CCI<=LLV(CCI,10),CCI,CCI& gt;=HHV(CCI,3),LLV(CCI,3),1),COLORWHITE;{白线飞狐不过,下面代替};
{股旁网-股票公式网站 www.GUpang.com}
em10:ema(cci,10),color07ecee;
em20:ema(cci,20),color00c500;stickline(cross(cci,em10),-198,-160,2,0),color8000ff;{金叉画线}
stickline(cross(em10,cci),198,160,2,0),color00ff00;{死叉画线}
stickline(cross(em10,em20),0+15,0-15,1,0);
stickline(cross(em20,em10),0+15,0-15,1,0);上影线:h-max(o,c),linethick0,colorff00ff;
下影线:min(o,c)-l,linethick0,color00ff00;
高低:h-l,linethick0,colorc0c0c0;
实体:c-o,linethick0,colorffffff;200,color00ff00;
100,colorwhite, pointdot;
0,color8000ff;
-100,colorwhite, pointdot;
-200,color00ff00;
{前期高低点——虚线}
QS:=HHV(cci,13);
RS:=llV(cci,13);
Var1:=BACKSET(REF(QS,2)=HHV(QS,5),3);
Var2:=CROSS(Var1,0.9);
Var3:=BACKSET(REF(RS,2)=LLV(RS,5),3);
Var4:=CROSS(Var3,0.9);
压力:REF(QS,BARSLAST(Var2)),POINTDOT,Color00ff00;
STICKLINE(cci,REF(QS,BARSLAST(Var2)),REF(QS,BARSLAST(Var2)),5,0),Color00ff00;
支撑:REF(RS,BARSLAST(Var4)),POINTDOT,COLORFF71FF{Color0087FF};
STICKLINE(cci,REF(RS,BARSLAST(Var4)),REF(RS,BARSLAST(Var4)),5,0),Color0087FF;
{RSI线变色}
PARTLINE(cci>REF(cci,1),cci),linethick2;
PARTLINE(cci<REF(cci,1),cci),linethick2;
{右边▲▼--只是比较与前一日的大小,无判断方面的意义}
LC111:=REF(CLOSE,1);
RS1:=SMA(MAX(CLOSE-LC111,0),M,1)/SMA(ABS(CLOSE-LC111),M,1)*100;
ATR:=MA(MAX(MAX((RS1-RS1),ABS(REF(RS1,1)-RS1)),ABS(REF(RS1,1)-RS1)),15);
VM:=MA(RS1,N1);
DRAWTEXT(BARSTATUS=2 and cci>REF(cci,1),Vm,' ▲'),COLORRED,LINETHICK2;
DRAWTEXT(BARSTATUS=2 and cci<REF(cci,1),Vm,' ▼'),COLOREEEE00,LINETHICK2;
{笑脸+哭脸【无未来函数】}
OBV:=cci;
DRAWICON(D1,OBV{*1.05},2);{哭脸}
DRAWICON(D2,OBV,1);{笑脸}
{顶底柱【副图】无未来函数}
N11:=9;
M11:=3;
快线:(CLOSE- LLV(LOW,N11))/(HHV(HIGH,N11)-LLV(LOW,N11))*100,COLORRED,LINETHICK0;
慢线:SMA(快线,M11,1),LINETHICK0;
BB:=IF(BARSLAST(CROSS(慢线,快线))>=3 AND CROSS(快线,慢线) AND 慢线<30,20,0);
STICKLINE(BB,-30,-55,7,1),COLORYellow,linethick3;{抄底--黄柱}
DRAWTEXT(BB>0,50,'B'),COLORF5F5F5,LINETHICK6;
AA:=IF(BARSLAST(CROSS(快线,慢线))>=4 AND CROSS(慢线,快线) AND 快线>50,20,0);
STICKLINE(AA,60,35,7,1),COLOR00FF00,linethick3;{逃顶--緑柱};
DRAWTEXT(AA>0,45,'S'),COLORF5F5F5,LINETHICK6;

飞狐CCI画线指标公式

 

相关文章