在线检测未来函数

通达信RSI突破指标公式

来源:Internet,编辑:股旁网,2011-05-05

N:=10;N1:=8;N2:=12;N3:=24;
ARSI:="RSI.RSI1#WEEK",COLOR5588AA;
BRSI:="RSI.RSI2#WEEK",COLOR00AACC;
CRSI:="RSI.RSI3#WEEK",COLOR77EE00;
STICKLINE(BRSI<CRSI,CRSI,RSI+1,0,1),COLOREEDD00;
STICKLINE(BRSI>=CRSI,CRSI,RSI+1,0,1),COLOR0000BB;
CCRSI:"RSI.RSI3#WEEK",COLORFF0000,LINETHICK2;
XJL:=LLV((REF(RSI,11)+REF(RSI,9)+REF(RSI,7)+REF(RSI,5)+REF(RSI,3)+REF(RSI,1))/6,12);
XJH:=HHV((REF(RSI,11)+REF(RSI,9)+REF(RSI,7)+REF(RSI,5)+REF(RSI,3)+REF(RSI,1))/6,12);
XX:MA((XJL+XJH)/2,2),COLOR777777,LINETHICK1;
LC:=REF(CLOSE,1);
RSI2:SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100,COLOR00DDEE,LINETHICK2;
RSI3:=SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100,COLORCC0000,LINETHICK1;
RSI1:SMA(MAX(C-LC,0),N1,1)/SMA(ABS(C-LC),N1,1)*100,COLOR0000FF,LINETHICK2;
{股旁网-股票公式网站 www.GUpang.com}
卖:IF(PEAKBARS(3,15,1)=1,65,88),COLORFF0000,LINETHICK2;
买:IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,35,12),COLORAA00FF,LINETHICK2;
周CK:="KDJ.K#WEEK";
周CD:="KDJ.D#WEEK";
突破周:=STICKLINE(周CK>=周CD,21,19,3,1),COLOR0066DD;
费氏数:=BACKSET(REF(LOW,1)=LLV(LOW,60),1);
成立距今:=BARSLAST(费氏数=1);
数L:DRAWTEXT((成立距今=7 OR 成立距今=12 OR 成立距今=20 OR 成立距今=33 OR 成立距今=54),
89,'ω'),COLOREEEEEE;
费氏数H:=BACKSET(REF(HIGH,1)=HHV(HIGH,100),1);
成立距今H:=BARSLAST(费氏数H=1);
费氏神奇数:=0;
数H:DRAWTEXT((成立距今H=7 OR 成立距今H=12 OR 成立距今H=20 OR 成立距今H=33 OR 成立距今H=54
OR 成立距今H=88),88,'H'),COLOR0000FF;
HRSI:=HHV("RSI.RSI1#WEEK",2);
叉下:IF((RSI1<XX) OR HRSI<=CRSI OR HRSI<=BRSI,RSI1,DRAWNULL),COLORCCCCEE,LINETHICK2;
叉△:=DRAWTEXT(CROSS(RSI2,XX) AND VOL/REF(VOL,1)>1.2,XX,'△'),COLORFFFF00;
金叉RSI:STICKLINE(CROSS("RSI.RSI2#WEEK","RSI.RSI3#WEEK"),88,12,0.6,0),COLOR0000FF;
下买:=DRAWTEXT((CROSS(ARSI,XX) AND CROSS(HRSI,BRSI)) OR CROSS(BRSI,CRSI) OR CROSS(ARSI,CRSI)
,40,'☆下买'),COLOR0099FF;
动感RSI:HHV("RSI.RSI1#WEEK",2),COLORBB00CC;
VARA:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;
DRAWTEXT(DATE>700101 AND CROSS(79,VARE),88,'R高'),COLOR00FF00;
ARSI下:STICKLINE(HRSI<=CRSI,HRSI,CRSI,0.1,1),COLOR00CC00,LINETHICK1;
VAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:=EMA(VAR1,13)-EMA(VAR1,73);
SD:=EMA(SK,2);
DRAWTEXT((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) OR 金叉RSI,38,'突破'),COLOR00FFBB;

通达信RSI突破指标公式

 

相关文章