在线检测未来函数

通达信趋势MACD指标公式

来源:Internet,编辑:股旁网,2011-05-05

A1:=EMA((EMA(CLOSE,1)+EMA(CLOSE,3)+EMA(CLOSE,5))/3,5),COLOR0055FF;
A2:=EMA((EMA(CLOSE,3)+EMA(CLOSE,5)+EMA( CLOSE,7))/3,5),COLOR0055FF;
A3:=EMA((EMA(CLOSE,5)+EMA(CLOSE,7)+EMA( CLOSE,9))/3,5),COLOR0055FF;
A4:=EMA((EMA(CLOSE,7)+EMA(CLOSE,9)+EMA( CLOSE,11))/3,5),COLOR0055FF;
A5:=EMA((EMA(CLOSE,9)+EMA(CLOSE,11)+EMA( CLOSE,13))/3,5),COLOR0055FF;
A6:=EMA((EMA(CLOSE,11)+EMA(CLOSE,13)+EMA( CLOSE,15))/3,5),COLOR0055FF;
A7:=EMA((EMA(CLOSE,13)+EMA(CLOSE,15)+EMA( CLOSE,17))/3,5),COLOR0055FF;
A8:=EMA((EMA(CLOSE,15)+EMA(CLOSE,17)+EMA( CLOSE,19))/3,5),COLOR0055FF;
A9:=EMA((EMA(CLOSE,17)+EMA(CLOSE,19)+EMA( CLOSE,21))/3,5),COLOR0000FF;
A10:=EMA((EMA(CLOSE,19)+EMA(CLOSE,21)+EMA( CLOSE,23))/3,5),COLOR0000FF;
A11:=EMA((EMA(CLOSE,21)+EMA(CLOSE,23)+EMA( CLOSE,25))/3,5),COLOR0000FF;
A12:=EMA((EMA(CLOSE,23)+EMA(CLOSE,26)+EMA(CLOSE,29))/3,5),COLOR0000FF;
AA:=(A1+A2+A3+A4+A5+A6)/6;
BB:=(A7+A8+A9+A10+A11+A12)/6;
{股旁网-股票公式网站 www.GUpang.com}
多空线1:=(AA+BB)/2,COLORBBBBBB,LINETHICK2;
A81:=MA(EMA(CLOSE,12),1),COLOR0000EE;
A82:=MA(EMA(CLOSE,12),3),COLOR0000EE;
A83:=MA(EMA(CLOSE,12),5),COLOR0000EE;
A84:=MA(EMA(CLOSE,12),7),COLOR0000EE;
A85:=MA(EMA(CLOSE,12),9),COLOR0000EE;
A86:=MA(EMA(CLOSE,12),11),COLOR0000EE;
A87:=MA(EMA(CLOSE,12),13),COLOR0000EE;
A88:=MA(EMA(CLOSE,60),1),COLOR33CC00;
A89:=MA(EMA(CLOSE,60),3),COLOR33CC00;
A90:=MA(EMA(CLOSE,60),5),COLOR33CC00;
A91:=MA(EMA(CLOSE,60),7),COLOR33CC00;
A92:=MA(EMA(CLOSE,60),9),COLOR33CC00;
A93:=MA(EMA(CLOSE,60),11),COLOR33CC00;
A94:=MA(EMA(CLOSE,60),13),COLOR33CC00;
多空A:=(A81+A82+A83+A84+A85+A86+A87)/7;
多空B:=(A88+A89+A90+A91+A92+A93+A94)/7;
多空线2:=(多空A+多空B)/2,COLOR0088CC;
DEF1:=EMA(EMA(多空线1-REF(多空线1,1),3),5);
DEF2:=EMA(EMA(多空线2-REF(多空线2,1),3),5);
STICKLINE(DEF1>=0 ,0,DEF1,2,1),COLOR0000AA;
STICKLINE(DEF1>=0 AND DEF1>=(REF(DEF1,1)+REF(DEF1,2))/2,0,DEF1,2,1),COLOR0000FF;
STICKLINE(DEF1<=0,0,DEF1,2,1),COLORFF9900;
DIFFR:EMA(CLOSE,9)- EMA(CLOSE,12),COLOR00FF00,LINETHICK2;
DEAR:EMA(DIFFR,24),COLORFFFFFF,LINETHICK1;
MACM:=2*(DIFFR-DEAR),LINETHICK1;
MACDR:=2*(DIFFR-DEAR),COLORSTICK;
DIFF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIFF1,27); MACD1:=2*(DIFF1-DEA1);
MACM1:=2*(DIFF1-DEA1);
BBM:=CROSS(DIFF1,DEA1) AND CROSS(MACM1,DEA1);
DEA2:=EMA(DIFF1,9);
MACD2:=2*(DIFF1-DEA2);
BAK:=CROSS(DIFFR,DEAR) AND CROSS(MACDR,DEAR) AND MACDR>DIFFR AND DIFFR>0;
DRAWTEXT(BAK,DEAR,'☆MM'),COLOR00FFFF;
DIF:=EMA(EMA((H+L)/2,8)-EMA((H+L)/2,13),13);
DDIF:=EMA(EMA(C,8)-EMA(C,13),13);
MD:=EMA(EMA(DDIF,5),5),COLOR58FF58;
DEF:=2*(DIF-MD),COLORFFFF00,LINETHICK0;
拉升:IF(DEF>REF(DEF,1) OR DIFFR>=(REF(DIFFR,1)+REF(DIFFR,2))/2,DIFFR,DRAWNULL),COLOR8800FF,LINETHICK2;
SG1:=EMA(HHV(HIGH,1),11);
金R:="RSI.RSI1#WEEK">="RSI.RSI2#WEEK";
SS:=CROSS(HIGH,SG1) AND 金R AND CROSS(CLOSE,A6) AND CROSS(CLOSE,A7) AND CROSS(CLOSE,多空线1) ;
走强:STICKLINE(SS AND C>O AND C>O AND VOL/REF(VOL,1)>=1.3,0.08,-0.08,3,1),COLOR00DDEE;
多A:=STICKLINE(CROSS(C,多空线2) AND 多空线2>=REF(多空线2,1) AND
VOL/REF(VOL,1)>=1.28 AND (C-REF(C,1))/REF(C,1)>=0.02,-0.09,0.09,1,0),COLOR0000FF;
多B:DRAWICON(CROSS(C,多空线1) AND 多空线1>REF(多空线1,1) AND
VOL/REF(VOL,1)>=1.28 AND (C-REF(C,1))/REF(C,1)>=0.03,0,5);
费氏数:=BACKSET(REF(HIGH,1)=HHV(HIGH,150),1);
成立距今:=BARSLAST(费氏数=1);
费氏神奇数:=0;
DRAWTEXT(成立距今=12,DIFFR,'13'),COLORFFFFFF;
DRAWTEXT(成立距今=20,DIFFR,'21'),COLORFFFFFF;
DRAWTEXT(成立距今=33,DIFFR,'34'),COLORFFFFFF;
DRAWTEXT(成立距今=54,DIFFR,'55'),COLORFFFFFF;
DRAWTEXT(成立距今=88,DIFFR,'89'),COLORFFFFFF;
DRAWTEXT(成立距今=143,DIFFR,'144'),COLORFFFFFF;
费氏数L:=BACKSET(REF(LOW,1)=LLV(LOW,100),1);
成立距今L:=BARSLAST(费氏数L=1);
数L:DRAWTEXT((成立距今L=7 OR 成立距今L=12 OR 成立距今L=20 OR 成立距今L=33),0,'L'),COLOR00FFFF;

通达信趋势MACD指标公式

 

相关文章