在线检测未来函数

通达信大额分析指标公式

来源:Internet,编辑:股旁网,2011-05-15

L1:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
龙K:=SMA(L1,3,1)*100,COLORBBFFBB;
凤D:=SMA(龙K,3,1),COLORBBFFBB;
NN:=120;
HH:=HHV(AMOUNT,NN);
LL:=LLV(AMOUNT,NN);
最高:=CONST(HH);
最低:=CONST(LL);
RCC:=最高*0.9-(最高-最低)*0.5;
RHL:=RCC;
HLMAX:=最高;
HLMIN:=最低;
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
DRAWBAND(((龙K-HLMN3)*HLMN2/HLMN4+HLMN1),RGB(80,80,20),((凤D-HLMN3)*HLMN2/HLMN4+HLMN1),RGB(50,80,20));
TTT:=IF(ISLASTBAR,240/FROMOPEN,1);
HLP:=SMA(WINNER(C)*100,3,1),COLOR2588FF,LINETHICK0;
TJ:=FILTER(C,239)>0,NODRAW;
TJJ:=SUM(TJ,0),NODRAW;
LTA:=FINANCE(7)+300000000;
C1:=CLOSE;
V1:=TIME;
A1:=COUNT(BARSCOUNT(C)=1 AND TIME<102000 ,0 );
T:=IF(V1<130000,(FLOOR(V1/10000)-9.5)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000)),
(FLOOR(V1/10000)-11)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000))),NODRAW;
成交:=AMOUNT,NODRAW;
总_亿OR百万:=SUM(AMOUNT,T)/1000000,NODRAW;
总亿OR万:总_亿OR百万*100;
VV3:=总_亿OR百万*1000000/T;
SS:=IF(CAPITAL>150000000,0.3,IF(CAPITAL>20000000,0.5,IF(CAPITAL>10000000,0.8,IF(CAPITAL<200000,5,IF(CAPITAL<1000000,3,
IF(CAPITAL<5000000,1.5,1)))))),NODRAW;
VV5:=(REF(VV3,T-1)/CEILING(REF(VV3,T-1)/CAPITAL *10000+0.1))*SS,NODRAW;
大额线:=IF(REF(VV3,T)=REF(VV3,T-1),VV5,REF(VV3,T)),NODRAW;
线位:大额线/10000,NODRAW;
{股旁网-股票公式网站 www.GUpang.com}
初正1:=IF(T=1 AND DYNAINFO(4)>=DYNAINFO(3),总_亿OR百万*1000000,0);
初负1:=IF(T=1 AND DYNAINFO(4)<DYNAINFO(3),总_亿OR百万*1000000,0);
初正:=CONST(SUM(IF(初正1>=大额线 AND T=1,初正1,0),T)),NODRAW;
初负:=CONST(SUM(IF(初负1>=大额线 AND T=1,初负1,0),T)),NODRAW;
初正2:=CONST(SUM(IF(初正1<大额线 AND T=1,初正1,0),T)),NODRAW;
初负2:=CONST(SUM(IF(初负1<大额线 AND T=1,初负1,0),T)),NODRAW;
T00:=IF(C1>REF(C1,1),0.9,-0.9);
T01:=IF(C1<REF(C1,1),-0.9,0.9);
T02:=T00+T01,NODRAW;
TT1:=BARSLAST(CROSS(T02,+1.5)),NODRAW;
TT2:=BARSLAST(CROSS(-1.5,T02)),NODRAW;
TT:=IF(T02=1.8,1,IF(T02=-1.8,-1,0));
正V1:=IF(TT=1 OR (TT=0 AND TT1<TT2),成交,0),NODRAW;
负V1:=IF(TT=-1 OR (TT=0 AND TT1>TT2),成交,0),NODRAW;
正负0:=IF(成交!= 0 AND (正V1=0 AND 负V1=0),成交,0);
正V0:=IF(正负0!= 0 AND REF(正V1,1)!= 0 ,正负0,0);
负V0:=IF(正负0!= 0 AND REF(负V1,1)!= 0 ,正负0,0);
正V11:=正V1+正V0;
负V11:=负V1+负V0;
正总1:=初正1+SUM(正V11,T),NODRAW,COLOR0000FF;
负总1:=初负1+SUM(负V11,T),NODRAW,COLOR00FF00;
正V:=IF(正V11>=大额线,正V11,0);
负V:=IF(负V11>=大额线,负V11,0);
正V2:=IF(正V11<大额线,正V11,0);
负V2:=IF(负V11<大额线,负V11,0);
大正总:=(IF(TJJ<2,初正,0)+SUM(正V,T))/1000000,NODRAW,COLOR0000FF;
大负总:=(IF(TJJ<2,初负,0)+SUM(负V,T))/1000000,NODRAW,COLOR00FF00;
大净:(大正总-大负总),NODRAW;
差%:(大正总-大负总)/(大正总+大负总)*100,COLOR00FF00,NODRAW;
正总2:=IF(TJJ<2,初正2,0)+SUM(正V2,T),NODRAW,COLOR0000FF;
负总2:=IF(TJJ<2,初负2,0)+SUM(负V2,T),NODRAW,COLOR00FF00;
小净:(正总2-负总2)/10000,NODRAW;
小差%:(正总2-负总2)/(正总2+负总2)*100,COLOR00FF00,NODRAW;
大额线*100,COLOR00FFFF;
STICKLINE(TT=1 OR 正V0!= 0,0,AMOUNT*100,1,1),COLOR0000FF;
STICKLINE(TT=-1 OR 负V0!= 0,0,AMOUNT*100,1,0),COLOR00FF00;
STICKLINE(TT=0 AND TT1<TT2,0,AMOUNT*100,1,1),COLOR00FFFF;
STICKLINE(TT=0 AND TT1>TT2,0,AMOUNT*100,1,0),COLORFF0000;
STICKLINE(正V>大额线,0,AMOUNT*100,1,1),COLORFF00FF;
STICKLINE(负V>大额线,0,AMOUNT*100,1,0),COLORFFFFFF;
STICKLINE(T=1 AND 初正1>0,0,初正1*100,1,0),COLOR00FFFF;
STICKLINE(T=1 AND 初负1>0,0,初负1*100,1,0),COLORFF0000;
STICKLINE(T=1 AND 初正>0,0,初正*100,1,0),COLORFF00FF;
STICKLINE(T=1 AND 初负>0,0,初负*100,1,0),COLORFFFFFF;

通达信大额分析指标公式

 

相关文章