在线检测未来函数

通达信必胜晴空指标公式

来源:Internet,编辑:股旁网,2011-05-16

STICKLINE(100,100,0,10,0),COLORFFB900,LINETHICK7;
VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
S:=SMA(VAR1,5,1),COLORRED;
VAR2:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
X:SMA(VAR2,2,1),COLORFF00FF ;
VR4:=SMA(ABS(L-REF(L,1)),13,1)/SMA(MAX(L-REF(L,1),0),13,1);
底部动量:IF(EMA(IF(L<=LLV(L,30),VR4,0),3)*10<100,EMA(IF(L<=LLV(L,30),VR4,0),3)*10,100),COLOR004DF5;
AA:=INTPART(底部动量);
DD:=IF(AA>REF(HHV(AA,120),1),AA,0);
VR2:=LLV(LOW,10);
VR3:=HHV(HIGH,25);
动力线:=IF(EMA((CLOSE-VR2)/(VR3-VR2)*4,4)*25<100,EMA((CLOSE-VR2)/(VR3-VR2)*4,4)*25,100),COLORYELLOW,LINETHICK1;
STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),4 ,0),COLORRED;
STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),4 ,1),COLOR00FF00;
CDP :=(HIGH + LOW + 2*CLOSE)/4;
买入价:(2*CDP-HIGH),COLORRED , LINETHICK0 ;
卖出价:(2*CDP-LOW) ,COLORWHITE, LINETHICK0 ;
VAR3:=1/WINNER(CLOSE);
VAR4:=EMA(CLOSE,13);
VAR5:=100-ABS((CLOSE-VAR4)/VAR4)*100,COLORGREEN;
黄金坑:=(100-IF(VAR3>10,IF(VAR3<100,VAR3,VAR5-90),0)),COLORGREEN,POINTDOT;
70,POINTDOT;
30,POINTDOT,COLORFF00FF ;
VAR1A:=WINNER(CLOSE);
VAR2A:=VOL/CAPITAL;
VAR3A:=VAR2A/VAR1A;
{两线重叠时间越长越好}
JJ:=IF(VAR1A<50/100 ,VAR3A,0)*100;
财神线:=IF(JJ<100,JJ,0),COLORYELLOW;
{STICKLINE(1,黄金坑,100,1,0)POINTDOT,COLORGREEN;}
STICKLINE(黄金坑<=100,100,黄金坑,0.0005,0),POINTDOT,COLOR00FFFF;
STICKLINE(财神线>=0,0,{财神线}底部动量,0.0005,0),POINTDOT,,COLOR00FFFF;
{股旁网-股票公式网站 www.GUpang.com}
JHH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);
STICKLINE(ABS(JHH/WINNER(C))>1000000000,0,0,0,0),COLORFF00FF,LINETHICK5;
DRAWTEXT((S-X)>=70 AND X<7,10,'★'),COLORRED;
VARC:=CLOSE*50/100;
VARD:=MA(VARC,30)*0.83;
VARE:=MA(VARC/VARD,3);
DRAWTEXT(FILTER(VARE<1.04,3),10,'★'),COLORYELLOW ;
DRAWTEXT(CROSS(X,底部动量) AND 动力线>REF(动力线,1) AND C>L*1.03,100,'★'),COLORGREEN;
DRAWTEXT(X>动力线*2 AND X>=80,90,'●');

通达信必胜晴空指标公式

 

相关文章