在线检测未来函数

飞狐量能平台主图指标公式

来源:Internet,编辑:股旁网,2011-05-21

CCC:=CLOSE;
HHH:=HIGH;
LLL:=LOW;
VVV:=VOL;
OOO:=OPEN;
IF SYSPARAM(1)>=300 THEN Begin
XX:=SETLBOUND(CCC,SYSPARAM(1)-299);
XX:=SETLBOUND(HHH,SYSPARAM(1)-299);
XX:=SETLBOUND(LLL,SYSPARAM(1)-299);
XX:=SETLBOUND(VVV,SYSPARAM(1)-299);
XX:=SETLBOUND(OOO,SYSPARAM(1)-299);
End;
Nt1:=IF(SYSPARAM(1)-120+1>1,SYSPARAM(1)-120+1,0);
Nt2:=SYSPARAM(1);
PosHH:=vVV;
xs:=SORTPOS(PosHH, 1, Nt1, Nt2);
筹码1:=SYSPARAM(1)-PosHH[Nt1];
筹码2:=SYSPARAM(1)-PosHH[Nt1+1];
as1:=NUMTOSTR(SYSPARAM(1)-PosHH[Nt1], 0);
平台上:=REF(HHH,筹码1);
平台下:=REF(LLL,筹码1);
平台:=REF((HHH+LLL+3*CCC)/5,筹码1);
A1:=REF(HHH-(HHH-LLL)*0.1,筹码1);
A2:=REF(HHH-(HHH-LLL)*0.2,筹码1);
A3:=REF(HHH-(HHH-LLL)*0.3,筹码1);
A4:=REF(HHH-(HHH-LLL)*0.4,筹码1);
A5:=REF(HHH-(HHH-LLL)*0.5,筹码1);
A6:=REF(HHH-(HHH-LLL)*0.6,筹码1);
A7:=REF(HHH-(HHH-LLL)*0.7,筹码1);
A8:=REF(HHH-(HHH-LLL)*0.8,筹码1);
A9:=REF(HHH-(HHH-LLL)*0.9,筹码1);
DRAWTEXT(SYSPARAM(1)=BARPOS,平台上,'﹌﹌﹌'),ALIGN2,colorbbbbFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,A1,'﹌﹌﹌﹌﹌﹌'),ALIGN2,color22FFFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,A2,'﹌﹌﹌﹌﹌﹌﹌﹌﹌'),ALIGN2,color22FFFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,A3,'﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌'),ALIGN2,color22FFFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,A4,'﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌'),ALIGN2,color22FFFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,A5,'﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌'),ALIGN2,color22ffff;
DRAWTEXT(SYSPARAM(1)=BARPOS,A6,'﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌'),ALIGN2,color22FFFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,A7,'﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌'),ALIGN2,color22FFFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,A8,'﹌﹌﹌﹌﹌﹌﹌﹌﹌'),ALIGN2,color22FFFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,A9,'﹌﹌﹌﹌﹌﹌'),ALIGN2,color22FFFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,平台下,'﹌﹌﹌'),ALIGN2,colorbbbbFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,平台,as1+'周期﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌'),ALIGN2,colorbbbbFF;
台上:=REF(Hhh,筹码2);
台下:=REF(Lll,筹码2);
台:=REF((HHH+LLL+3*CCC)/5,筹码2);
A11:=REF(HHH-(HHH-LLL)*0.1,筹码2);
A21:=REF(HHH-(HHH-LLL)*0.2,筹码2);
A31:=REF(HHH-(HHH-LLL)*0.3,筹码2);
A41:=REF(HHH-(HHH-LLL)*0.4,筹码2);
A51:=REF(HHH-(HHH-LLL)*0.5,筹码2);
A61:=REF(HHH-(HHH-LLL)*0.6,筹码2);
A71:=REF(HHH-(HHH-LLL)*0.7,筹码2);
A81:=REF(HHH-(HHH-LLL)*0.8,筹码2);
A91:=REF(HHH-(HHH-LLL)*0.9,筹码2);
as2:=NUMTOSTR(筹码2, 0);
DRAWTEXT(SYSPARAM(1)=BARPOS,台上,'﹌﹌﹌'),ALIGN2,colorbbbbFF;
DRAWTEXT(SYSPARAM(1)=BARPOS ,A11,'﹋'),ALIGN2,colorFF00;
DRAWTEXT(SYSPARAM(1)=BARPOS,A21,'﹋﹋﹋'),ALIGN2,colorFF00;
DRAWTEXT(SYSPARAM(1)=BARPOS,A31,'﹋﹋﹋﹋﹋﹋'),ALIGN2,colorFF00;
DRAWTEXT(SYSPARAM(1)=BARPOS,A41,'﹋﹋﹋﹋﹋﹋﹋﹋﹋'),ALIGN2,colorFF00;
DRAWTEXT(SYSPARAM(1)=BARPOS,A51,'﹋﹋﹋﹋﹋﹋﹋﹋﹋﹋﹋﹋'),ALIGN2,colorFF00;
DRAWTEXT(SYSPARAM(1)=BARPOS,A61,'﹋﹋﹋﹋﹋﹋﹋﹋﹋'),ALIGN2,colorFF00;
DRAWTEXT(SYSPARAM(1)=BARPOS,A71,'﹋﹋﹋﹋﹋﹋'),ALIGN2,colorFF00;
DRAWTEXT(SYSPARAM(1)=BARPOS,A81,'﹋﹋﹋'),ALIGN2,colorFF00;
DRAWTEXT(SYSPARAM(1)=BARPOS,A91,'﹋'),ALIGN2,colorFF00;
DRAWTEXT(SYSPARAM(1)=BARPOS,台下,'﹌﹌﹌'),ALIGN2,colorbbbbFF;
DRAWTEXT(SYSPARAM(1)=BARPOS,台,as2+'周期﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌﹌'),ALIGN2,colorbbbbFF;
B1:='^^^^^^^^^^^^^^^^^^^^^^^^';
DRAWTEXT(VOL=HHV(VOL,20),CLOSE ,B1),color00FFCC;
十天买卖:EMA(REF(CLOSE,1),2),COLORFFCC00,LINETHICK1;
十天压力:HHV(十天买卖,13),COLOR00FF00,LINETHICK1;
十天支撑:LLV(十天买卖,13),Color00FFFF,LINETHICK1;
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
压力位:IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J)))),color0000FF;
支撑位:IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24)))),colorFF0000;
{股旁网-股票公式网站 www.GUpang.com}
价在线下:=CLOSE<十天买卖;
STICKLINE(价在线下 ,CLOSE ,OPEN,7.5,0 ),COLORff7700;
STICKLINE(价在线下 ,CLOSE ,OPEN,6,0 ),COLORff9900;
STICKLINE(价在线下 ,CLOSE ,OPEN,5,0 ),COLORffbb00;
STICKLINE(价在线下,CLOSE ,OPEN,4,0 ),COLORffcc00;
STICKLINE(价在线下,CLOSE ,OPEN,3,0 ),COLORffdd00;
STICKLINE(价在线下 ,CLOSE ,OPEN,2,0 ),COLORffee00;
STICKLINE(价在线下,CLOSE ,OPEN,1,0 ),COLORffff00;
价在线上:=CLOSE>=十天买卖;
STICKLINE(价在线上,CLOSE,OPEN,7.5,0) ,COLOR000055;
STICKLINE(价在线上,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(价在线上,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(价在线上,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(价在线上,CLOSE,OPEN,3,0) ,COLOR0000bb;
STICKLINE(价在线上,CLOSE,OPEN,2,0) ,COLOR0000dd;
STICKLINE(价在线上,CLOSE,OPEN,1,0) ,COLOR0000ff;
收小于开:=CLOSE>=十天买卖 and CLOSE<OPEN;
STICKLINE(收小于开,OPEN,(OPEN+CLOSE)/2,7.5,0),colorff11ff;
STICKLINE(收小于开,OPEN,(OPEN+CLOSE)/2,6,0),colorff33ff;
STICKLINE(收小于开,OPEN,(OPEN+CLOSE)/2,5,0),colorff55ff;
STICKLINE(收小于开,OPEN,(OPEN+CLOSE)/2,4,0),colorff77ff;
STICKLINE(收小于开,OPEN,(OPEN+CLOSE)/2,3,0),colorff99ff;
STICKLINE(收小于开,OPEN,(OPEN+CLOSE)/2,2,0),colorffbbff;
STICKLINE(收小于开,OPEN,(OPEN+CLOSE)/2,1,0),colorffddff;
收大于开:=CLOSE<十天买卖 and CLOSE>OPEN;
STICKLINE(收大于开,CLOSE,(OPEN+CLOSE)/2,7.5,0),color333333;
STICKLINE(收大于开,CLOSE,(OPEN+CLOSE)/2,6,0),color555555;
STICKLINE(收大于开,CLOSE,(OPEN+CLOSE)/2,5,0),color777777;
STICKLINE(收大于开,CLOSE,(OPEN+CLOSE)/2,4,0),color999999;
STICKLINE(收大于开,CLOSE,(OPEN+CLOSE)/2,3,0),colorbbbbbb;
STICKLINE(收大于开,CLOSE,(OPEN+CLOSE)/2,2,0),colordddddd;
STICKLINE(收大于开,CLOSE,(OPEN+CLOSE)/2,1,0),colorffffff;
LL:=LLV(CLOSE,100);
TJ:=IF((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.025,1,0);
平台支撑:=IF(CLOSE>REF(OPEN,BARSLAST(TJ =1)),REF(OPEN,BARSLAST(TJ =1)),0);
STICKLINE(平台支撑,CLOSE,(OPEN+CLOSE)/2,7.5,0),color005555;
STICKLINE(平台支撑,CLOSE,(OPEN+CLOSE)/2,6,0),color006666;
STICKLINE(平台支撑,CLOSE,(OPEN+CLOSE)/2,5,0),color007777;
STICKLINE(平台支撑,CLOSE,(OPEN+CLOSE)/2,4,0),color009999;
STICKLINE(平台支撑,CLOSE,(OPEN+CLOSE)/2,3,0),color00bbbb;
STICKLINE(平台支撑,CLOSE,(OPEN+CLOSE)/2,2,0),color00dddd;
STICKLINE(平台支撑,CLOSE,(OPEN+CLOSE)/2,1,0),color00ffff;

平台压力:=IF(CLOSE<OPEN and REF(CLOSE,1)>REF(OPEN,1),REF(CLOSE,1),0);
STICKLINE(平台压力,OPEN,(OPEN+CLOSE)/2,7.5,0),color003300;
STICKLINE(平台压力,OPEN,(OPEN+CLOSE)/2,6,0),color005500;
STICKLINE(平台压力,OPEN,(OPEN+CLOSE)/2,5,0),color007700;
STICKLINE(平台压力,OPEN,(OPEN+CLOSE)/2,4,0),color009900;
STICKLINE(平台压力,OPEN,(OPEN+CLOSE)/2,3,0),color00bb00;
STICKLINE(平台压力,OPEN,(OPEN+CLOSE)/2,2,0),color00dd00;
STICKLINE(平台压力,OPEN,(OPEN+CLOSE)/2,1,0),color00ff00;
yl:=IF(CLOSE>REF(OPEN,BARSLAST(TJ =1)),REF(OPEN,BARSLAST(TJ =1)),0);
FT:=BARSLAST(yl);
YLX:=REF(yl,FT);
bt:=IF(CLOSE<OPEN and REF(CLOSE,1)>REF(OPEN,1),REF(CLOSE,1),0);
XFT:=BARSLAST(bt);
XYLX:=REF(bt,XFT);
平台调下:=CROSS(XYLX,CLOSE);
平台突破:=CROSS(CLOSE,YLX);
;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
主力进场:=VAR8>REF(VAR8,1);
进场:REF(主力进场,1),LINETHICK0;
DRAWTEXT(进场 and 平台突破 ,LOW * 0.97,'进'),ALIGN1,COLOR0000FF;
DRAWTEXT(进场 and 平台突破 ,LOW * 0.94,'场'),ALIGN1,COLOR0000FF;
机构增仓:=EXTDATA(1);
大户增仓:=EXTDATA(2);
散户增仓:=EXTDATA(3);
增仓风向:=机构增仓+大户增仓;
增仓:=REF(CROSS(增仓风向,0)and CLOSE<十天买卖,1);
进:=CROSS(增仓风向,机构增仓) or 增仓;
出:=CROSS(机构增仓,增仓风向);
var1:=VOL>SUM(VOL,5)/3 or VOL>=REF(VOL,1)*2;
var2:=(VOL/FINANCE(7))*100>10;
var3:=CLOSE>DYNAINFO(11);
选股:var1 and var2 and var3,LINETHICK0;
DRAWTEXT(选股,CLOSE*0.98,'突破平台'),COLORGREEN,LINETHICK0;

飞狐量能平台主图指标公式

 

相关文章