在线检测未来函数

通达信微分MACD指标公式

来源:Internet,编辑:股旁网,2011-05-23

DIF12:=(EMA(CLOSE,12)-EMA(CLOSE,26))/((EMA(CLOSE,12)+EMA(CLOSE,26))/2)*1000;
DEA12:=EMA(DIF12,9);
{相对MACD:2*(DIF12-DEA12),STICK,COLORRED;}
KDIF12:=3*(DIF12-DEA12);{KDIF12:=2*(DIF12-DEA12)};
KDEA12:=SMA(KDIF12,5,2);
买卖力道:2*(KDIF12-KDEA12),COLORLIRED,LINETHICK1;
{相对DIF:DIF12,COLORMAGENTA,LINETHICK2;
相对DEA:DEA12,COLORGREEN,LINETHICK2;}
微分DIF:KDIF12,COLORYELLOW,LINETHICK2;
微分DEA:KDEA12,COLORLIGRAY,LINETHICK1;
微分MACD:2*(KDIF12-KDEA12),STICK,,LINETHICK2,COLORBLUE;
B11:微分MACD>REF(微分MACD,1) AND 微分MACD>REF(微分MACD,2) AND
REF(微分MACD,2)>REF(微分MACD,1) AND REF(微分MACD,2)/REF(微分MACD,1)>0,NODRAW;
B12:=EXIST(B11,15)=1 AND 微分MACD<REF(微分MACD,1) AND REF(微分MACD,1)>REF(微分MACD,2);
B121:B12 AND BARSLAST(B11)>BARSLAST(B12) AND COUNT(B12,BARSLAST(B11))=1,NODRAW;
{以下为MACD变色的代码}
_红柱:IF(微分MACD>REF(微分MACD,1),微分MACD,DRAWNULL),STICK,COLORRED;
IF(B11,微分MACD,DRAWNULL),STICK,COLORYELLOW,LINETHICK7;
IF(B121,微分MACD,DRAWNULL),STICK,COLORGREEN,LINETHICK7;
{股旁网-股票公式网站 www.GUpang.com}
绿柱:IF(微分MACD<REF(微分MACD,1),微分MACD,DRAWNULL),STICK,COLORYELLOW;
_抄底:=((CROSS(微分DIF,微分DEA)
&&微分DEA<=-0.07)*微分DIF)*1.50,COLORLIMAGENTA;
_DIF:=微分DIF,COLORWHITE;
_DEA:=微分DEA,COLORYELLOW;
__强度:=IF(_DIF>_DEA,_DIF,DRAWNULL),COLORRED,LINETHICK2;
_强度:=IF(_DEA<_DIF,_DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
0;
{统计买入涨幅};
ZF:=C/(REF(C,BARSLAST(B11)))*100-100,NODRAW;
本轮涨幅1:=IF(B121=1,ZF,DRAWNULL);
本轮涨幅:IF(C/(REF(C,BARSLAST(B11)))=0,1,本轮涨幅1);
涨跌算术和1:SUM(本轮涨幅,0);
{ZFF:=1*本轮涨幅/100;
首轮涨后:1*(1+REF(ZFF,BARSSINCE(B121)) );
N1轮涨:首轮涨后*REF(本轮涨幅,BARSSINCEN(B121,COUNT(B121,0)-1));
总涨倍率1:=(本轮涨幅*REF(本轮涨幅,BARSLAST(B121)))/10000,NODRAW;
总涨倍率:IF(B121=1,总涨倍率1,DRAWNULL);};

通达信微分MACD指标公式

 

相关文章