在线检测未来函数

通达信真实资金指标公式

来源:Internet,编辑:股旁网,2011-05-23

预测量:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,预测量,0,3.5,-1),COLORRED;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
主买2:=ABS(QJ0*(JJ-MIN(CLOSE,OPEN)));
STICKLINE(主买2,0,主买2,3.3,0),COLORRED;
主卖2:=ABS(QJ0*(MIN(OPEN,CLOSE)-LOW));
STICKLINE(主卖2,0,-主卖2,3.3,0),COLORGREEN;
散买2:=ABS(QJ0*(HIGH-MAX(OPEN,CLOSE)));
STICKLINE(散买2,主买2,主买2+散买2,3.3,0),COLORCBC0FF;
散卖2:=ABS(QJ0*(MAX(CLOSE,OPEN)-JJ));
STICKLINE(散卖2,-主卖2,-主卖2-散卖2,3.3,0),COLORCD0000;
资金异动:=VOL/MA(VOL,55)*100,COLORYELLOW;
STICKLINE(资金异动>100 ,0,主买2+散买2,0.2,0),COLORYELLOW;
主买:主买2,COLORRED,NODRAW;
主卖:-主卖2,COLORGREEN,NODRAW;
散买:散买2,COLORCBC0FF,NODRAW;
散卖:-散卖2,COLORCD0000,NODRAW;
FJ:0,COLORRED;
VAR1:=VOL/((H-L)*2-ABS(C-O));
主买1:=IF(C>O,VAR1*(H-L),IF(C<O,VAR1*((H-O)+(C-L)),VOL/2)),COLORRED,NODRAW;
主卖1:=IF(C>O,0-VAR1*((H-C)+(O-L)),IF(C<O,0-VAR1*(H-L),0+V/2)),COLOR00FF00,NODRAW;
AA1:=VOL<REF(LLV(VOL,20),1);
STICKLINE(AA1,(-主卖2-散卖2),(主买2+散买2),1.8,1),COLORYELLOW;
AA2:=VOL<REF(LLV(VOL,60),1);
STICKLINE(AA2,(-主卖2-散卖2),(主买2+散买2),1.4,1),COLORCD0000;
AA3:=VOL<REF(LLV(VOL,100),1);
STICKLINE(AA3,(-主卖2-散卖2),(主买2+散买2),1.0,1),COLORGREEN;
DDX:=主买1+主卖1;
DX:=MA(DDX,5)*5;
DDX1:SMA(DX,3,1),COLORRED,LINETHICK1;
DDX2:SMA(DDX1,3,1),COLORYELLOW,LINETHICK1;
DDX3:EMA(DDX2,5),COLORF0F000,LINETHICK1;
X1:=(3*C+L+H+O)/6;
F:=(EMA(CLOSE,5)-EMA(CLOSE,21))*4;
{股旁网-股票公式网站 www.GUpang.com}
VAR10:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR20:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
VAR30:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR40:=(20*X1+19*REF(X1,1)+18*REF(X1,2)+17*REF(X1,3)+16*REF(X1,4)+15*REF(X1,5)+
14*REF(X1,6)+13*REF(X1,7)+12*REF(X1,8)+11*REF(X1,9)+10*REF(X1,10)+9*REF(X1,11)+8*REF(X1,12)
+7*REF(X1,13)+6*REF(X1,14)+5*REF(X1,15)+4*REF(X1,16)+3*REF(X1,17)+2*REF(X1,18)+REF(X1,20))/210;
MTM:=C-REF(C,1);
DX1:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR40,13);
卖1:=HHV(DX1,2)=HHV(DX1,7) AND COUNT(DX1>50,2) AND CROSS(MA(DX1,2),DX1);
DRAWTEXT(FILTER(卖1=1,1),(-主卖2-散卖2)*1.08,'卖'),COLOR00C800;
买1:=LLV(DX1,2)=LLV(DX1,7) AND COUNT(DX1<0,2) AND CROSS(DX1,MA(DX1,2));
DRAWTEXT(FILTER(DDX1>=DDX2 AND 买1=1,5),(-主卖2-散卖2)*1.08,'买'),COLORYELLOW;
ZZ:=IF(REF(C,1)>REF(O,1) AND O>REF(C,1)*1.014 AND C<O*1.02,1,3);
V5:=MA(V,5);
V12:=MA(V,12);
V34:=MA(V,34);
C6:=MA(C,6);
吸货:=CROSS(C,C6) AND V>V5*1.2 AND V>V12*1.2 AND ZZ>2 AND C>H*0.975;
DRAWTEXT (吸货,(主买2+散买2)*1.26,'吸'),COLORYELLOW;

通达信真实资金指标公式

 

相关文章