在线检测未来函数

通达信胜利逃亡指标公式

来源:Internet,编辑:股旁网,2011-05-25

VAR1:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VAR2:=SMA(VAR1,26,1);
VAR3:=SMA(VAR2,26,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=SMA(VAR5,5,1);
VAR7:=SMA(VAR6,10,1);
VAR8:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);
VAR9:=HIGH-REF(HIGH,1);
VARA:=REF(LOW,1)-LOW;
VARB:=SMA(IF(VAR9>0 AND VAR9>VARA,VAR9,0),12,1);
VARC:=SMA(IF(VARA>0 AND VARA>VAR9,VARA,0),12,1);
VARD:=VARB*100/VAR8;
VARE:=VARC*100/VAR8;
VARF:=SMA(ABS(VARE-VARD)/(VARE+VARD)*100,12,1);
VAR10:=(VARF+REF(VARF,5))/2;
VAR11:=SUM(HIGH-OPEN,12)/SUM(OPEN-LOW,12)*100;
VAR12:=SUM(MAX(0,HIGH-REF(CLOSE,1)),12)/SUM(MAX(0,REF(CLOSE,1)-LOW),12)*100;
VAR13:=AMOUNT/VOL/100;
VAR14:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR15:=SUM(AMOUNT,5)/VAR13/100;
VAR16:=SUM(AMOUNT,13)/VAR13/100;
VAR17:=SUM(AMOUNT,34)/VAR13/100;
VAR18:=SUM(AMOUNT,209)/VAR13/100;
{股旁网-股票公式网站 www.GUpang.com}
VAR19:=REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4);
VAR1A:=VAR19/CAPITAL;
VAR1B:=VOL/CAPITAL*VAR14+VAR1A*REF(VAR13,1);
VAR1C:=DMA(VAR14,VOL/VAR15);
VAR1D:=DMA(VAR14,VOL/VAR16);
VAR1E:=DMA(VAR14,VOL/VAR17);
VAR1F:=DMA(VAR14,VOL/CAPITAL);
VAR20:=100*(CLOSE-VAR1C)/VAR1C;
VAR21:=100*(CLOSE-VAR1D)/VAR1D;
VAR22:=100*(CLOSE-VAR1E)/VAR1E;
VAR23:=100*(CLOSE-VAR1F)/VAR1F;
VAR24:=100*(CLOSE-VAR1D)/VAR1D;
VAR25:=LLV(HIGH,480);
VAR26:=100*(CLOSE-VAR25)/VAR25;
VAR27:=LLV(HIGH,240);
VAR28:=100*(CLOSE-VAR27)/VAR27;
VAR29:=LLV(HIGH,720);
VAR2A:=100*(CLOSE-VAR29)/VAR29;
VAR2B:=AMOUNT/(100*VOL);
VAR2C:=MA(CLOSE,5);
VAR2D:=100*(VAR2C-REF(VAR2C,1))/REF(VAR2C,1);
VAR2E:=CLOSE-LOW;
VAR2F:=HIGH-LOW;
VAR30:=CLOSE-HIGH;
VAR31:=IF(CLOSE>=0,(VAR2E/VAR2F+VAR30/VAR2F)*VOL,(VAR30/VAR2F+VAR2E/VAR2F)*VOL);
VAR32:=SUM(VAR31,10)/10000;
VAR33:=AMOUNT/(100*VOL);
VAR34:=VAR1D;
VAR35:=100*(VAR1D-REF(VAR1D,1))/REF(VAR1D,1);
VAR36:=VAR32>0 AND VAR35>0;
VAR37:=VAR6<30 AND VAR7<30 AND VAR6>VAR7 AND VAR2<80 AND VAR3<80 AND VAR28<45 AND VAR26<45;
VAR38:=VAR36 AND VAR37;
买入: IF(VAR38,100,0), LINETHICK2,COLORYELLOW;
VAR39:=CROSS(VAR7,VAR6);
VAR3A:=VAR7>80 OR VAR6>80;
VAR3B:=VAR39 AND VAR3A;
逃顶: IF(VAR3B,100,0),LINETHICK2,COLORRED;

通达信胜利逃亡指标公式

 

相关文章