在线检测未来函数

通达信MACD超准指标公式

来源:Internet,编辑:股旁网,2011-05-26

SQX:=(C-MA(CLOSE,13))*100;
DIFF:EMA(MA(SQX,7),1),COLORWHITE;
DEA:EMA(DIFF,7),COLORYELLOW;
MACD:(DIFF-DEA)*2,COLORSTICK;
低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,15,DRAWNULL),COLORYELLOW,LINETHICK4,CROSSDOT;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28,DRAWNULL),COLORFF00FF,LINETHICK4,CROSSDOT;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
{股旁网-股票公式网站 www.GUpang.com}
背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),40,DRAWNULL),COLORRED,LINETHICK4,CROSSDOT;
势:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORGREEN;{,COLORRED;}
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),COLORWHITE;
顶背离_:IF(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF
AND CROSS(DEA,DIFF),66,DRAWNULL)
,COLORF08000,LINETHICK4,CROSSDOT;
压:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFFBB99;
A3:=CROSS(DIFF,DEA) AND DEA<0;
零下二次金叉_:IF(FILTER(COUNT(A3,21)=2,10),53,DRAWNULL)
,COLORWHITE,LINETHICK4,CROSSDOT;

通达信MACD超准指标公式

 

相关文章