在线检测未来函数

大智慧私募操盘线主图指标公式

来源:Internet,编辑:股旁网,2011-05-30

A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
止损线:EMA(X,13),LINETHICK2,COLORFF00FF;
强弱线:MA(C,20),LINETHICK2,COLORYELLOW;
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
趋势线:EMA(KKC,50),LINETHICK2, COLORGREEN;
N1:=5;
N4:=34;
CQ:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N4)/HHV(C,N4));
饱和度:=IF(SAT>1,1,SAT)*100;
KAAA:=饱和度>=97 AND CQ>90;
KBBB:=ANY(KAAA,20);
DRAWTEXTABS(5,5,'股旁网 www.gupang.com'),linethick1,COLOR00EEff;
牛熊线:IF(KBBB,REF(L,BARSLAST(KAAA)+1),REF(L,BARSLAST(KAAA)+1)),LINETHICK4;
N:=80;
M:=3;
MA5X:=MA(C,5);
MA13X:=MA(C,13);
高:=REF(HHV(H,N),M);
低:=REF(LLV(L,N),M);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
一:REF(高,DATE),POINTDOT,COLORWHITE;
二:REF(H19,DATE),POINTDOT,COLORYELLOW;
三:REF(H38,DATE),POINTDOT,COLORMAGENTA;
四:REF(H中,DATE),POINTDOT,COLORRED;
五:REF(H61,DATE),POINTDOT,COLORMAGENTA;
六:REF(H80,DATE),POINTDOT,COLORYELLOW;
七:REF(低,DATE),POINTDOT,COLORWHITE;
A60:MA(C,60),COLORBLUE;
A120:MA(C,120),COLORGRAY;
A250:MA(C,250);
DRAWTEXT(BARSTATUS=2,一,' 一'),COLORWHITE;
DRAWTEXT(BARSTATUS=2,二,' 二'),COLORYELLOW;
DRAWTEXT(BARSTATUS=2,三,' 三'),COLORMAGENTA;
DRAWTEXT(BARSTATUS=2,四,' 四'),COLORRED;
DRAWTEXT(BARSTATUS=2,五,' 五'),COLORMAGENTA;
DRAWTEXT(BARSTATUS=2,六,' 六'),COLORYELLOW;
DRAWTEXT(BARSTATUS=2,七,' 七'),COLORWHITE;
AA:=CLOSE/REF(CLOSE,1)>=1.09;
STICKLINE(AA,OPEN,CLOSE,1,0),COLORYELLOW;

大智慧私募操盘线主图指标公式

 

相关文章