在线检测未来函数

通达信倍量资金指标公式

来源:Internet,编辑:股旁网,2011-06-01

预量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,预量,0,3,-1),COLORFFFFFF;
量_价:=1;CTKG:=1;
W:=量_价;
EPSL:=0.0001;
ZZ:=(C+H+L)/3;
TJA:=ZZ>=MAX(C,O) AND CTKG=1;{倒锤头};
TJB:=ZZ<=MIN(C,O) AND CTKG=1;{正锤头};
ZF:=IF(TJA,1,IF(TJB,-1,0));{正负数};
TJ0:=TJA OR TJB;
TJ1:=H=L AND C>REF(C,1);{一字涨停};
TJ2:=H=L AND C<REF(C,1);{一字跌停};
TJ3:=H=L AND C=REF(C,1);{连续一字涨、跌停};
量_价:=IF(W=1,VOL,AMOUNT),STICK,COLOREEFFEE;{平盘量,白色}
{以下4句组合属核心公式,版权属于JIPGEMLING.见凌见}
EE:=IF(TJ1,EPSL,IF(TJ2,-EPSL,0));
ZL:=2*(H-L)+ABS(C-O)+3*IF(TJ3,EPSL,ABS(EE));
JGL_DX:=(IF(TJ0,2/3*(2*C-H-L)+ZF*ABS(C-O),(C-O))+EE)/ZL;
买卖差:JGL_DX*量_价,COLOR13AADD,NODRAW;
DX%:JGL_DX*100,NODRAW;
买盘:量_价*(1+JGL_DX)/2,COLOR1133AA,NODRAW;
卖盘:量_价*(1-JGL_DX)/2,COLORFFFF00,NODRAW;
{加入成交量移动平均线}
M5:MA(V,5),COLORRED;M10:MA(V,10);
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),LINETHICK0;
主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;
{因为可能会出现卖出量为0的BUG,所以放在最后参考}
净量:主动买盘+主动卖盘,NODRAW;
STICKLINE(C<O ,0,VOL,3.2,0),COLORFF1100;
STICKLINE(C<O ,0,VOL,2.7,0),COLORFF3300;
STICKLINE(C<O ,0,VOL,2.1,0),COLORFF5500;
STICKLINE(C<O ,0,VOL,1.5,0),COLORFF7700;
STICKLINE(C<O ,0,VOL,0.9,0),COLORFF9900;
STICKLINE(C<O ,0,VOL,0.3,0),COLORFFBB00;
STICKLINE(C=O AND C<REF(C,1),0,VOL,3.2,0),COLOR006000;
STICKLINE(C=O AND C<REF(C,1),0,VOL,2.7,0),COLOR007500;
STICKLINE(C=O AND C<REF(C,1),0,VOL,2.1,0),COLOR009100;
STICKLINE(C=O AND C<REF(C,1),0,VOL,1.5,0),COLOR00A600;
STICKLINE(C=O AND C<REF(C,1),0,VOL,0.9,0),COLOR00BB00;
STICKLINE(C=O AND C<REF(C,1),0,VOL,0.3,0),COLOR00CC00;
STICKLINE(C=O AND C>REF(C,1),0,VOL,3.2,0),COLOR555555;
STICKLINE(C=O AND C>REF(C,1),0,VOL,2.7,0),COLOR777777;
STICKLINE(C=O AND C>REF(C,1),0,VOL,2.1,0),COLOR999999;
STICKLINE(C=O AND C>REF(C,1),0,VOL,1.5,0),COLORBBBBBB;
STICKLINE(C=O AND C>REF(C,1),0,VOL,0.9,0),COLORDDDDDD;
STICKLINE(C=O AND C>REF(C,1),0,VOL,0.3,0),COLORFFFFFF;
STICKLINE(C>O,0,VOL,3.2,0),COLORFF11FF;
STICKLINE(C>O,0,VOL,2.7,0),COLORFF33FF;
STICKLINE(C>O,0,VOL,2.1,0),COLORFF55FF;
STICKLINE(C>O,0,VOL,1.5,0),COLORFF77FF;
STICKLINE(C>O,0,VOL,0.9,0),COLORFF99FF;
STICKLINE(C>O,0,VOL,0.3,0),COLORFFBBFF;
{这一句很好,也就是中间出现黄色,为活跃资金}
资金异动:VOL/MA(VOL,55)*100,COLORYELLOW;
{股旁网-股票公式网站 www.GUpang.com}
STICKLINE(主动买盘>0,0,主动买盘,3.2,0),COLOR000055;
STICKLINE(主动买盘>0,0,主动买盘,2.7,0),COLOR000077;
STICKLINE(主动买盘>0,0,主动买盘,2.1,0),COLOR000099;
STICKLINE(主动买盘>0,0,主动买盘,1.5,0),COLOR0000BB;
STICKLINE(主动买盘>0,0,主动买盘,0.9,0),COLOR0000DD;
STICKLINE(主动买盘>0,0,主动买盘,0.3,0),COLOR0000FF;
STICKLINE(主动卖盘<0,0,主动卖盘,3.2,0),COLOR006000;
STICKLINE(主动卖盘<0,0,主动卖盘,2.7,0),COLOR007500;
STICKLINE(主动卖盘<0,0,主动卖盘,2.1,0),COLOR009100;
STICKLINE(主动卖盘<0,0,主动卖盘,1.5,0),COLOR00A600;
STICKLINE(主动卖盘<0,0,主动卖盘,0.9,0),COLOR00BB00;
STICKLINE(主动卖盘<0,0,主动卖盘,0.3,0),COLOR00CC00;
STICKLINE(资金异动>100 ,0,VOL,0.6,0),COLORYELLOW;
{这两句为放量,如果低位,当然要关注了,柱子中画一白一蓝两线,用于提示}
STICKLINE(V>=3*REF(V,1),V/3,V/3,5.9,0),COLORBLUE,LINETHICK2;
STICKLINE(V>=2*REF(V,1),V/2,V/2,3.9,0),COLORYELLOW,LINETHICK2;

通达信倍量资金指标公式

 

相关文章