在线检测未来函数

通达信彩色MACD改良指标公式

来源:Internet,编辑:股旁网,2011-06-03

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9),COLORYELLOW;
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORRED;
STICKLINE(MACD>=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLORGREEN;
STICKLINE(MACD<=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORFF00FF;
STICKLINE(MACD<=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLOR00FFFF;
多转空:=((((LLV(MACD,4)>0) AND (MACD<REF(MACD,1))) AND (REF(MACD,1)>REF(MACD,2))) AND (REF(MACD,2)>REF(MACD,3)));
{股旁网-股票公式网站 www.GUpang.com}
空转多:=((((HHV(MACD,4)<0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3)));
DRAWICON(多转空,MACD,2);
DRAWICON(空转多,MACD,1);
CD:MACD,COLORCYAN;
涨CD:IF(CD>REF(CD,1),CD,DRAWNULL),COLORRED,LINETHICK2;
涨DIF:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
背离:DRAWLINE(A1=0,DEA,底背,DEA,0),COLORGREEN,LINETHICK3;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
顶背离:DRAWLINE(A2=0,DEA,顶背,DEA,0),COLORMAGENTA,LINETHICK3;
多空分界线:0,COLORGREEN;

通达信彩色MACD改良指标公式

 

相关文章