在线检测未来函数

通达信短线是银主图指标公式

来源:Internet,编辑:股旁网,2011-06-05

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA30:MA(CLOSE,30);
MA62:MA(C,62);
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前期高位:REF(H,BARSLAST(HD)),COLOR00FF00,POINTDOT;
前期低位:REF(L,BARSLAST(LD)),COLORFF00FF,POINTDOT;
STICKLINE(C,前期高位,前期高位,5,0),COLOR00FF00;
STICKLINE(C,前期低位,前期低位,5,0),COLORFF00FF;
月价托:=MA5>MA20 AND MA5>MA10 AND CROSS(MA10,MA20);
季价托:=MA20>MA62 AND MA20>MA30 AND CROSS(MA20,MA62);
短长价托:=MA5>MA62 AND MA5>MA10 AND CROSS(MA10,MA62);
{股旁网-股票公式网站 www.GUpang.com}
DRAWTEXT(月价托,L-0.12,'月价托'),COLORYELLOW;
STICKLINE(月价托,H,L,0.5,1),COLORYELLOW;
STICKLINE(月价托,O,C,6,1),LINETHICK2,COLORYELLOW;
DRAWTEXT(季价托,L-0.12,'季价托'),COLOR0099FF;
STICKLINE(季价托,H,L,0.5,1),COLOR0099FF;
STICKLINE(季价托,O,C,6,1),LINETHICK2,COLOR0099FF;
DRAWTEXT(短长价托,L-0.12,'短长价托'),COLOR36C0C1;
STICKLINE(短长价托,H,L,0.5,1),COLOR36C0C1;
STICKLINE(短长价托,O,C,6,1),LINETHICK2,COLOR36C0C1;
VOL5:=MA(VOL,5),COLORWHITE;
VOL10:=MA(VOL,10),COLORYELLOW;
VOL20:=MA(VOL,20),COLORFF00FF ;
量托:=VOL5>=VOL20 AND CROSS(VOL10,VOL20) AND REF(VOL10,1)<REF(VOL20,1);
DRAWTEXT(量托,L*0.97,'量托'),COLORWHITE;
STICKLINE(量托,H,L,0.5,1),COLORWHITE;
STICKLINE(量托,O,C,6,1),LINETHICK2,COLORWHITE;
AA:=BARSLAST(MA62>MA30 AND (MA30=MA20 OR MA30>MA20));
BB:=REF(COUNT(C<MA62,AA)=AA,1);
CC:=CROSS(C,MA62) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB AND CC,COLOR00FF00;
DRAWTEXT(芙蓉出水,L-0.12,'芙蓉出水'),COLORFF00FF;
STICKLINE(芙蓉出水,H,L,0.5,1),COLORFF00FF;
STICKLINE(芙蓉出水,O,C,6,1),LINETHICK2,COLORFF00FF;

通达信短线是银主图指标公式

 

相关文章