在线检测未来函数

通达信潜筹涌动指标公式

来源:Internet,编辑:股旁网,2011-06-10

SW:=18;BW:=66;DW:=86;
CJ:=(H+L+2*O+3*C)/7;
DK:=INTPART(276/POW(TOTALBARSCOUNT+0.3,2)-1.1);
DN:=IF(DK<5,5,DK);
KN:=POW(HHV(H,3.6*DN)/HHV(H,0),0.9);
短筹:SMA(SMA((PWINNER(2*SW,BW*CJ/100)+0.618*PWINNER(SW,DW*CJ/100))*61.8,1.2*DN,0.41*DN),2.2*DN,2.2*DN-1),COLORYELLOW;
抢筹:IF(SLOPE(短筹,0.4*DN)>=0,SLOPE(短筹,0.4*DN)*POW(0.61*DN,1.5),0),COLORB0AFFF;
活筹:=0.28*短筹+4.62*抢筹-3;
上涨角:=HHV(ATAN(SLOPE(活筹,0.6*DN)*0.58)*180/3.14159,0.6*DN);
TT:=(上涨角+1.11*短筹)/1.916;
屯:=SMA(TT,2.4*DN,0.6*DN);
屯筹:=(2.28*HHV(屯,1.6*DN)+SMA(屯,2.4*DN,1))/2.801;
IF(SLOPE(屯筹,2)>0,屯筹,DRAWNULL),COLORRED;
IF(SLOPE(屯筹,2)<=0,屯筹,DRAWNULL),COLORBLUE;
{股旁网-股票公式网站 www.GUpang.com}
QL:=(抢筹*0.8+SLOPE(短筹,0.4*DN)*(60-短筹)*0.8+SLOPE(屯筹,0.6*DN)*(88-屯筹)*0.55+SLOPE(屯,0.6*DN)*(屯-100)*0.2)*POW(DN/4.2,0.4)*KN;
潜筹:IF(SLOPE(QL,1.6*DN)>0,0.22*SMA(QL,2.4*DN,2.4*DN-1)+0.44*HHV(QL,1.6*DN)-4,0),COLORFF9977;
QF:=BARSLAST(CROSS(68,潜筹))+1;
潜伏期:IF(QF=1,REF(QF,1)+1,QF),LINETHICK0;
潜深:=0.5*HHV(潜伏期,3.6*DN)+0.5*SMA(潜伏期,3.6*DN,1);
上浮力:IF(SLOPE(潜深,2)<0,KN*50*POW(-SLOPE(潜深,2),0.2),0),COLORMAGENTA,LINETHICK2;
KP:=BARSLAST(CROSS(短筹,屯筹*(KN-0.0495)))+1;
庄筹派发:SMA(MA(115*KN-屯筹*(KN-0.0495),KP)*0.6,1.8*DN,2)+25,COLORWHITE;
潜筹涌动:=SMA(潜筹,1.8*DN,2);
XG:=SMA(V,4,3)<1.421*SMA(V,24,1);
牛市粗选:屯筹>88 AND 庄筹派发<46.7 AND 0.495*潜筹涌动+潜伏期>18.2 AND XG ,LINETHICK0;
回头岸:-潜筹*SLOPE(潜筹,2)/100,LINETHICK0;
定军山:抢筹+SLOPE(屯筹,8),LINETHICK0;
熊市粗选:(回头岸>0.1 OR 定军山>0) AND C/REF(C,1)>=1.048 AND 潜筹涌动>0.3*潜筹 AND XG,LINETHICK0;
IF(牛市粗选,庄筹派发,DRAWNULL),COLORMAGENTA,LINETHICK3;
IF(熊市粗选,庄筹派发,DRAWNULL),,COLORFF48A3,LINETHICK3;

通达信潜筹涌动指标公式

 

相关文章