在线检测未来函数

通达信乘风破浪VOL指标公式

来源:Internet,编辑:股旁网,2011-06-11

换手:IF(CAPITAL>0,V/CAPITAL*100,V),LINETHICK0;
HS:=换手;
HLP:=SMA(WINNER(C)*100,3,1);
NN:=250;
HH:=HHV(V,NN);
LL:=LLV(V,NN);
最高:=HH;
最低:=LL;
RCC:=最高*0.9-(最高-最低)*0.5;
RHL:=RCC;
HLMAX:=MAX(最高,最低);
HLMIN:=MIN(最高,最低);
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
显示K线面积:=1;
((100-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,COLOR333333;
((80-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,COLOR333333;
((50-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,COLOR888888;
((25-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,COLOR333333;
{最佳买入时机}
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
STICKLINE(CROSS(最佳买入,0),((85-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,((100-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,2.8,0),COLORRED;
{百万测底}
趋势线:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
准备:IF(趋势线<=5,((65-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,((100-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL),COLORFFFFFF;
VARA2:=LLV(MA(LOW,3),3);
VARA3:=HHV(MA(HIGH,3),3);
KK:=EMA((CLOSE-VARA2)/(VARA3-VARA2)*100,4)*0.7+20;
DD:=EMA(0.667*REF(KK,1)+0.333*KK,2)*0.7+20;
KK2:=EMA(ABS(VARA2-CLOSE)/ABS(VARA2-VARA3)*100,4)*0.7+20;
DD2:=EMA(0.667*REF(KK2,1)+0.333*KK2,2)*0.7+20;
{股旁网-股票公式网站 www.GUpang.com}
提示:IF((KK2-KK)*2.5>35,((75-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,((100-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL),LINETHICK2,COLORFF00FF;
XXJJ:=LLV("KDJ.J",2)=LLV("KDJ.J",8);
时机: IF(CROSS("KDJ.J",1) AND REF(XXJJ,1),((90-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,((100-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL),LINETHICK2,COLORYELLOW;
地量买点:=CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0);
STICKLINE(地量买点,((0-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,((20-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,3,0),COLORFF0080;
SJ:=240;
地量:=IF(CAPITAL=0,AMOUNT=LLV(AMOUNT,34),换手<MA(换手,SUMBARS(V,CAPITAL))/3) ;
极地量:IF(换手<MA(换手,SUMBARS(VOL,CAPITAL))/4,1,0),LINETHICK0;
连续地量:=COUNT(地量,3)>=3 AND COUNT(极地量,3)>=1;
一字涨板:=C>=REF(C,1)*1.01 AND C=O AND H=L;
一字跌板:=C*1.1>=REF(C,1) AND C=O AND H=L;
无一字板:=NOT(一字涨板 OR 一字跌板);
STICKLINE(地量 AND 无一字板 AND (C-MA(C,5))/MA(C,5)*100<0,V,0,2.8,0),COLORFF0080;
STICKLINE(地量 AND 无一字板 AND (C-MA(C,5))/MA(C,5)*100<0,V,0,2.5,0),COLOR00FFFF;
STICKLINE(C>O,V,0,2,1),COLORRED;
STICKLINE(C<=O,V,0,2,1),COLORFFF333;
AA:=VOL>=REF(V,1)*1.91 AND C>REF(C,1);
AA1:=VOL<REF(LLV(VOL,21),1) AND 无一字板;
AA2:=VOL<REF(LLV(VOL,55),1) AND 无一字板;
AA3:=ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.05 AND 无一字板;
STICKLINE(AA,0,V,2,0),COLORRED;
STICKLINE(AA1,0,V/2,2,0),COLORGREEN;
STICKLINE(AA2,0,V/2,2,0),COLORFF00FF;
STICKLINE(AA3,0,V,1,0),COLORWHITE;
地线:HHV(V,60)/6,COLOR00FF00,LINETHICK2;
((HLP-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,COLOR0000FF,LINETHICK1,POINTDOT;
(("KDJ.K"-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,COLORFFF111;
(("KDJ.D"-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,COLOR00FF00;
(("KDJ.J"-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL,COLORFF1111;
MV35:MA(V,35),COLORFFFFFF;
MV10:MA(V,10),COLOR00FFFF;
MV5:MA(V,5),COLORFF00FF;

通达信乘风破浪VOL指标公式

 

相关文章