在线检测未来函数

通达信圣灵石之股海神灯主图指标公式

来源:Internet,编辑:股旁网,2011-06-22

圣灵石:EMA(C,3);
圣灵石仙:EMA(C,7);
圣:=IF((EMA((C*2+H+L)/4,1)-EMA((C*2+H+L)/4,40)-EMA(EMA((C*2+H+L)/4,1)-EMA((C*2+H+L)/4,40),5))*100<-20,-20,IF((EMA((C*2+H+L)/4,1)-EMA((C*2+H+L)/4,40)-EMA(EMA((C*2+H+L)/4,1)-EMA((C*2+H+L)/4,40),5))*100>100,100,(EMA((C*2+H+L)/4,1)-EMA((C*2+H+L)/4,40)-EMA(EMA((C*2+H+L)/4,1)-EMA((C*2+H+L)/4,40),5))*100));
灵:=IF((3*(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*20-2*SMA((HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*20,3,1))*1>100,100,IF((3*(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*20-2*SMA((HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*20,3,1))*1<-5,-5,(3*(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*20-2*SMA((HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*20,3,1))*1));
石:=IF((HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*120>100,100,(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*120);
股海神灯:=CROSS(圣,灵) AND CROSS(80,石);
DRAWTEXT(股海神灯,LOW *0.98,'股海神灯' ),COLORYELLOW;
STICKLINE(股海神灯,H,L,6,0),LINETHICK1,COLORRED;
STICKLINE(股海神灯,H,L,0.2,0),COLORYELLOW;
STICKLINE(股海神灯,O,C,2,0),LINETHICK1,COLORYELLOW;
DRAWICON(股海神灯,(H+L)/2,7);

通达信圣灵石之股海神灯主图指标公式

 

相关文章