在线检测未来函数

通达信涨停回马枪主图指标公式

来源:Internet,编辑:股旁网,2011-06-26

中轴:MA(C,21),COLORWHITE,LINETHICK4;
压力:中轴 + 2*STD(C,21),COLORYELLOW,LINETHICK2;
支撑:中轴 - 2*STD(C,21),COLORYELLOW,LINETHICK2;
高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
%19.1:REFDATE(H1,DATE),POINTDOT,COLORYELLOW,LINETHICK3;
%38.2:REFDATE(H2,DATE),POINTDOT,COLORMAGENTA,LINETHICK3;
%50:REFDATE(H3,DATE),POINTDOT,COLORLIGRAY,LINETHICK3;
%61.8:REFDATE(H4,DATE),POINTDOT,COLORRED,LINETHICK3;
%80.9:REFDATE(H5,DATE),POINTDOT,COLORWHITE,LINETHICK3;
M1:EMA(C,5),COLORRED,LINETHICK3;
M2:EMA(M1,5),COLORLIGRAY;
M3:EMA(M2,5),COLORLIGRAY;
M4:EMA(M3,5),COLORLIGRAY;
M5:EMA(M4,5),COLORLIGRAY,LINETHICK2;
{www.gUPang.com 股旁网_最新股票指标公式}
M1S:IF(M1>REF(M1,1),M1,DRAWNULL),COLORLIRED;
M2S:IF(M2>REF(M2,1),M2,DRAWNULL),COLORLIRED;
M3S:IF(M3>REF(M3,1),M3,DRAWNULL),COLORLIRED;
M4S:IF(M4>REF(M4,1),M4,DRAWNULL),COLORLIRED;
M5S:IF(M5>REF(M5,1),M5,DRAWNULL),COLORLIRED,LINETHICK2;
PMA:=MA(C,5);
X:=(3*C+L+O+H)/6;
多空线:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)
+14*REF(X,6)+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)
+8*REF(X,12)+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)
+2*REF(X,18)+REF(X,20))/210;
DD:=多空线<REF(多空线,1);
AA:=(PMA>多空线);
卖出线:=XMA((C+O+H+L)/4,20)*(1+55/1000);
买入线:=XMA((C+O+H+L)/4,32)*(1-55/1000);
趋势线:=(卖出线+买入线)/2;
VV:=(C+L+H)/3;
DSA:=SMA(XMA(VV,15),2,1);
DRAWICON(H<=DSA AND C<O AND (L=LLV(L,5) OR C=LLV(C,5)),L,1);
DRAWICON(L>=DSA AND C>O AND (H=HHV(H,5) OR C=HHV(C,5)),H,2);
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
震仓线:=45;
抄底线:=20;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;
DRAWICON((REF(PP,1) AND HH) OR (REF(PP3,1) AND HH),支撑*0.98,11);

通达信涨停回马枪主图指标公式

 

相关文章