在线检测未来函数

飞狐凯恩斯工作线主图指标公式

来源:Internet,编辑:股旁网,2011-07-03

X0:=IF(C>=REF(C,1),AMOUNT/10000,0);
X1:=IF(C<REF(C,1),AMOUNT/10000,0);
DD:=(X0-X1);
EE:=vol/sum(vol,55);
LC:=REF(CLOSE,1);
JH:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
cp:=FILTER(CROSS(75,JH),11);
zp:=FILTER(CROSS(JH,25),22);
DP:=IF(C>1000,(DD/10000000000)/EE,DD/(FINANCE(7)*c))*100;
七天线:MA(C,7),ColorFFFFFF;
工作线:(EMA(C,14)),POINTDOT,linethick4,coloryellow;
生命线:(MA(C,25)),linethick2,colorFF00FF;
长线启动点:(MA(C,99)),CIRCLEDOT,ColorEEBBEE;
A0:= zp;
A1:= cp;
A2:= DP;
STICKLINE((A2>=2.1),H,L,0.8,1),colorGreen;
STICKLINE(((A2>=2.1) AND (C>REF(C,1))),O,C,8,1),colorGreen;
STICKLINE(((A2>=2.1) AND (C<REF(C,1))),C,O,8,0),colorGreen;
STICKLINE(((A2>0) AND (A2<5)),H,L,0.8,1),colorRed;
STICKLINE((((A2>0) AND (A2<5)) AND (C>REF
(C,1))),O,C,8,0),colorRed;
STICKLINE((((A2>0) AND (A2<5)) AND (C<REF
(C,1))),C,O,8,1),colorRed;
STICKLINE(((C>=工作线) AND (C>REF
(C,1))),H,L,0.5,1),colorRed;
STICKLINE(((C>=工作线) AND (C>REF(C,1))),O,C,8,1),colorRed;
STICKLINE(((C>=工作线) AND (C<REF
(C,1))),H,L,0.5,0),colorRed;
STICKLINE(((C>=工作线) AND (C<REF(C,1))),O,C,8,0),colorRed;
STICKLINE(((C<工作线) AND (C>REF
(C,1))),H,L,0.5,1),colorGreen;
STICKLINE(((C<工作线) AND (C>REF
(C,1))),O,C,8,1),colorGreen;
STICKLINE(((C<工作线) AND (C<REF
(C,1))),H,L,0.5,0),colorGreen;
{www.gUPang.com 股旁网_最新股票指标公式}
STICKLINE(((C<工作线) AND (C<REF
(C,1))),O,C,8,0),colorGreen;
DRAWTEXT(A0,L,' ̄ ̄'),linethick2,ColorFFFFFF;
DRAWTEXT(A0,L*0.98,' B-B'),linethick5,colorFFFFFF;
DRAWTEXT(A1,H,' ̄ ̄'),linethick2,colorFFFF00;
DRAWTEXT(A1,H*1.03,' S-S'),linethick5,colorFFFF00;
STICKLINE(A1,C,O,8,0),colorFFFF00;
STICKLINE(A1,H,L,1,0),colorFFFF00;
STICKLINE(A0,C,O,8,0),ColorFFFFFF;
STICKLINE(A0,H,L,1,0),ColorFFFFFF;
STICKLINE((A2>=10 and A2<30),C,O,0,0),ColorFFBBFF;
STICKLINE((A2>=10 and A2<30),C,O,8,0),colorFF00FF;
STICKLINE((A2>=10 and A2<30),C,O,7,0),ColorFF22FF;
STICKLINE((A2>=10 and A2<30),C,O,6,0),ColorFF44FF;
STICKLINE((A2>=10 and A2<30),C,O,5,0),ColorFF66FF;
STICKLINE((A2>=10 and A2<30),C,O,4,0),ColorFF88FF;
STICKLINE((A2>=10 and A2<30),C,O,3,0),ColorFF99FF;
STICKLINE((A2>=10 and A2<30),C,O,2,0),ColorFFAAFF;
STICKLINE((A2>=10 and A2<30),C,O,1,0),ColorFFBBFF;
A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4:=EMA(C,10);
A5:=REF(C,2);
A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C -
A5)),6,1))) * 100;
A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
DRAWTEXT((CROSS(A4,A3)),L,'△'),linethick2,colorYellow;
DRAWTEXT(A7,H,'○'),linethick3,colorGreen;
A8:=LLV(L,21);
A9:=HHV(H,21);
A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
A13:=LLV(L,55);
A14:=HHV(H,34);
A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
A16:=(A11 + A15) / 2;
A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
A18:=EMA(A16,5);
A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
A20:=CROSS(A10,A11);
A21:=(CROSS(A10,A19)) AND (A19 < 30);
A22:=A21 * 0.6;
DRAWTEXT((A22 = 0.6),L,'◇'),colorYellow;
DRAWTEXT((A20 = 1),L,'◇'),colorWhite;

飞狐凯恩斯工作线主图指标公式

 

相关文章