在线检测未来函数

飞狐霸王庄主图指标公式

来源:Internet,编辑:股旁网,2011-07-06

{大箱体}
顶: COST(95)*1, linedot,COLORRED;
Var11:=(2*CLOSE+HIGH+LOW)/4;
底: EMA(Var11,99)*0.91,linedot,colorgreen ;
{小箱体}
//箱顶:MA(REF(HHV(c,30),1),2),COLOR0000FF,LINETHICK2;
//箱底:MA(REF(LLV(c,30),1),2),COLOR00FF00,LINETHICK2;
{均线系统}
MA10:=MA(C,10),colorwhite;
MA60:MA(C,60),coloryellow;
DRAWTEXT(CROSS(MA10,MA60),(LOW * 0.95),'注意'),Coloryellow;
多:=EMA(C,3),COLORYELLOW;
空:=EMA(C,5),COLOR00FF00;
均衡:=EMA(空,5),COLORWHITE,;
VARF1:=COUNT(CROSS(多,均衡),2)=1;
VARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(ZAI,均衡,'主升'),COLORFF00FF;
{中轨:HHV(MA(H,13),13),COLORRED,LINETHICK2;}
{趋势123:LLV(MA(H,13),1),COLORGREEN,LINETHICK2;}
主升:=if(ZAI,1,0),colorwhite;
{趋势}
MA15:=EMA(CLOSE,21);
STICKLINE((MA15 > REF(MA15,1)),MA15,MA15,9,6),LINETHICK4,Color00FFFF;
STICKLINE((MA15 < REF(MA15,1)),MA15,MA15,9,6),LINETHICK2,colorFF0000;
{k线}
FO:=OPEN;
FH:=HIGH;
FL:=LOW;
FC:=CLOSE;
KK:=IF(FC>=FO AND (FC>=REF(FC,1) OR REF(FC,1)>=REF(FO,1)),1,IF(FC<FO AND (FC<REF(FO,1) OR REF(FC,1)<REF(FO,1)),-1,0));
STICKLINE(FC>FO,FH,FL,0.4,0),colorFF;
STICKLINE(KK=1 AND FC>=FO,FO,FC,8,0),colorFF;
STICKLINE(KK=1 AND FC<FO,FO,FC,8,0),colorFF;
STICKLINE(KK=0 AND FC>=FO,FO,FC,8,0),colorFF;
STICKLINE(KK=0 AND FC<FO,FO,FC,8,0),colorFF;
{趋势向下k线染灰}
STICKLINE((MA15 < REF(MA15,1)),h,l,0.4,0),Colorgray;
STICKLINE((MA15 < REF(MA15,1)),c,o,8,0),Colorgray;
{k线涂粉关注}
STICKLINE(MA15 < REF(MA15,1) and (FC>FO),FH,FL,0.4,0),ColorFF80FF;
STICKLINE(KK=1 AND FC>=FO and ma15 < ref(ma15,1),FO,FC,8,0),ColorFF80FF;
STICKLINE(KK=1 AND FC<FO and ma15 < ref(ma15,1),FH,FL,0.4,0),ColorFF80FF;
STICKLINE(KK=1 AND FC<FO and ma15 < ref(ma15,1),FO,FC,8,0),ColorFF80FF;
STICKLINE(KK=0 AND FC>=FO and ma15 < ref(ma15,1),FH,FL,0.4,0),ColorFF80FF;
STICKLINE(KK=0 AND FC>=FO and ma15 < ref(ma15,1),FO,FC,8,0),ColorFF80FF;
STICKLINE(KK=0 AND FC<FO and ma15 < ref(ma15,1),FH,FL,0.4,0),ColorFF80FF;
STICKLINE(KK=0 AND FC<FO and ma15 < ref(ma15,1),FO,FC,8,0),ColorFF80FF;
{霸王庄}
主力持仓:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
指数趋势:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
强弱分界:=80;
主力筹码集中度:=WINNER(C)*100;
散筹筹码集中度:=(WINNER(C*1.1)-WINNER(C*0.9))*100;
qiang:=(主力持仓-散筹筹码集中度)>20 and (主力筹码集中度-散筹筹码集中度)>0 and 主力持仓>50;
强庄坐镇:if(qiang,1,0),colorred,linethick0;
DRAWTEXT(强庄坐镇,(LOW * 0.99),'☉'),Coloryellow;
●霸王庄●:if(qiang and 主力筹码集中度-散筹筹码集中度>20,1,0),ColorFF80FF,linethick0;;
DRAWTEXT(●霸王庄●,(LOW * 0.99),'⊙'),Colorred;
{神秘均线}
LOCK:=IF(CURRENTDATE<1120923,1,0);
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,6)>REF(EMA((2*CLOSE+HIGH+LOW)/4,6),1),EMA((2*CLOSE+HIGH+LOW)/4,5)),colorFF;
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,6)<REF(EMA((2*CLOSE+HIGH+LOW)/4,6),1),EMA((2*CLOSE+HIGH+LOW)/4,5)),colorFF00;
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,10)>REF(EMA((2*CLOSE+HIGH+LOW)/4,13),1),EMA((2*CLOSE+HIGH+LOW)/4,13)),colorFF;
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,10)<REF(EMA((2*CLOSE+HIGH+LOW)/4,13),1),EMA((2*CLOSE+HIGH+LOW)/4,13)),LINETHICK2,colorFF00;
PARTLINE(EMA((LOW+CLOSE+OPEN)/3,28)>REF(EMA((LOW+CLOSE+OPEN)/3,28),1),REF(EMA((LOW+CLOSE+OPEN)/3,25),1)),LINETHICK3,colorFF;
PARTLINE(EMA((LOW+CLOSE+OPEN)/3,28)<REF(EMA((LOW+CLOSE+OPEN)/3,28),1),REF(EMA((LOW+CLOSE+OPEN)/3,25),1)),LINETHICK3,colorff00;
PARTLINE((EMA(LOW,250)+EMA((CLOSE+LOW)/2,300))/2>REF((EMA(LOW,250)+EMA((CLOSE+LOW)/2,300))/2,1),(EMA(LOW,250)+EMA((CLOSE+LOW)/2,250))/2),linethick4,colorFF;
PARTLINE((EMA(LOW,250)+EMA((CLOSE+LOW)/2,300))/2<REF((EMA(LOW,250)+EMA((CLOSE+LOW)/2,300))/2,1),(EMA(LOW,250)+EMA((CLOSE+LOW)/2,250))/2),linethick4,colorgray;
小趋势线:ma15,coloryellow,linethick0;
小趋势成立:if(MA15 > REF(MA15,1),1,0),linethick0,coloryellow;
大趋势线:(EMA(LOW,250)+EMA((CLOSE+LOW)/2,300))/2,colorwhite,linethick0;
{立庄量}
VOLUME:=VOL,linethick0;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
V2:=IF(BARSTATUS=2,VOL*240/MINUTE/REF(VOL,1)-1,VOL/REF(VOL,1)-1),COLORRED;
STICKLINE(V2>=1,(llv(l,10)/2+hhv(h,10)/2),c,3,0),COLORYELLOW;
{财务指标}
毛利润率:=FINANCE(21)/FINANCE(20)*100;
主营业务增长率:=FINANCE(53);
净利润增长率:=FINANCE(55);
市盈率:=DYNAINFO(39);
市净率:=c/FINANCE(34);
莸利比例:=WINNER(c )*100;
净资产:=FINANCE(34);
净资收益率:=FINANCE(37);
{www.gUPang.com 股旁网_最新股票指标公式}
DRAWTEXTEX(c,1,10,253,'市盈率:'),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c,1,90,253,NUMTOSTR(市盈率,2)+''),ColorFFFFFF;
DRAWTEXTEX(c,1,150,253,'市净率:'),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c,1,230,253,NUMTOSTR(市净率,2)+''),ColorFFFFFF;
DRAWTEXTEX(c,1,10,85,'莸利比例:'),LINETHICK2,ColorAFFF00;
DRAWTEXTEX(c,1,90,85,NUMTOSTR(莸利比例,2)+'%'),ColorAFFF00;
DRAWTEXTEX(c,1,10,157,'主营业务增长率:'),LINETHICK2,Color00FFFF;
DRAWTEXTEX(c,1,170,157,NUMTOSTR(主营业务增长率,2)+'%'),Color00FFFF;
DRAWTEXTEX(c,1,260,157,'净利润增长率:'),LINETHICK2,Color00FFFF;
DRAWTEXTEX(c,1,390,157,NUMTOSTR(净利润增长率,2)+'%'),Color00FFFF;
DRAWTEXTEX(c,1,190,85,'净资产:'),LINETHICK2,ColorAFFF00;
DRAWTEXTEX(c,1,270,85,NUMTOSTR(净资产,2)+''),ColorAFFF00;
DRAWTEXTEX(c,1,370,85,'净资收益率:'),LINETHICK2,Colorgreen;
DRAWTEXTEX(c,1,485,85,NUMTOSTR(净资收益率,2)+'%'),Colorgreen;
DRAWTEXTex(c,1,10,20,'\n所属板块:'+BLKNAME),colorFFFFFF;

飞狐霸王庄主图指标公式

 

相关文章