在线检测未来函数

通达信成本多空布林主图指标公式

来源:Internet,编辑:股旁网,2011-07-08

VAR1:=AMOUNT/(100*VOL);
VAR2:=MA(VAR1,3);
VAR3:=MA(VAR1,6);
VAR4:=MA(VAR1,12);
VAR5:=MA(VAR1,24);
BBI: (VAR2+VAR3+VAR4+VAR5)/4;
UPR: BBI+3*STD(BBI,10);
DWN: BBI-3*STD(BBI,10);
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORAAAAAA;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORBBBBBB;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.2,0 ),COLORCCCCCC;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1.1,0 ),COLORDDDDDD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0 ),COLOR6666CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2 ,0 ),COLOR7777DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4 ,0 ),COLOR8888EE;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.1 ,0 ),COLOR9999FF;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.3,0 ),COLOR1199FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.3 ,0 ),COLOR1199FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.3 ,0 ),COLORCCCCCC;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.3 ,0 ),COLORCCCCCC;
跌停:=REF(C,1)/C>=1.0996;
STICKLINE(跌停,OPEN,CLOSE,4,0),COLORGREEN;
STICKLINE(跌停,OPEN,CLOSE,3,0),COLORBLUE;
STICKLINE(跌停,H,L,0,0),COLORBLUE;
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
{www.gUPang.com 股旁网_最新股票指标公式}
STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.05,'进'),COLORYELLOW;
STICKLINE(买,OPEN,CLOSE,6,0),COLORYELLOW;
A:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
A0:=(AH-AL)/40;
B1:=L-A0;
STICKLINE((A+0)/34=FLOOR((A+0)/34),B1,B1-1.5*A0,3,0),COLORF00FF0;
DRAWTEXT((A+0)/34=FLOOR((A+0)/34),B1-1*A0,'时间窗'),COLORWHITE;
DRAWTEXT(HIGH>REF(HIGH,1) AND REF(HIGH,2)>REF(HIGH,1) AND LOW>REF(LOW,1) AND REF(LOW,2)>REF(LOW,1) AND MA(CLOSE,5)<MA(CLOSE,10) , LOW, '拐点') ,COLORRED;
DRAWTEXT(HIGH<REF(HIGH,1) AND LOW<REF(LOW,1) AND REF(HIGH,2)<REF(HIGH,1) AND REF(LOW,2)<REF(LOW,1) AND MA(CLOSE,5)>MA(CLOSE,10), HIGH, '拐点') ,COLOR00C800;
量顶:=FILTER(V>0.9*HHV(V,150),3)=1;
DRAWTEXT(量顶,1.06*H,'量'),COLORFFAA00;
DRAWTEXT(量顶,1.02*H,'顶'),COLORFFAA00;
理:=EMA(HHV(HIGH,1),8);
想:=EMA(CLOSE,8);
论:=((想 < REF(想,1)) AND (CLOSE < 想));
坛:=IF(((理 < REF(理,1)) OR 论),1,0);
理想论坛出击:=((((COUNT((坛 = 1),4) = 3) AND (坛 = 0)) AND (((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) > 0.085)) * 89);
DRAWICON((理想论坛出击 >=89),L*0.97,1);
DRAWTEXT((理想论坛出击 >=89),L*0.97,'理想论坛出击'),COLORYELLOW;
STICKLINE((理想论坛出击 >=89),H,L,6,0),LINETHICK1,COLORRED;
STICKLINE((理想论坛出击 >=89),H,L,0.2,0),COLORYELLOW;
STICKLINE((理想论坛出击 >=89),O,C,2,0),LINETHICK1,COLORYELLOW;
DRAWICON((理想论坛出击 >=89),(H+L)/2,7);

通达信成本多空布林主图指标公式

 

相关文章