在线检测未来函数

飞狐分割角度主图指标公式

来源:Internet,编辑:股旁网,2011-07-10

INPUT:n(13,1,999),n1(2,1,3),上角(11,0,500),下角(11,0,500);
DRAWGBK(CLOSE,COLORRGB(50,100,120),0,1);
DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,'板块:'+BLKNAME),Color0095BC,align4;
u1:=SYSPARAM(3);
u:=u1-SYSPARAM(2)+1;
hh:=HHV(HIGH,u);
ll:=LLV(LOW,u);
最高:hh[u1],ColorC0C0C0;
最低:ll[u1],ColorC0C0C0;
PARTLINE(CLOSE and n1<>3,最低),COLORred;
PARTLINE(CLOSE and n1=1,最低+(最高-最低)*0.191),LINEDOT,COLORWHITE;
PARTLINE(CLOSE and n1=1,最低+(最高-最低)*0.382),LINEDOT,COLORWHITE;
PARTLINE(CLOSE and n1<>3,最低+(最高-最低)*0.5),ColorFF8200;
PARTLINE(CLOSE and n1=1,最低+(最高-最低)*0.618),LINEDOT,COLORWHITE;
PARTLINE(CLOSE and n1=1,最低+(最高-最低)*0.809),LINEDOT,COLORWHITE;
{www.gUPang.com 股旁网_最新股票指标公式}
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(3) and n1<>3,REF(最低,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'最低↓'),ALIGN2,COLORred;
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(3) and n1<>3,REF(最高,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'最高↑'),ALIGN2,COLORYELLOW;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=1,REF((最低+(最高-最低)*0.191)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'黄金 0.191↑'+NUMTOSTR(最低+(最高-最低)*0.191,2)),COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=1,REF((最低+(最高-最低)*0.382)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'黄金 0.382↑'+NUMTOSTR(最低+(最高-最低)*0.382,2)),COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1<>3,REF((最低+(最高-最低)*0.5)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM (2))),' 50% ↑'+NUMTOSTR(最低+(最高-最低)*0.5,2)),ColorFF8200;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=1,REF((最低+(最高-最低)*0.618)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'黄金 0.618↑'+NUMTOSTR(最低+(最高-最低)*0.618,2)),COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(2) and n1=1,REF((最低+(最高-最低)*0.809)*0.996,BARSLAST(BARSCOUNT(CLOSE)=SYSPARAM(2))),'黄金 0.809↑'+NUMTOSTR(最低+(最高-最低)*0.809,2)),COLORWHITE;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*1/8),LINEDOT,Color0095BC;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*1/4),LINEDOT,Color0095BC;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*3/8),LINEDOT,Color0095BC;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*5/8),LINEDOT,Color0095BC;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*7/8),LINEDOT,Color0095BC;
PARTLINE(CLOSE and n1=2,最低+(最高-最低)*3/4),LINEDOT,Color0095BC;
k3:=CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1);
STICKLINE(k3,HIGH,LOW,0.1,0),colorred;
STICKLINE(k3,OPEN,CLOSE,7,1),colorred;
STICKLINE(NOT(k3),HIGH,LOW,0.1,0),colorcyan;
STICKLINE(NOT(k3),CLOSE,OPEN,7,0),colorcyan;
N日:=n*10;
p1:=CLOSE-REF(CLOSE,1); p2:=SUM(ABS(p1),0); p3:=COUNT(CLOSE>0,0);
k1:=p2/p3/上角*10; k2:=p2/p3/下角*10;
DRAWSL(FILTER(BACKSET(ISLASTBAR,HHVBARS(HIGH,N日)+1),N日),HIGH,-0.5*K2,0,0),COLOR33FFCC,POINTDOT;
DRAWSL(FILTER(BACKSET(ISLASTBAR,HHVBARS(HIGH,N日)+1),N日),HIGH, -K2,0,0),COLOR33FFCC,POINTDOT;
DRAWSL(FILTER(BACKSET(ISLASTBAR,HHVBARS(HIGH,N日)+1),N日),HIGH,-2*K2,0,0),COLOR33FFCC;
DRAWSL(FILTER(BACKSET(ISLASTBAR,HHVBARS(HIGH,N日)+1),N日),HIGH,-4*K2,0,0),COLOR33FFCC,POINTDOT;
DRAWSL(FILTER(BACKSET(ISLASTBAR,HHVBARS(HIGH,N日)+1),N日),HIGH,-8*K2,0,0),COLOR33FFCC,POINTDOT;
DRAWSL(FILTER(BACKSET(ISLASTBAR,LLVBARS(LOW,N日)+1),N日),LOW,0.5*K1,0,0),COLORffCCff,POINTDOT;
DRAWSL(FILTER(BACKSET(ISLASTBAR,LLVBARS(LOW,N日)+1),N日),LOW,
K1,0,0),COLORffCCff,POINTDOT;
DRAWSL(FILTER(BACKSET(ISLASTBAR,LLVBARS(LOW,N日)+1),N日),LOW,2*K1,0,0),COLORffCCff;
DRAWSL(FILTER(BACKSET(ISLASTBAR,LLVBARS(LOW,N日)+1),N日),LOW,4*K1,0,0),COLORffCCff,POINTDOT;
DRAWSL(FILTER(BACKSET(ISLASTBAR,LLVBARS(LOW,N日)+1),N日),LOW,8*K1,0,0),COLORffCCff,POINTDOT;

飞狐分割角度主图指标公式

 

相关文章