在线检测未来函数

同花顺黑马摇篮指标公式

来源:Internet,编辑:股旁网,2011-07-15

n:=5;
Va6:=(2*CLOSE+HIGH+LOW)/4;
Va8:=LLV(LOW,34);
VarB:=HHV(HIGH,34);
VarC:=EMA((Va6-Va8)/(VarB-Va8)*100,13);
VarD:=EMA(0.667*REF(VarC,1)+0.333*VarC,2);
生命线:EMA(VarD,N), coloryellow,linethick1;
var1:=HHV(HIGH,9)-LLV(LOW,9);
var2:=HHV(HIGH,9)-CLOSE;
var3:=CLOSE-LLV(LOW,9);
var4:=((var2)/(var1))*(100)-70;
var5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
var6:=((2)*(CLOSE)+HIGH+LOW)/(4);
var7:=SMA(((var3)/(var1))*(100),3,1);
var8:=LLV(LOW,34);
var9:=SMA(var7,3,1)-SMA(var4,9,1);
var10:=IF((var9>100),var9-100,0);
var11:=HHV(HIGH,34);
b1:=EMA(((var6-var8)/(var11-var8))*(100),8);
b2:=EMA(b1,5);
bu1:=CROSS(b1,b2) AND 生命线<30;
sel1:=CROSS(b2,b1) AND 生命线>70;
STICKLINE(b1-b2>0,b1,b2,4,0),colorred;
STICKLINE(b1-b2<0,b1,b2,4,0),colorgreen;
ss1:=(LOW+HIGH+CLOSE*2)/4;
ss2:= MA(ss1,4);
ss3:=HHV(ss2,10);
ss4:=MA(ss3,3);
ss5:=1.25*ss4-0.25*ss3;
xkkj:=IF(ss5>ss3,ss3,ss5);
ccr1:=LLV(ss2,10);
ccr2:=MA(ccr1,3);
ccr3:=1.25*ccr2-0.25*ccr1;
dkkj:=IF(ccr3 < ccr1 , ccr1 , ccr3 );
ma13:=MA(C,13);
zdhm:=CROSS(C,dkkj) AND CROSS(C,ma13) AND CROSS(C,xkkj);
zhm:=CROSS(C,ma13) AND CROSS(C,xkkj);
dhm:=IF(zdhm OR zhm AND EMA(VarD,N)<=20,50,0);
黑马:dhm,colorred;
a:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*a+19*REF(a,1)+18*REF(a,2)+17*REF(a,3)+16*REF(a,4)+15*REF(a,5)+14*REF(a,6)
+13*REF(a,7)+12*REF(a,8)+11*REF(a,9)+10*REF(a,10)+9*REF(a,11)+8*REF(a,12)
+7*REF(a,13)+6*REF(a,14)+5*REF(a,15)+4*REF(a,16)+3*REF(a,17)+2*REF(a,18)+
REF(a,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
xhm:=IF(CROSS(D1,K1) AND EMA(VarD,N)<=50,45,0);
小黑马:xhm,Colorff00ff;
DRAWTEXT(bu1 OR xhm OR dhm,30,'▲'),colorred;
DRAWTEXT(sel1,60,'▼'),colorgreen;
SELECT bu1 OR xhm OR dhm;

同花顺黑马摇篮指标公式

 

相关文章