在线检测未来函数

通达信斋主量交+DDX指标公式

来源:Internet,编辑:股旁网,2011-07-16

N:=5;
M:=13;
N日内净流入:=SUM(DDX,N)*3;
万手:VOL/10000,LINETHICK0;
AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
预测:AA/10000;
BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主买:主动买/10000,COLORRED;
主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));
主卖:-主动卖/10000,COLORGREEN;
差额:=(主动买+主动卖)/10000;
STICKLINE(CLOSE=REF(CLOSE,1),0,VOL,3.5,0),COLORWHITE;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,3.5,0),COLORRED;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,3.5,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.5 , 0 ) , COLOR00FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.2 , 0 ) , COLOR007777 ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.7 , 0 ) , COLOR009999 ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.1 , 0 ) , COLOR00BBBB ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 1.5 , 0 ) , COLOR00DDEE ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.9 , 0 ) , COLOR66FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.2 , 0 ) , COLORFFFFFF ;
STICKLINE(主动买>=0,VOL,-主动卖,3.2,0),COLOR000033;
STICKLINE(主动买>=0,VOL,-主动卖,2.7,0),COLOR000066;
STICKLINE(主动买>=0,VOL,-主动卖,2.1,0),COLOR000099;
STICKLINE(主动买>=0,VOL,-主动卖,1.5,0),COLOR0000CC;
STICKLINE(主动买>=0,VOL,-主动卖,0.9,0),COLOR0000FF;
STICKLINE(主动买>=0,VOL,-主动卖,0.2,0),COLORCC66FF;
STICKLINE(主动卖<=0,0,-主动卖,3.2,0),COLOR990000;
STICKLINE(主动卖<=0,0,-主动卖,2.7,0),COLORCC0000;
STICKLINE(主动卖<=0,0,-主动卖,2.1,0),COLORFF4400;
STICKLINE(主动卖<=0,0,-主动卖,1.5,0),COLORFF8800;
STICKLINE(主动卖<=0,0,-主动卖,0.9,0),COLORFFCC00;
STICKLINE(主动卖<=0,0,-主动卖,0.2,0),COLORCYAN;
持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORBLUE;
持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED;
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘:=(V9+V8);
卖盘:=(V6+V7);
买卖差:=买盘-卖盘;
DDX:=买卖差;
DX:=MA(买卖差,5)*20;
DDX1:SMA(DX,3,1),COLORFFFFFF;
DDX2:SMA(DDX1,3,1),COLOR00FFFF;
DDX3:(5*DDX2+4*REF(DDX2,1)+3*REF(DDX2,2)+2*REF(DDX2,3)+REF(DDX2,4))/15;
预警:DDX>0 AND MA(V,5)>MA(MA(V,5),5) AND CROSS(DDX1,DDX2),LINETHICK;
天:=COUNT(DDX>0,5),COLORRED;
{www.gUPang.com 股旁网_最新股票指标公式}
DRAWTEXT(预警,DDX*1.5,'★'),LINETHICK3,COLOR00FFFF;
五日: MA(V,5)COLORLIGRAY,LINETHICK2;
十日: MA(V,10)COLORCYAN,LINETHICK2;
二十日:MA(V,20),COLORRED,LINETHICK2;
{三十日:MA(V,30)*1.2,COLORLIBLUE;}
{50_DDX}
流入:=IF(N日内净流入>REF(N日内净流入,1),N日内净流入,DRAWNULL);
DRAWBAND(N日内净流入,RGB(100,100,100),0,RGB(0,100,150));
{波段转向}{5天3%}
DLX1:=SMA(DX,3,1),LINETHICK,COLORWHITE;
RSV:=((C-LLV(L,6))/(HHV(H,6)-LLV(L,6)))*100;
K:=POW(SMA(RSV,2,1),5)/POW(10,8);
D:=POW(SMA(RSV,2,1),5)/POW(10,10);
J:=(K+ D)/2;
花开短买:IF(CROSS(J,1),1,0) AND DLX1>REF(DLX1,1),COLORYELLOW;
IF(花开短买,150000,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF33FF;
IF(花开短买,150000,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
RSI1:=N日内净流入;
AAZ:=REF(RSI1,N)=HHV(RSI1,2*N+1);
BBZ:=BACKSET(AAZ,N+1);
CC:=FILTER(BBZ,N) AND RSI1=HHV(RSI1,N+1);
A1:=BARSLAST(REF(CC,1));
{STICKLINE(DDX<0,0,DDX,4,0),COLOR006600;}
STICKLINE(DDX<0,0,DDX,3,0),COLOR009900;
STICKLINE(DDX<0,0,DDX,1.5,0),COLOR00CC00;
STICKLINE(DDX<0,0,DDX,0,0),COLOR66CCFF;
STICKLINE(DDX>0,0,DDX,3,0),{COLOR0000CC}COLORYELLOW;
STICKLINE(DDX>0,0,DDX,1.5,0),COLORYELLOW;{COLOR0000FF};
STICKLINE(DDX>0,0,DDX,0,0),COLORCC66FF;
背离:REF(CLOSE,A1+1)<CLOSE AND REF(RSI1,A1+1)>RSI1 AND CC,COLORRED;
DRAWLINE(CC,RSI1,FILTER(顶背离>0,5),RSI1,0),COLORRED;
AA2:=REF(RSI1,N)=LLV(RSI1,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND RSI1=LLV(RSI1,N+1);
A2:=BARSLAST(REF(CC2,1));
底背离:REF(CLOSE,A2+1)>CLOSE AND REF(RSI1,A2+1)<RSI1 AND CC2,COLORCYAN;
DRAWLINE(CC2,RSI1,FILTER(底背离>0,5),RSI1,0),COLORCYAN;

通达信斋主量交+DDX指标公式

 

相关文章