在线检测未来函数

飞狐回抽支撑指标公式

来源:Internet,编辑:股旁网,2011-07-20

WR1:=100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
WR2:=100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6));
涨:WR2<10,POINTDOT,COLORRED;
跌:WR2>80,POINTDOT,COLORWHITE;
DRAWTEXT(涨>0 ,7 , '$'),COLORRED;
DRAWTEXT(跌>0 ,1 , '#'),COLORWHITE;
P1:=5;P2:=10;P3:=20;P4:=30;P5:=60;P6:=120;
MA1:=MA(C,P1),COLORYELLOW;
MA2:=MA(C,P2),COLORFF00FF;
MA3:=MA(C,P3),COLOR00FF00;
MA4:=MA(C,P4),COLORWHITE;
MA5:=MA(C,P5),COLORFF9900;
MA6:=MA(C,P6),COLOR0000FF;
{ENV轨道线支撑}
UPPER:=(1+6/100)*MA(CLOSE,25);
LOWER:=(1-6/100)*MA(CLOSE,25);
MID:=(UPPER+LOWER)/2,COLORYELLOW,LINETHICK2;
生命线:=MID,COLORYELLOW,POINTDOT,LINETHICK2;
DTPLENV:=COUNT(MID>REF(MID,1),5)=5;
回:=((CROSS(MID,L) OR CROSS(MID,C)) AND DTPLENV)*1,COLORYELLOW,POINTDOT;
{MA2支撑}
QSXS2:=MA2>=REF(MA2,1);
DTPL2:=MA1>MA2 AND MA2>MA3 AND MA3>MA4;
ZWP2:=COUNT(C>MA2,P1)=P1 AND DTPL2;
HCP2A:=CROSS(MA2*1.02,L) AND REF(ZWP2,1);
HCP2B:=CROSS(MA2,C) AND REF(ZWP2,1);
回2:=((HCP2A OR HCP2B) AND QSXS2 AND DTPL2)*3,COLOR00FF00,POINTDOT;
{MA3支撑}
QSXS3:=MA3>=REF(MA3,1);
DTPL3:=MA1>MA2 AND MA2>MA3 AND MA3>MA4;
ZWP3:=COUNT(C>MA3,P1)=P1 AND DTPL3;
HCP3A:=CROSS(MA3*1.03,L) AND REF(ZWP3,1);
HCP3B:=CROSS(MA3,C) AND REF(ZWP3,1);
回3:=((HCP3A OR HCP3B) AND QSXS3)*3,COLOR00FF00,POINTDOT;
{MA4支撑}
QSXS4:=MA4>=REF(MA4,1);
DTPL4:=MA2>MA3 AND MA3>MA4 AND MA4>MA5;
ZWP4:=COUNT(C>MA4,P2)=P2 AND DTPL4;
HCP4A:=CROSS(MA4*1.04,L) AND REF(ZWP4,1);
HCP4B:=CROSS(MA4*1.02,C) AND REF(ZWP4,1);
回4:=((HCP4A OR HCP4B) AND QSXS4)*4,COLORWHITE,POINTDOT;
{MA5支撑}
QSXS5:=MA5>=REF(MA5,1);
DTPL5:=MA3>MA4 AND MA4>MA5 AND MA5>MA6;
ZWP5:=COUNT(C>MA5,P3)=P3 AND DTPL5;
HCP5A:=CROSS(MA5*1.05,L) AND REF(ZWP5,1);
HCP5B:=CROSS(MA5*1.02,C) AND REF(ZWP5,1);
回5:=((HCP5A OR HCP5B) AND QSXS5)*5,COLORFF9900,POINTDOT;
{MA6支撑}
QSXS6:=MA6>=REF(MA6,1);
DTPL6:=MA5>MA6;
ZWP6:=COUNT(C>MA6,P3)=P3 AND DTPL6;
HCP6A:=CROSS(MA6*1.05,L) AND REF(ZWP6,1);
HCP6B:=CROSS(MA6*1.02,C) AND REF(ZWP6,1);
回6:=((HCP6A OR HCP6B) AND QSXS6)*6,COLORRED,POINTDOT;
买:COUNT(回>0,2)>=1 AND ABS(L/MID-1)*100<=2,COLORYELLOW,POINTDOT;
买2:COUNT(回2>0,2)>=1 AND ABS(L/MA2-1)*100<=2,COLORFF00FF,POINTDOT;
买3:COUNT(回3>0,2)>=1 AND ABS(L/MA3-1)*100<=2,COLOR00FF00,POINTDOT;
买4:COUNT(回4>0,2)>=1 AND ABS(L/MA4-1)*100<=2,COLORWHITE,POINTDOT;
买5:COUNT(回5>0,2)>=1 AND ABS(L/MA5-1)*100<=2,COLORFF9900,POINTDOT;
买6:COUNT(回6>0,2)>=1 AND ABS(L/MA6-1)*100<=2,COLORRED,POINTDOT;
MBZ:=买 OR 买2 OR 买3 OR 买4 OR 买5 OR 买6;
QSXS:=DTPL4 AND MA3>REF(MA3,1) AND MA4>REF(MA4,1);
YX:=跌 AND MBZ AND QSXS AND COUNT(V<REF(V,1),4)>=2 AND COUNT(C<REF(C,1),3)>=2;
优选:(YX OR (REF(YX,1) AND C<REF(C,1)))*5,COLOR00FF00;
{以下设置副图显示方式}
1,POINTDOT,COLORYELLOW;
2,POINTDOT,COLORFF00FF;
3,POINTDOT,COLOR00FF00;
4,POINTDOT,COLORWHITE;
5,POINTDOT,COLORFF9900;
6,POINTDOT,COLORRED;
7,POINTDOT,color00FF00;
{www.gUPang.com 股旁网_最新股票指标公式}
STICKLINE(买>0,1,2,4,0),COLORYELLOW;
STICKLINE(买2>0,2,3,4,0),COLORFF00FF;
STICKLINE(买3>0,3,4,4,0),COLOR00FF00;
STICKLINE(买4>0,4,5,4,0),COLORWHITE;
STICKLINE(买5>0,5,6,4,0),COLORFF9900;
STICKLINE(买6>0,6,7,4,0),COLORRED;
DRAWTEXT(回>0 ,1 , '⊙'),COLORYELLOW;
DRAWTEXT(回2>0 ,2 , '②'),COLORFF00FF;
DRAWTEXT(回3>0 ,3 , '③'),COLOR00FF00;
DRAWTEXT(回4>0 ,4 , '④'),COLORWHITE;
DRAWTEXT(回5>0 ,5 , '⑤'),COLORFF9900;
DRAWTEXT(回6>0 ,6 , '⑥'),COLORRED;
{以下设置主图显示方式}
{DRAWTEXT(回>0 ,MID , '⊙'),COLORYELLOW;
DRAWTEXT(回2>0 ,MA2 , '②'),COLORFF00FF;
DRAWTEXT(回3>0 ,MA3 , '③'),COLOR00FF00;
DRAWTEXT(回4>0 ,MA4 , '④'),COLORWHITE;
DRAWTEXT(回5>0 ,MA5 , '⑤'),COLORFF9900;
DRAWTEXT(回6>0 ,MA6 , '⑥'),COLORRED;
DRAWTEXT(买>0 ,L*0.99 , '★'),COLORYELLOW;
DRAWTEXT(买2>0 ,L*0.98 , '□'),COLORFF00FF;
DRAWTEXT(买3>0 ,L*0.99 , '▲'),COLOR00FF00;
DRAWTEXT(买4>0 ,L*0.98 , '◆'),COLORWHITE;
DRAWTEXT(买5>0 ,L*0.99 , '■'),COLORFF9900;
DRAWTEXT(买6>0 ,L*0.98 , '●'),COLORRED;
支撑点:IF(COUNT(ZC3>0,5),REF(L,HCSJ3),REF(L,HCSJ3)),COLOR00FF00,POINTDOT,linethick1;}

飞狐回抽支撑指标公式

 

相关文章