在线检测未来函数

通达信黑马全息指标公式

来源:Internet,编辑:股旁网,2011-07-20

上:=(SMA(HIGH,13,2) *1.5);
下轨道:=(SMA(LOW,13,2) * 0.3),POINTDOT,COLORFFFF00;
阻挡:=(SMA(HIGH,13,2) * 1.5);
RSV:=(((CLOSE - LLV(LOW,7)) / (HHV(HIGH,7) - LLV(LOW,7))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV12:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=((3 * K12) - (2 * D12));
RSV24:=(((CLOSE - LLV(LOW,24)) / (HHV(HIGH,24) - LLV(LOW,24))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
支撑位:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24))));
压力位:=IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J)))),COLORFF00FF;
U2L:=IF((CLOSE >= MA(CLOSE,20)),80,50);
L2L:=IF((CLOSE >= MA(CLOSE,20)),50,20);
RH1:=IF(((J < U2L) AND (REF(J,1) >= U2L)),HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),BARSLAST(((J < U2L) AND REF(J,1)))));
RH4:=IF((HIGH > RH1),LOW,REF(LOW,BARSLAST((HIGH > RH1))));
RH42:=IF((HIGH > RH1),J,REF(J,BARSLAST((HIGH > RH1))));
RH5:=IF((((HIGH > RH4) AND (J < RH42)) AND (J < J24)),HIGH,REF(HIGH,BARSLAST((((HIGH > RH4) AND (J < RH42)) AND (J < J24)))));
RL1:=IF(((J > L2L) AND (REF(J,1) <= L2L)),LLV(REF(LOW,1),(BARSLAST(((J <= L2L) AND (REF(J,1) > L2L))) - 1)),REF(LLV(REF(LOW,1),(BARSLAST(((J <= L2L) AND (REF(J,1) > L2L))) - 1)),BARSLAST(((J > L2L) AND REF(J,1)))));
RL4:=IF((LOW < RL1),HIGH,REF(HIGH,BARSLAST((LOW < RL1))));
RL42:=IF((LOW < RL1),J,REF(J,BARSLAST((LOW < RL1))));
RL5:=IF((((LOW < RL4) AND (J > RL42)) AND (J > J24)),LOW,REF(LOW,BARSLAST((((LOW < RL4) AND (J > RL42)) AND (J > J24)))));
黑马趋势:=MA(CLOSE,3);
AA5:=MA(CLOSE,7);
AA10:=MA(CLOSE,4),COLORFF0000;
追击:FILTER(((((((CLOSE / OPEN) >1.04) AND ((CLOSE - REF(CLOSE,1)) > 0)) AND (CLOSE > 下轨道)) AND ((AA10 - REF(AA10,1)) > 0)) AND (CLOSE < 上)),3),LINETHICK0;
STICKLINE(FILTER(((((((CLOSE / OPEN) > 1.04) AND ((CLOSE - REF(CLOSE,1)) > 0)) AND (CLOSE > 下轨道)) AND ((AA10 - REF(AA10,1)) > 0)) AND (CLOSE < 上)),3),8,0,3,0),COLORRED;
DRAWTEXT(FILTER(((((((CLOSE / OPEN) > 1.04) AND ((CLOSE - REF(CLOSE,1)) > 0)) AND (CLOSE > 下轨道)) AND ((AA10 - REF(AA10,1)) > 0)) AND (CLOSE < 上)),3),8,'追击'),COLORD1E768;
VARD:=((((OPEN + LOW) + HIGH) + CLOSE) / 3);
支撑:=EMA(VARD,5);
短期底部:=LLV(OPEN,30);
机会难得:FILTER((((((((LOW <= 短期底部) AND ((CLOSE - REF(CLOSE,1)) > CLOSE)) AND ((MA(CLOSE,10) - REF(MA(CLOSE,10),1)) > 0)) AND (WINNER(CLOSE) < 0.05)) AND (短期底部 = RL5)) AND (LOW <= RL5)) AND (HIGH < 压力位)),3)*8,LINETHICK0;
STICKLINE(FILTER((((((((LOW <= 短期底部) AND ((CLOSE - REF(CLOSE,1)) > CLOSE)) AND ((MA(CLOSE,10) - REF(MA(CLOSE,10),1)) > 0)) AND (WINNER(CLOSE) < 0.05)) AND (短期底部 = RL5)) AND (LOW <= RL5)) AND (HIGH < 压力位)),3),8,0,8,0),COLORYELLOW;
DRAWTEXT(FILTER((((((((LOW <= 短期底部) AND ((CLOSE - REF(CLOSE,1)) > CLOSE)) AND ((MA(CLOSE,10) - REF(MA(CLOSE,10),1)) > 0)) AND (WINNER(CLOSE) < 0.05)) AND (短期底部 = RL5)) AND (LOW <= RL5)) AND (HIGH < 压力位)),3),8,'★机会难得'),COLORFFFFFF;
历史大底:FILTER((((((LLV(LOW,0) AND (WINNER(CLOSE) < 0.08)) AND (LOW <= 短期底部)) AND (CLOSE > 短期底部)) AND (J < 80)) AND ((CLOSE / OPEN) > 1.08)),20)*12,LINETHICK1 ,COLORGREEN;
STICKLINE(FILTER((((((LLV(LOW,0) AND (WINNER(CLOSE) < 0.08)) AND (LOW <= 短期底部)) AND (CLOSE > 短期底部)) AND (J < 80)) AND ((CLOSE / OPEN) > 1.08)),20),12,0,8,0),COLORGREEN;
DRAWTEXT(FILTER((((((LLV(LOW,0) AND (WINNER(CLOSE) < 0.08)) AND (LOW <= 短期底部)) AND (CLOSE > 短期底部)) AND (J < 80)) AND ((CLOSE / OPEN) > 1.08)),20),LOW,'★★历史大底'), COLORGREEN;
黑马登天:FILTER(((((((((LOW <= 短期底部) AND (CLOSE > 压力位)) AND ((AA5 - REF(AA5,1)) > 0)) AND (J < 80)) AND (CLOSE > 支撑位)) AND ((黑马趋势 - REF(黑马趋势,1)) > 0)) AND (WINNER(CLOSE) < 0.1)) AND (CLOSE > OPEN)),5)*15,LINETHICK0;
DRAWTEXT(FILTER(((((((((LOW <= 短期底部) AND (CLOSE > 压力位)) AND ((AA5 - REF(AA5,1)) > 0)) AND (J < 80)) AND (CLOSE > 支撑位)) AND ((黑马趋势 - REF(黑马趋势,1)) > 0)) AND (WINNER(CLOSE) < 0.1)) AND (CLOSE > OPEN)),5),(LOW - 0.15),'★黑马登天'),COLORCDEEC5;
X1:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);
X2:=EMA(X1,10);
均线:=MA(CLOSE,7);
均线13:=MA(CLOSE,13);
均线24:=MA(CLOSE,24);
VA:=CROSS(MA(CLOSE,7),MA(CLOSE,24));
跳马:FILTER(((((((((OPEN > 均线24) AND (均线13 < 均线24)) AND (LOW <= 均线24)) AND ((均线13 - REF(均线13,1)) > 0)) AND (CLOSE > OPEN)) AND ((均线24 - REF(均线24,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= 均线24)),15)*5,COLOR00FF00 ,LINETHICK0;
DRAWTEXT(FILTER(((((((((OPEN > 均线24) AND (均线13 < 均线24)) AND (LOW <= 均线24)) AND ((均线13 - REF(均线13,1)) > 0)) AND (CLOSE > OPEN)) AND ((均线24 - REF(均线24,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= 均线24)),15),LOW,'★跳马'),COLOR00FF00;
宝马望月:((((VA AND ((均线24 - REF(均线24,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE > OPEN)))*15,LINETHICK0;
DRAWTEXT((((VA AND ((均线24 - REF(均线24,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE > OPEN)),LOW,'★宝马望月'),COLORFFFFFF;
三线开花:((((((均线 - REF(均线,1)) > 0) AND CROSS(均线13,均线24)) AND (LOW <= 均线24)) AND (CLOSE >= 均线24)))*3,LINETHICK0;
DRAWTEXT((((((均线 - REF(均线,1)) > 0) AND CROSS(均线13,均线24)) AND (LOW <= 均线24)) AND (CLOSE >= 均线24)),LOW,'三线开花'),COLORFFFFFF;
{www.gUPang.com 股旁网_最新股票指标公式}
快马加鞭:FILTER(((((((((((OPEN < X2) AND (CLOSE > X2)) AND ((支撑 - REF(支撑,1)) > 0)) AND ((支撑 - REF(支撑,1)) > 0)) AND (CLOSE < 阻挡)) AND ((均线 - REF(均线,1)) > 0)) AND (CLOSE >= 均线)) AND (HIGH < 阻挡)) AND ((AA10 - REF(AA10,1)) > 0)) AND ((阻挡 - REF(阻挡,2)) > 0)),11)*8,LINETHICK0;
DRAWTEXT(FILTER(((((((((((OPEN < X2) AND (CLOSE > X2)) AND ((支撑 - REF(支撑,1)) > 0)) AND ((支撑 - REF(支撑,1)) > 0)) AND (CLOSE < 阻挡)) AND ((均线 - REF(均线,1)) > 0)) AND (CLOSE >= 均线)) AND (HIGH < 阻挡)) AND ((AA10 - REF(AA10,1)) > 0)) AND ((阻挡 - REF(阻挡,2)) > 0)),11),(LOW - 0.11),'★快马加鞭'),COLORFF0000;
黑马狂奔:FILTER(((((((OPEN < X2) AND (WINNER(CLOSE) < 0.2)) AND (CLOSE > X2)) AND ((X2 - REF(X2,1)) > 0)) AND (HIGH < 阻挡)) AND ((CLOSE - REF(CLOSE,1)) > 0.35)),4)*13,LINETHICK0,COLORFF00FF;
DRAWTEXT(FILTER(((((((OPEN < X2) AND (WINNER(CLOSE) < 0.2)) AND (CLOSE > X2)) AND ((X2 - REF(X2,1)) > 0)) AND (HIGH < 阻挡)) AND ((CLOSE - REF(CLOSE,1)) > 0.35)),4),(LOW - 0.05),'★黑马狂奔'),COLORFF00FF;

通达信黑马全息指标公式

 

相关文章