在线检测未来函数

飞狐黑马进场退场主图指标公式

来源:Internet,编辑:股旁网,2011-07-21

DRAWGBK(v>=0,COLORRGB(18,19,51),COLORRGB(1,105,155),0);
底部:=LLV(CLOSE,30);
MA3:=MA(底部,2);
X:=MA(CLOSE,26);
压力:=HHV(HIGH,30);
PARTLINE(MA3>=REF(MA3,1) AND CLOSE>=X AND CLOSE>MA3,MA3),LINETHICK3,colorFFFFFF;
PARTLINE(压力<=REF(压力,1) AND CLOSE<=X,压力),LINETHICK3,colorFFFFFF;
DRAWICON(C>=MA(CLOSE,18),MA(CLOSE,18),10);
DRAWICON(C<MA(CLOSE,18),MA(CLOSE,18),11);
Var0:=CROSS(MA(INDEXV,31),MA(INDEXV,2));
Var2:= MA((CLOSE-(MA(CLOSE,80)-MA(CLOSE,13)/3))/(MA(CLOSE,80)-MA(CLOSE,13)/3),1);
买点一:= IF(CROSS(Var2,0) AND LOW/REF(HIGH,1)<1.012,0.5,0);
买点二:= IF(COUNT(Var2>REF(Var2,1),3)=3 AND COUNT(Var2<0,10)=10 AND REF(Var2,3)=LLV(Var2,10),0.5,0);
买点三:= IF(REF(Var2,2)=LLV(Var2,20) AND REF(Var2,2)<0.071 AND REF(Var2,2)<REF(Var2,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),0.5,0);
var11:=(2*c+o+h+l)/5;
m8:=sum(var11*vol,8)/sum(vol,8);
主力:m8,COLORYELLOW,linethick;
散户:llv(主力, 8),linethick;
DRAWTEXT(散户=ref(散户,1),散户,' ┬ '),COLORWHITE,linethick2;
MA17:ma(C,17),coloryellow,linethick;
STICKLINE(C>MA17 and C>=O,C,O,8,1), COLORMAGENTA;
STICKLINE(C>MA17 and C>=O,O,L,1,1), COLORMAGENTA;
STICKLINE(C>MA17 and C>=O,C,H,1,1), COLORMAGENTA;
STICKLINE(C>MA17 and C<O,C,O,8,0), COLORMAGENTA;
STICKLINE(C>MA17 and C<O,C,H,1,1), COLORMAGENTA;
STICKLINE(C>MA17 and C<O,O,L,1,1), COLORMAGENTA;
STICKLINE(C<MA17 and C>=O,C,O,8,1), COLOR009300;
STICKLINE(C<MA17 and C>=O,O,L,1,1), COLOR009300;
STICKLINE(C<MA17 and C>=O,C,H,1,1), COLOR009300;
STICKLINE(C<MA17 and C<O,C,O,8,0), COLOR009300;
STICKLINE(C<MA17 and C<O,C,L,1,1), COLOR009300;
STICKLINE(C<MA17 and C<O,O,H,1,1), COLOR009300;
ggg:=MIN(CLOSE,OPEN);
突变:=v+ref(v,1)>=(ref(v,2)+ref(v,3)+ref(v,4)+ref(v,5)+ref(v,6))/5*3 and v<2*ref(v,1) and c>o and c>ma(c,21);
量能突变:stickline(突变,ABS(O-C)*0.8+ggg,ABS(O-C)*0.6+ggg,8,0),colorred;
配合:=ref(v,1)<max(ma(v,5),ma(v,10))and ref(v,1)<max(ma(v,20),ma(v,10))and v>max(ma(v,10),ma(v,20))and v>max(ma(v,5),ma(v,10)) and v<2*ref(v,1) and cross(c,ma(c,21));
量价配合:stickline(配合,ABS(O-C)*0.8+ggg,ABS(O-C)*0.6+ggg,8,0),coloryellow;
量底:stickline(v=llv(v,15),ABS(O-C)*0.2+ggg,ABS(O-C)*0.4+ggg,8,0),colorwhite;
突破:=c>=hhv(c,15) and v>=hhv(v,15);
量价突破:stickline(突破,ABS(O-C)*0.2+ggg,ABS(O-C)*0.4+ggg,8,0),COLORCYAN;
TC:=SMA(C,2,1);
DIFF :=EMA(TC,5) - EMA(TC,17);
DEA := EMA(DIFF,7);
MACD:=2*(DIFF-DEA);
drawtext(CROSS(0,MACD) AND REF(C,1)>=ma(c,5),h*1.08,'★'),colorBLUE,align1;
drawtext(CROSS(0,MACD) AND REF(C,1)>=ma(c,5),h*1.08,'☆'),colorWHITE,align1;
EMA18:=MA(C,18),COLORYELLOW;
中线买入】:=COUNT(CLOSE<EMA18,5)=4 AND CLOSE/EMA18>1.004 AND CROSS(CLOSE,EMA18) AND EMA18>=REF(EMA18,1),LINETHICK,COLORRED;
DRAWTEXT(中线【买入】,LOW*0.95,' 中线【买入】'),COLORRED;
VL:=REF(LOW,1);
VAR12:=(SMA(ABS(LOW-VL),13,1))/(SMA(MAX(LOW-VL,0),13,1))*100;
VAR14:=MA(VAR12,13);
VAR15:=LLV(LOW,34);
VAR18:=EMA(IF(LOW<=VAR15,VAR14,0),3);
VAR110:=SMA(SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1),5,1);
VAR111:=SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1)*16.18-VAR110*10.9;
Tjj:=FILTER(IF(VAR111<=VAR110 AND VAR18>REF(VAR18,1),VAR18*8,0),20);
{www.gUPang.com 股旁网_最新股票指标公式}
DRAWTEXT(Tjj,LOW-0.4,'←洗盘结束'),COLORFF00FF;
DRAWTEXT(Tjj,LOW-0.2,'|'),COLORFF00FF;
VAR21:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR22:=SMA(VAR21,3,1);
VAR23:=SMA(VAR22,3,1);
VAR24:=SMA(VAR23,3,1);
VAR25:=CROSS(VAR23,VAR24) AND VAR23<20;
DRAWTEXT(FILTER(VAR25,10)=1,LOW-0.4,'←抄底'),COLORRED;
DRAWTEXT(FILTER(VAR25,10)=1,LOW-0.2,'|'),COLORRED;
VAR29:=CROSS(VAR24,VAR23) AND VAR23>80;
DRAWTEXT(FILTER(VAR29,5)=1,HIGH+0.4,'←逃顶'),COLORBLUE;
DRAWTEXT(FILTER(VAR29,5)=1,HIGH+0.2,'|'),COLORBLUE;
A:=HHV(MA((LOW+HIGH+CLOSE)/3,3),3);
B:=LLV(MA((LOW+HIGH+CLOSE)/3,3),5);
DRAWTEXT(CLOSE>=A ,A*1.03,''),SHIFT1,colorFFFF;
DRAWTEXT(REF(CLOSE,1)<REF(A,1) AND CLOSE>=A ,low,'黑马进场'),colorFF;
DRAWTEXT(REF(CLOSE,1)>REF(A,1) AND CLOSE<A ,high,'黑马退场'),colorFF00;

飞狐黑马进场退场主图指标公式

 

相关文章