在线检测未来函数

信号成功率测试公式

来源:Internet,编辑:股旁网,2011-07-26

只要你的选股指标中选股符号是:XG(如果是别的选股符号,你可以将它改成“XG”符号)
就可以在原选股代码下面加上下面这段代码,就可以在副图上显示你手上选股指标的成功率了。
注:本例是统计在一年所有的选股次数和在三日内达到涨幅2%的成功次数,即成功率。
N:=3;{几日内达标,可以随意调,如10,15等}
M:=250;{统计多少日,一年为250日,也可以调成二年,为500}
P:=1.02;{制定涨幅,1.02为涨百分二.也可以调到1.10,即涨幅为百分之十}
一年内选股次数:SUM(XG,M),NODRAW;
三日内涨二点卖:HHV(H,N)>REF(C,N)*P AND REF(CROSS(XG,0.8),N);{显示成功符号}
一年内成功次数:SUM(三日内涨二点卖,M),NODRAW;
成功率:一年内成功次数/一年内选股次数,NODRAW;
实例:(见图)
{任一个选股代码,选股符号是:XG}
EM100:=EMA(EMA(C,2)-EMA(C,150),100);
EM100A:=2*(EMA(C,2)-EMA(C,150)-EM100);
EMP:=POW(EM100A,3)*0.1+POW(EM100A,1);
黑马线:=IF(EM100A>0.1,EMP,0)COLORMAGENTA,LINETHICK3;
JRS:=CROSS(黑马线,20);
XG:CROSS(JRS,0.8);{显示选股符号}
{统计选股成功率(此例统计在1年内,凡3日内涨幅达到2%的个股),
只要上面选股代码是"XG"就可以加下面一段代码进行统计}
N:=3;{几日内达标,可以随意调,如10,15等}
M:=250;{统计多少日,一年为250日,也可以调成二年,为500}
P:=1.02;{制定涨幅,1.02为涨百分二.也可以调到1.10,即涨幅为百分之十}
一年内选股次数:SUM(XG,M),NODRAW;
三日内涨二点卖:HHV(H,N)>REF(C,N)*P AND REF(CROSS(XG,0.8),N);{显示成功符号}
一年内成功次数:SUM(三日内涨二点卖,M),NODRAW;
成功率:一年内成功次数/一年内选股次数,NODRAW;{要选大于等于1的个股};
说明:当你选股的个股较多时,就要从中筛选出成功率高的个股,最好是大于等于1的个股。这样成功的希望就大了。

相关文章