在线检测未来函数

飞狐十九资金指标公式

来源:Internet,编辑:股旁网,2011-07-27

DRAWGBK((CLOSE > 0),COLORRGB(260,280,150),COLORRGB(260,280,0),2);
AAA:=CHECKUSER(1);
VAR1:=(SMA(AMOUNT,19,3) / 60000);
VAR2:=(MA(REF(CLOSE,1),5) / 60000);
VAR3:=(((VAR1 * CLOSE) / VAR2) / 5700000);
VAR4:=VAR3;
VAR5:=REF(VAR4,1);
VAR6:=REF(VAR4,2);
VAR7:=REF(VAR4,3);
VAR8:=REF(VAR4,4);
VAR9:=REF(VAR4,5);
VARA:=REF(VAR4,6);
VARB:=REF(VAR4,7);
VARC:=REF(VAR4,8);
VARD:=REF(VAR4,9);
VARE:=REF(VAR4,10);
VARF:=REF(VAR4,11);
VAR10:=REF(VAR4,12);
VAR11:=REF(VAR4,13);
VAR12:=REF(VAR4,14);
VAR13:=REF(VAR4,15);
VAR14:=REF(VAR4,16);
VAR15:=REF(VAR4,17);
VAR16:=REF(VAR4,18);
VAR17:=REF(VAR4,19);
VAR18:=REF(VAR4,20);
VAR19:=REF(VAR4,21);
VAR1A:=REF(VAR4,22);
VAR1B:=REF(VAR4,23);
VAR1C:=REF(VAR4,24);
VAR1D:=REF(VAR4,25);
VAR1E:=REF(VAR4,26);
VAR1F:=REF(VAR4,27);
VAR20:=REF(VAR4,28);
VAR21:=REF(VAR4,29);
VAR22:=REF(VAR4,30);
VAR23:=REF(VAR4,31);
VAR24:=REF(VAR4,32);
VAR25:=REF(VAR4,33);
VAR26:=REF(VAR4,34);
VAR27:=REF(VAR4,35);
VAR28:=REF(VAR4,36);
VAR29:=REF(VAR4,37);
VAR2A:=REF(VAR4,38);
VAR2B:=REF(VAR4,39);
VAR2C:=REF(VAR4,40);
VAR2D:=REF(VAR4,41);
VAR2E:=REF(VAR4,42);
VAR2F:=REF(VAR4,43);
VAR30:=REF(VAR4,44);
VAR31:=REF(VAR4,45);
VAR32:=REF(VAR4,46);
VAR33:=REF(VAR4,47);
VAR34:=REF(VAR4,48);
VAR35:=REF(VAR4,49);
VAR36:=REF(VAR4,50);
VAR37:=IF(((VAR4 > VAR5) AND (VAR5 >= VAR6)),1,IF(((VAR4 < VAR5) AND (VAR5 <= VAR6)),(0 - 1),IF(((VAR4 > VAR6) AND (VAR6 > VAR5)),2,IF(((VAR4 < VAR6) AND (VAR6 < VAR5)),(0 - 2),0))));
VAR38:=IF(((VAR5 > VAR6) AND (VAR5 > VAR7)),1,IF(((VAR5 < VAR6) AND (VAR5 < VAR7)),(0 - 1),IF(((VAR6 > VAR7) AND (VAR6 > VAR8)),2,IF(((VAR6 < VAR7) AND (VAR6 < VAR8)),(0 - 2),IF(((VAR7 > VAR8) AND (VAR7 > VAR9)),3,IF(((VAR7 < VAR8) AND (VAR7 < VAR9)),(0 - 3),IF(((VAR8 > VAR9) AND (VAR8 > VARA)),4,IF(((VAR8 < VAR9) AND (VAR8 < VARA)),(0 - 4),IF(((VAR9 > VARA) AND (VAR9 > VARB)),5,IF(((VAR9 < VARA) AND (VAR9 < VARB)),(0 - 5),IF(((VARA > VARB) AND (VARA > VARC)),6,IF(((VARA < VARB) AND (VARA < VARC)),(0 - 6),IF(((VARB > VARC) AND (VARB > VARD)),7,IF(((VARB < VARC) AND (VARB < VARD)),(0 - 7),IF(((VARC > VARD) AND (VARC > VARE)),8,IF(((VARC < VARD) AND (VARC < VARE)),(0 - 8),IF(((VARD > VARE) AND (VARD > VARF)),9,IF(((VARD < VARE) AND (VARD < VARF)),(0 - 9),IF(((VARE > VARF) AND (VARE > VAR10)),10,IF(((VARE < VARF) AND (VARE < VAR10)),(0 - 10),IF(((VARF > VAR10) AND (VARF > VAR11)),11,IF(((VARF < VAR10) AND (VARF < VAR11)),(0 - 11),IF(((VAR10 > VAR11) AND (VAR10 > VAR12)),12,IF(((VAR10 < VAR11) AND (VAR10 < VAR12)),(0 - 12),IF(((VAR11 > VAR12) AND (VAR11 > VAR13)),13,IF(((VAR11 < VAR12) AND (VAR11 < VAR13)),(0 - 13),IF(((VAR12 > VAR13) AND (VAR12 > VAR14)),14,IF(((VAR12 < VAR13) AND (VAR12 < VAR14)),(0 - 14),IF(((VAR13 > VAR14) AND (VAR13 > VAR15)),15,IF(((VAR13 < VAR14) AND (VAR13 < VAR15)),(0 - 15),IF(((VAR14 > VAR15) AND (VAR14 > VAR16)),16,IF(((VAR14 < VAR15) AND (VAR14 < VAR16)),(0 - 16),IF(((VAR15 > VAR16) AND (VAR15 > VAR17)),17,IF(((VAR15 < VAR16) AND (VAR15 < VAR17)),(0 - 17),IF(((VAR16 > VAR17) AND (VAR16 > VAR18)),18,IF(((VAR16 < VAR17) AND (VAR16 < VAR18)),(0 - 18),IF(((VAR17 > VAR18) AND (VAR17 > VAR19)),19,IF(((VAR17 < VAR18) AND (VAR17 < VAR19)),(0 - 19),IF(((VAR18 > VAR19) AND (VAR18 > VAR1A)),20,IF(((VAR18 < VAR19) AND (VAR18 < VAR1A)),(0 - 20),IF(((VAR19 > VAR1A) AND (VAR19 > VAR1B)),21,IF(((VAR19 < VAR1A) AND (VAR19 < VAR1B)),(0 - 21),IF(((VAR1A > VAR1B) AND (VAR1A > VAR1C)),22,IF(((VAR1A < VAR1B) AND (VAR1A < VAR1C)),(0 - 22),IF(((VAR1B > VAR1C) AND (VAR1B > VAR1D)),23,IF(((VAR1B < VAR1C) AND (VAR1B < VAR1D)),(0 - 23),IF(((VAR1C > VAR1D) AND (VAR1C > VAR1E)),24,IF(((VAR1C < VAR1D) AND (VAR1C < VAR1E)),(0 - 24),IF(((VAR1D > VAR1E) AND (VAR1D > VAR1F)),25,IF(((VAR1D < VAR1E) AND (VAR1D < VAR1F)),(0 - 25),IF(((VAR1E > VAR1F) AND (VAR1E > VAR20)),26,IF(((VAR1E < VAR1F) AND (VAR1E < VAR20)),(0 - 26),IF(((VAR1F > VAR20) AND (VAR1F > VAR21)),27,IF(((VAR1F < VAR20) AND (VAR1F < VAR21)),(0 - 27),IF(((VAR20 > VAR21) AND (VAR20 > VAR22)),28,IF(((VAR20 < VAR21) AND (VAR20 < VAR22)),(0 - 28),IF(((VAR21 > VAR22) AND (VAR21 > VAR23)),29,IF(((VAR21 < VAR22) AND (VAR21 < VAR23)),(0 - 29),IF(((VAR22 > VAR23) AND (VAR22 > VAR24)),30,IF(((VAR22 < VAR23) AND (VAR22 < VAR24)),(0 - 30),IF(((VAR23 > VAR24) AND (VAR23 > VAR25)),31,IF(((VAR23 < VAR24) AND (VAR23 < VAR25)),(0 - 31),IF(((VAR24 > VAR25) AND (VAR24 > VAR26)),32,IF(((VAR24 < VAR25) AND (VAR24 < VAR26)),(0 - 32),IF(((VAR25 > VAR26) AND (VAR25 > VAR27)),33,IF(((VAR25 < VAR26) AND (VAR25 < VAR27)),(0 - 33),IF(((VAR26 > VAR27) AND (VAR26 > VAR28)),34,IF(((VAR26 < VAR27) AND (VAR26 < VAR28)),(0 - 34),IF(((VAR27 > VAR28) AND (VAR27 > VAR29)),35,IF(((VAR27 < VAR28) AND (VAR27 < VAR29)),(0 - 35),IF(((VAR28 > VAR29) AND (VAR28 > VAR2A)),36,IF(((VAR28 < VAR29) AND (VAR28 < VAR2A)),(0 - 36),IF(((VAR29 > VAR2A) AND (VAR29 > VAR2B)),37,IF(((VAR29 < VAR2A) AND (VAR29 < VAR2B)),(0 - 37),IF(((VAR2A > VAR2B) AND (VAR2A > VAR2C)),38,IF(((VAR2A < VAR2B) AND (VAR2A < VAR2C)),(0 - 38),IF(((VAR2B > VAR2C) AND (VAR2B > VAR2D)),39,IF(((VAR2B < VAR2C) AND (VAR2B < VAR2D)),(0 - 39),IF(((VAR2C > VAR2D) AND (VAR2C > VAR2E)),40,IF(((VAR2C < VAR2D) AND (VAR2C < VAR2E)),(0 - 40),IF(((VAR2D > VAR2E) AND (VAR2D > VAR2F)),41,IF(((VAR2D < VAR2E) AND (VAR2D < VAR2F)),(0 - 41),IF(((VAR2E > VAR2F) AND (VAR2E > VAR30)),42,IF(((VAR2E < VAR2F) AND (VAR2E < VAR30)),(0 - 42),IF(((VAR2F > VAR30) AND (VAR2F > VAR31)),43,IF(((VAR2F < VAR30) AND (VAR2F < VAR31)),(0 - 43),IF(((VAR30 > VAR31) AND (VAR30 > VAR32)),44,IF(((VAR30 < VAR31) AND (VAR30 < VAR32)),(0 - 44),IF(((VAR31 > VAR32) AND (VAR31 > VAR33)),45,IF(((VAR31 < VAR32) AND (VAR31 < VAR33)),(0 - 45),IF(((VAR32 > VAR33) AND (VAR32 > VAR34)),46,IF(((VAR32 < VAR33) AND (VAR32 < VAR34)),(0 - 46),IF(((VAR33 > VAR34) AND (VAR33 > VAR35)),47,IF(((VAR33 < VAR34) AND (VAR33 < VAR35)),(0 - 47),IF(((VAR34 > VAR35) AND (VAR34 > VAR36)),48,IF(((VAR34 < VAR35) AND (VAR34 < VAR36)),(0 - 48),0))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))));
VAR39:=(REF(VAR3,1) / 5700000);
VAR3A:=(((VAR3 - REF(VAR3,1)) / REF(VAR3,1)) * 100);
VAR3B:=(((VAR1 * OPEN) / VAR2) / 5700000);
最高:=(((VAR1 * HIGH) / VAR2) / 5700000);
最低:=(((VAR1 * LOW) / VAR2) / 5700000);
生命线:EMA(VAR3,5),color6699CC;
蓄势:STICKLINE((((VAR37 = 1) OR (VAR37 = 2)) AND (VAR38 < 0)),VAR6,VAR5,7,0),color888888;
{www.gUPang.com 股旁网_最新股票指标公式}
带量上涨:STICKLINE((VAR37 = 2),VAR6,VAR4,7,0),colorFFFF;
多头:STICKLINE(((VAR37 = 1) OR ((VAR38 >= 1) AND (VAR37 = 0))),VAR5,VAR4,6,1),colorFF;
多翻空变盘:STICKLINE((((VAR37 = (0 - 1)) OR (VAR37 = (0 - 2))) AND (VAR38 > 0)),VAR6,VAR5,6,0),colorFF6633;
空头:STICKLINE((VAR37 = (0 - 2)),VAR6,VAR4,6,0),colorFFFFFF;
下跌:STICKLINE(((VAR37 = (0 - 1)) OR ((VAR38 <= (0 - 1)) AND (VAR37 = 0))),VAR5,VAR4,6,1),colorFF00;
EXPLAIN((((VAR37 = 1) OR (VAR37 = 2)) AND (VAR38 < 0)),'蓄势阶段'),colorFFFF;
EXPLAIN((VAR37 = 2),'带量上涨,爆破点'),colorFF;
EXPLAIN(((VAR37 = 1) OR ((VAR38 >= 1) AND (VAR37 = 0))),'多头持有'),colorFF;
EXPLAIN((((VAR37 = (0 - 1)) OR (VAR37 = (0 - 2))) AND (VAR38 > 0)),'多翻空变盘'),colorFFFF;
EXPLAIN((VAR37 = (0 - 2)),'空头占优,注意风险'),colorFFFF;
EXPLAIN(((VAR37 = (0 - 1)) OR ((VAR38 <= (0 - 1)) AND (VAR37 = 0))),'空头持仓阶段'),colorFF00;

飞狐十九资金指标公式

 

相关文章