在线检测未来函数

大智慧资金净量指标公式

来源:Internet,编辑:股旁网,2011-07-27

input:n(5);
k1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
k2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
dt:=VOL*K1/(K1+K2);
kt:=VOL-DT;
买量:sum(dt,n),COLOR0000FF;
卖量:-sum(kt,n),COLORFFFF00;
FILLRGN(买量,0,1,RGB(0,120,0));
FILLRGN(卖量,0,1,RGB(0,80,0));
进出量:买量+卖量,POINTDOT,COLOR00FFFF;
净量换手:100*进出量/CAPITAL,POINTDOT,COLOR00FF33;
STICKLINE(进出量>=0,0,进出量,6,1),COLOR0000FF;
STICKLINE(进出量<0,0,进出量,6,1),COLORFFFF00;
D5:=100*SUM(DT,5)/CAPITAL;
K5:=100*SUM(KT,5)/CAPITAL;
J5:=D5-K5;
D10:=100*SUM(DT,10)/CAPITAL;
K10:=100*SUM(KT,10)/CAPITAL;
J10:=D10-K10;
D20:=100*SUM(DT,20)/CAPITAL;
K20:=100*SUM(KT,20)/CAPITAL;
J20:=D20-K20;
BL5:=400/MAX(D5,K5);
BL10:=400/MAX(D10,K10);
BL20:=400/MAX(D20,K20);
DRAWRECTREL(0,0,360,999,RGB(50,50,50));
D5B:=999-D5*BL5;
K5B:=999-K5*BL5;
J5B:=999-ABS(J5)*BL5;
D10B:=999-D10*BL10;
K10B:=999-K10*BL10;
J10B:=999-ABS(J10)*BL10;
D20B:=999-D20*BL20;
K20B:=999-K20*BL20;
J20B:=999-ABS(J20)*BL20;
{画直方图}
DRAWRECTREL(30,D5B,50,999,RGB(150,0,0));
DRAWRECTREL(50,K5B,70,999,RGB(0,150,150));
DRAWRECTREL(70,J5B,90,999,RGB(150,150,0));
DRAWRECTREL(150,D10B,170,999,RGB(150,0,0));
DRAWRECTREL(170,K10B,190,999,RGB(0,150,150));
DRAWRECTREL(190,J10B,210,999,RGB(150,150,0));
DRAWRECTREL(270,D20B,290,999,RGB(150,0,0));
DRAWRECTREL(290,K20B,310,999,RGB(0,150,150));
DRAWRECTREL(310,J20B,330,999,RGB(150,150,0));
DRAWTEXTREL(90,0,'买量'), colorddffff;
DRAWTEXTREL(180,0,'卖量'), colorddffff;
DRAWTEXTREL(270,0,'进出量'), colorddffff;
DRAWTEXTREL(20,100,'今日'), color33ffff;
DRAWTEXTABS(5,5,'股旁网 www.gupang.com'),linethick1,COLOR00EEff;
DRAWTEXTREL(90,100,NUMTOSTRN(100*DT/CAPITAL,2)), color33ffff;
DRAWTEXTREL(180,100,NUMTOSTRN(100*KT/CAPITAL,2)), color33ffff;
DRAWTEXTREL(270,100,NUMTOSTRN(100*DT/CAPITAL-100*KT/CAPITAL,2)), color33ffff;
DRAWTEXTREL(27,200,'5日'), colorddffff;
DRAWTEXTREL(90,200,NUMTOSTRN(D5,2)), colorddffff;
DRAWTEXTREL(180,200,NUMTOSTRN(K5,2)), colorddffff;
DRAWTEXTREL(270,200,NUMTOSTRN(J5,2)), colorddffff;
DRAWTEXTREL(20,300,'10日'), color33ffff;
DRAWTEXTREL(90,300,NUMTOSTRN(D10,2)), color33ffff;
DRAWTEXTREL(180,300,NUMTOSTRN(K10,2)), color33ffff;
DRAWTEXTREL(270,300,NUMTOSTRN(J10,2)), color33ffff;
DRAWTEXTREL(20,400,'20日'), colorddffff;
DRAWTEXTREL(90,400,NUMTOSTRN(D20,2)), colorddffff;
DRAWTEXTREL(180,400,NUMTOSTRN(K20,2)), colorddffff;
DRAWTEXTREL(270,400,NUMTOSTRN(J20,2)), colorddffff;
DRAWTEXTREL(15,800,'5'), colorbbffff;
DRAWTEXTREL(10,900,'日'), colorbbffff;
DRAWTEXTREL(130,800,'10'), colorbbffff;
DRAWTEXTREL(130,900,'日'), colorbbffff;
DRAWTEXTREL(250,800,'20'), colorbbffff;
DRAWTEXTREL(250,900,'日'), colorbbffff;

大智慧资金净量指标公式

 

相关文章