在线检测未来函数

通达信主力顶底扫描指标公式

来源:Internet,编辑:股旁网,2011-07-27

A1:=CAPITAL;
A2:=(((H + L) + O) + C) / 4;
A3:=(((INDEXH + INDEXL) + INDEXO) + INDEXC) / 4;
A17:=(SUM((A2 * VOL),16)) / (SUM(VOL,16));
A18:=(SUM((A2 * VOL),11)) / (SUM(VOL,11));
A19:=(SUM((A2 * VOL),6)) / (SUM(VOL,6));
A20:=((SUM((A2 * VOL),7)) - (A2 * VOL)) / ((SUM(VOL,7)) - VOL);
A21:=((A18 - A17) / A2) * 1000;
A22:=IF((A21 > 50),50,(IF((A21 < -50),-50,A21)));
A23:=((A19 - A18) / A2) * 1000;
A24:=IF((A23 > 50),50,(IF((A23 < -50),-50,A23)));
A25:=((((A19 - A20) / A20) * 5) / 4) * 1000;
A26:=IF((A25 > 50),50,(IF((A25 < -50),-50,A25)));
A27:=(A22 + A24) + A26;
红柱:IF((A27 > 0),A27,0),COLORRED,LINETHICK0;
兰柱:IF((A27 < 0),REVERSE(A27),0),COLORBLUE,LINETHICK0;
{www.gUPang.com 股旁网_最新股票指标公式}
A28:=IF((兰柱 < 150),兰柱,(IF((兰柱 = 150),65,0)));
A29:=IF((兰柱 = 150),60,0);
A30:=IF((红柱 < 150),红柱,(IF((红柱 = 150),65,0)));
A31:=IF((红柱 = 150),60,0);
STICKLINE(A30,0,A30,1,0),COLORRED;
STICKLINE(A31,105,150,1,0),COLORFF00FF;
STICKLINE(A31,65,105,1,0),COLORFF0000;
STICKLINE(A28,0,A28,1,0),COLORFF0000;
STICKLINE(A29,105,150,1,0),COLORFF0000;
STICKLINE(A29,65,105,1,0),COLORRED;
A33:=SUMBARS(VOL,(A1 * 0.8));
A34:=IF((A33 < 9),9,A33);
A35:=HHV(A2,A34);
A36:=LLV(A2,A34);
A37:=IF((A35 = A36),0,((100 * (A2 - A36)) / (A35 - A36)));
趋势线:(1.5 * (SUM(A37,6))) / 6,LINETHICK2,COLORRED;
长趋势线:(SUM(中趋势线,6)) / 6,LINETHICK2,COLORGREEN;
VAR33:=PEAKBARS(3,15,1)<10;
VAR35:=IF(VAR33=1,2,0);
顶:= IF(VAR35=2,2,0);
顶A:IF(顶>REF(顶,1),100,0),COLORGREEN;
VAR1P:=(CLOSE-LLV(LOW,60.135))/(HHV(HIGH,60.135)-LLV(LOW,60))*80;
VAR2P:=SMA(VAR1P,7,1);
VAR3P:=SMA(VAR2P,5,1);
百万预警:IF(CROSS(VAR2P,VAR3P) AND VAR2P<20,85,0),LINETHICK2 , COLOR000999;
DRAWTEXT(CROSS(VAR2P,VAR3P) AND VAR2P<20,75,'预警'), COLOR000999;

通达信主力顶底扫描指标公式

 

相关文章