在线检测未来函数

飞狐波浪与波神主图指标公式

来源:Internet,编辑:股旁网,2011-07-29

INPUT:最近天(20,1,360);
当前月:=FRACPART(ROUND(当前日期/100)/100)*100;
月:=MONTH;日:=DAY;
VERTLINE(月=1 AND ( 日=25)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=3 AND ( 日=20)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=5 AND ( 日=12)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=6 AND (日=14 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=7 AND ( 日=19 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=8 AND ( 日=6 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=9 AND ( 日=18 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=10 AND ( 日=31)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=11 AND ( 日=28)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=12 AND ( 日=31)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=1 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=2 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=3 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=4 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=5 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=6 AND ( 日=6 OR 日=21)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=7 AND ( 日=8 OR 日=15 OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=8 AND ( 日=8 OR 日=15 OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=9 AND ( 日=8 OR 日=15 OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=10 AND ( 日=8 OR 日=15 OR 日=23 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=11 AND ( 日=8 OR 日=15 OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=12 AND ( 日=8 OR 日=15 OR 日=23 )),COLORAAAAAA,LINEDASHDOT;
N:=if(sysparam(1)=datacount,最近天,datacount-sysparam(1));
HH:=HHV(HIGH,N);
LL:=LLV(LOW,N);
VN:=N;
{LAST1:=DATACOUNT;}
IF VN>DATACOUNT THEN
VN:=DATACOUNT+1;
FOR I=DATACOUNT DOWNTO DATACOUNT-VN+1 DO BEGIN
HH[I]:=HH[DATACOUNT];
LL[I]:=LL[DATACOUNT];
END;
TMP:=SETLBOUND(hh,DATACOUNT-VN+1);
TMP:=SETLBOUND(ll,DATACOUNT-VN+1);
阶段高:HH,LINETHICK2,color0000FF;阶段低:LL,LINETHICK2,color00FF00;
中线:(HH+LL)/2,linethick0;
KKH:=BARSLAST(H=HH);
KKL:=BARSLAST(L=LL);
N低日:=STRTONUM(NUMTOSTR(REF(DATE,KKL),0)),LINETHICK;
N高日:=STRTONUM(NUMTOSTR(REF(DATE,KKH),0)),LINETHICK;
多空:IF(N低日>N高日,2,1),LINETHICK0;
多空天:IF(N低日<N高日,kkl,kkh),LINETHICK0;
DATE1:=IF(多空=1,N低日,N高日);{}
hh0:=ref(h,BARSLAST(DATE1=DATE));
ll0:=ref(l,BARSLAST(DATE1=DATE));
H1:=STRTONUM(NUMTOSTR(Hh0,3)),POINTDOT;
L1:=STRTONUM(NUMTOSTR(Ll0,3)),POINTDOT;
PARTLINE(1,H1),,POINTDOT,linethick0;
PARTLINE(1,L1),,POINTDOT,linethick0;
LL:=H1 - L1;
VERTLINE(DATE=DATE1),COLORFFAAAA,,LINETHICK2;
DRAWTEXT(DATE=DATE1,SYSPARAM(4)*0.95,'起\n \n始\n \n线'),COLORFFFFFF;
起始至今天:BARSLAST(DATE1=DATE),COLORFFFF00,LINETHICK0;
涨幅:(C-REF(C,起始至今天))/REF(C,起始至今天)*100,COLORFFDDDD,LINETHICK0;
IF 多空=1 THEN BEGIN
{看多}
开门线: PARTLINE(DATE>=N低日,LL*1.50801 + L1),LINETHICK1,COLOREE99FF;;
PARTLINE(DATE>=N低日,LL*2.00001 + L1),COLOR9999FF,LINEDOT;
多2线: PARTLINE(DATE>=N低日,LL*2.40001 + L1),COLORFFFF99,linethick1;
PARTLINE(DATE>=N低日,LL*3.05001 + L1),COLOR99FF99,LINEDOT;
PARTLINE(DATE>=N低日,LL*3.75001 + L1),COLORFF9999,LINEDOT;
多5线: PARTLINE(DATE>=N低日,LL*4.15001 + L1),COLORMAGENTA,linethick2,LINEDOT;
PARTLINE(DATE>=N低日,LL*4.80001 + L1),COLORRED,LINEDOT;
多7线: PARTLINE(DATE>=N低日,LL*5.50001 + L1),COLORCYAN,linethick2;
PARTLINE(DATE>=N低日,LL*6.10001 + L1),COLORGREEN,LINEDOT;
PARTLINE(DATE>=N低日,LL*6.90001 + L1),LINETHICK1,COLORRED;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*1.50801+0.002,NUMTOSTR(L1+LL*1.50801,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*2.00001+0.002,NUMTOSTR(L1+LL*2.00001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*2.40001+0.002,'NO.2 '+NUMTOSTR(L1+LL*2.40001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*3.05001+0.002,NUMTOSTR(L1+LL*3.05001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*3.75001+0.002,NUMTOSTR(L1+LL*3.75001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*4.15001+0.002,'NO.5 '+NUMTOSTR(L1+LL*4.15001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*4.80001+0.002,NUMTOSTR(L1+LL*4.80001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*5.50001+0.002,'NO.7 '+NUMTOSTR(L1+LL*5.50001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*6.10001+0.002,NUMTOSTR(L1+LL*6.10001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*6.90001+0.002,NUMTOSTR(L1+LL*6.90001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(DATE=DATE1,LL*1.50801 + L1+0.002,'多开门'),colorred;
DRAWTEXT(DATE=DATE1,LL*6.90001 + L1+0.002,'多关门'),colorred;
END;
ELSE BEGIN
{看空}
空开门线: PARTLINE(DATE>=N高日,H1-LL*1.50801),LINETHICK1,COLOREE99FF;
PARTLINE(DATE>=N高日,H1-LL*2.00001),COLOR9999FF,LINEDOT;
空2线: PARTLINE(DATE>=N高日,H1-LL*2.40001),COLORFFFF99;
PARTLINE(DATE>=N高日,H1-LL*3.05001),COLOR99FF99,LINEDOT;
PARTLINE(DATE>=N高日,H1-LL*3.75001),COLORFF9999,LINEDOT;
空5线: PARTLINE(DATE>=N高日,H1-LL*4.15001),COLORMAGENTA;
PARTLINE(DATE>=N高日,H1-LL*4.80001),COLORRED,LINEDOT;
空7线: PARTLINE(DATE>=N高日,H1-LL*5.50001),COLORCYAN;
PARTLINE(DATE>=N高日,H1-LL*6.10001),COLORGREEN,LINEDOT;
空关门线: PARTLINE(DATE>=N高日,H1-LL*6.90001),LINETHICK1,COLORRED;
DRAWTEXT(DATE=DATE1,H1-LL*1.50801+0.002,'空开门'),color3333FF;
DRAWTEXT(DATE=DATE1,H1-LL*6.90001+0.002,'空关门'),color3333FF;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*1.50801+0.002,NUMTOSTR(H1-LL*1.50801,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*2.00001+0.002,NUMTOSTR(H1-LL*2.00001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*2.40001+0.002,'NO.2 '+NUMTOSTR(H1-LL*2.40001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*3.05001+0.002,NUMTOSTR(H1-LL*3.05001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*3.75001+0.002,NUMTOSTR(H1-LL*3.75001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*4.15001+0.002,'NO.5 '+NUMTOSTR(H1-LL*4.15001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*4.80001+0.002,NUMTOSTR(H1-LL*4.80001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*5.50001+0.002,'NO.7 '+NUMTOSTR(H1-LL*5.50001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*6.10001+0.002,NUMTOSTR(H1-LL*6.10001,2)),COLORAAAAAA,ALIGN2;
DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*6.90001+0.002,NUMTOSTR(H1-LL*6.90001,2)),COLORAAAAAA,ALIGN2;
END;
高年:=ref(YEAR,BARSLAST(date=N高日));
高月:=ref(MONTH,BARSLAST(date=N高日));
高日:=ref(DAY,BARSLAST(date=N高日));
低年:=ref(YEAR,BARSLAST(date=N低日));
低月:=ref(MONTH,BARSLAST(date=N低日));
低日:=ref(DAY,BARSLAST(date=N低日));
DRAWTEXT(SYSPARAM(2)=BARPOS,H1,'最近'+NUMTOSTR(最近天,0)+'天最高价日期:'+NUMTOSTR(高年,0)+'年'+NUMTOSTR(高月,0)+'月'+NUMTOSTR(高日,0)+'日'+'\n \n'
+'最近'+NUMTOSTR(最近天,0)+'天最低价日期:'+NUMTOSTR(低年,0)+'年'+NUMTOSTR(低月,0)+'月'+NUMTOSTR(低日,0)+'日'),COLORFFAAAA,ALIGN4;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='1',c,NUMTOSTR(当前月,0)+'月转折日:6、15、21、*25\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='2',c,NUMTOSTR(当前月,0)+'月转折日:6、15、21\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='3',c,NUMTOSTR(当前月,0)+'月转折日:6、15、*20、21\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='4',c,NUMTOSTR(当前月,0)+'月转折日:6、15、21\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='5',c,NUMTOSTR(当前月,0)+'月转折日:6、*1 2、15、21\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='6',c,NUMTOSTR(当前月,0)+'月转折日:6、*1 4、21\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='7',c,NUMTOSTR(当前月,0)+'月转折日:8、15、*1 9、23\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='8',c,NUMTOSTR(当前月,0)+'月转折日:*6、8、15、23\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='9',c,NUMTOSTR(当前月,0)+'月转折日:8、15、*1 8、23\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='10',c,NUMTOSTR(当前月,0)+'月转折日:8、15、23、*31\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='11',c,NUMTOSTR(当前月,0)+'月转折日:8、15、23、*28\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='12',c,NUMTOSTR(当前月,0)+'月转折日:8、15、23、*31\n \n \n \n '),COLOR00FFFF,ALIGN5;
{-----------------------------立体K线--------------------------------------}
Ko:=close;
Kc:=ref(close,1);
STICKLINE(ko<=kc ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(ko<=kc ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(ko<=kc ,CLOSE ,OPEN,6,0 ),COLOR00aa00;
STICKLINE(ko<=kc ,CLOSE ,OPEN,5,0 ),COLOR00bb00;
STICKLINE(ko<=kc,CLOSE ,OPEN,4,0 ),COLOR00cc00;
STICKLINE(ko<=kc,CLOSE ,OPEN,3,0 ),COLOR33dd00;
STICKLINE(ko<=kc,CLOSE ,OPEN,2,0 ),COLOR00ee00;
STICKLINE(ko<=kc,CLOSE ,OPEN,1,0 ),COLOR66ff00;
STICKLINE(ko>kc,CLOSE,OPEN,8,0 ),COLOr000088;
STICKLINE(ko>kc,CLOSE,OPEN,7,0 ),COLOr000099;
STICKLINE(ko>kc,CLOSE,OPEN,6 ,0 ),COLOR0000aa;
STICKLINE(ko>kc,CLOSE,OPEN,5,0 ),COLOr0000bb;
STICKLINE(ko>kc,CLOSE,OPEN,4,0 ),COLOr0000cc;
STICKLINE(ko>kc,CLOSE,OPEN,3 ,0 ),COLOR0000dd;
STICKLINE(ko>kc,CLOSE,OPEN,2,0 ),COLOr0000ee;
STICKLINE(ko>kc,CLOSE,OPEN,1 ,0 ),COLOR0033ff;
STICKLINE(ko>kc,OPEN,LOW,0.5,0 ),COLORred;
STICKLINE(ko>kc,CLOSE,HIGH,0.5 ,0 ),COLORred;
STICKLINE(ko<=kc,CLOSE,LOW,0.5 ,0 ),COLOR66cc33;
STICKLINE(ko<=kc,OPEN,HIGH,0.5 ,0 ),COLOR66cc33;
pl5:=之字转向(3,5);
en1:=之字转向(3,5)>向前引用(之字转向(3,5),1) and 向前引用(之字转向(3,5),1)<=向前引用(之字转向(3,5),2) and 向前引用(之字转向(3,5),2)<=向前引用(之字转向(3,5),3);
ex1:=之字转向(3,5)<向前引用(之字转向(3,5),1) and 向前引用(之字转向(3,5),1)>=向前引用(之字转向(3,5),2) and 向前引用(之字转向(3,5),2)>=向前引用(之字转向(3,5),3);
pl10:=之字转向(3,13);
en2:=之字转向(3,10)>向前引用(之字转向(3,10),1) and 向前引用(之字转向(3,10),1)<=向前引用(之字转向(3,10),2) and 向前引用(之字转向(3,10),2)<=向前引用(之字转向(3,10),3);
ex2:=之字转向(3,10)<向前引用(之字转向(3,10),1) and 向前引用(之字转向(3,10),1)>=向前引用(之字转向(3,10),2) and 向前引用(之字转向(3,10),2)>=向前引用(之字转向(3,10),3);
pl20:=之字转向(3,26);
en3:= 之字转向(3,20)>向前引用(之字转向(3,20),1) and 向前引用(之字转向(3,20),1)<=向前引用(之字转向(3,20),2) and 向前引用(之字转向(3,20),2)<=向前引用(之字转向(3,20),3);
ex3:=之字转向(3,20)<向前引用(之字转向(3,20),1) and 向前引用(之字转向(3,20),1)>=向前引用(之字转向(3,20),2) and 向前引用(之字转向(3,20),2)>=向前引用(之字转向(3,20),3);
pl40:=之字转向(3,55);
走强1:=上一次条件成立位置(pl5<向前引用(pl5,1));
走弱1:=上一次条件成立位置(pl5>向前引用(pl5,1));
走强2:=上一次条件成立位置(pl10<向前引用(pl10,1));
走弱2:=上一次条件成立位置(pl10>向前引用(pl10,1));
走强3:=上一次条件成立位置(pl20<向前引用(pl20,1));
走弱3:=上一次条件成立位置(pl20>向前引用(pl20,1));
ztjz5:=条件函数(pl10>向前引用(pl10,1),统计总数(en1,走强2),0);
ztjd5:=条件函数(pl10>向前引用(pl10,1),统计总数(ex1,走强2),0);
dtjz5:=条件函数(pl10<向前引用(pl10,1),统计总数(en1,走弱2),0);
dtjd5:=条件函数(pl10<向前引用(pl10,1),统计总数(ex1,走弱2),0);
ztjz10:=条件函数(pl20>向前引用(pl20,1),统计总数(en2,走强3),0);
ztjd10:=条件函数(pl20>向前引用(pl20,1),统计总数(ex2,走强3),0);
dtjz10:=条件函数(pl20<向前引用(pl20,1),统计总数(en2,走弱3),0);
dtjd10:=条件函数(pl20<向前引用(pl20,1),统计总数(ex2,走弱3),0);
显示文字(en1 and dtjz5=1,最低价*0.98,'(Ⅰ)'),colorffff00;
显示文字(ex1 and dtjd5=2,最高价*1.02,'(Ⅱ)'),colorffff00;
显示文字(en2 and ztjz5=1,最低价*0.98,'(Ⅲ)'),colorffff00;
显示文字(ex1 and pl10>向前引用(pl10,1) and ztjd5=1,最高价*1.02,'⑴'),colorff;
显示文字(en1 and pl10>向前引用(pl10,1) and ztjz5=2,最低价*0.98,'⑵'),colorff;
显示文字(ex1 and pl10>向前引用(pl10,1) and ztjz5=2,最高价*1.02,'⑶'),colorff;
显示文字(en1 and pl10>向前引用(pl10,1) and ztjz5=3,最低价*0.98,'⑷'),colorff;
显示文字(ex2 and pl20>向前引用(pl20,1) and ztjd10=1,最高价*1.02,'⑸'),colorff;
显示文字(en2 and dtjz10=1,最低价*0.94,'【A】'),color00ff00;
显示文字(ex2 and dtjd10=2,最高价*1.03,'【B】'),color00ff00;
显示文字(en3 and ztjz10=1,最低价*0.94,'【C】'),color00ff00;
显示文字(ex2 and pl20>向前引用(pl20,1) and ztjd10=1,最高价*1.04,'①'),Linethick3,colorffff;
显示文字(en2 and pl20>向前引用(pl20,1) and ztjz10=2,最低价*0.94,'②'),Linethick3,colorffff;
显示文字(ex2 and pl20>向前引用(pl20,1) and ztjd10=2 or (ztjd10=0 or ztjd10=2) and ex2,最高价*1.04,'③'),Linethick3,colorffff;
显示文字(en2 and pl20>向前引用(pl20,1) and ztjz10=3,最低价*0.94,'④'),Linethick3,colorffff;
DMLJ:=最高值(最高价,120);
TY:=收盘价;
HD:=信号过滤(向前赋值(信号过滤(向前引用(TY,10)=最高值(TY,2*10+1),10),10+1),10);
LD:=信号过滤(向前赋值(信号过滤(向前引用(TY,10)=最低值(TY,2*10+1),10),10+1),10);
A:=向前引用(收盘价,上一次条件成立位置(HD));
B:=向前引用(收盘价,上一次条件成立位置(LD));
T1:=上一次条件成立位置(HD)<上一次条件成立位置(LD) AND 求逻辑非(HD) ;
T2:=上一次条件成立位置(HD)>上一次条件成立位置(LD) AND 求逻辑非(LD);
波浪顶:条件函数(T1,A,A),COLORFF00FF,点状线,LINETHICK4;
画柱线(T1,A,A,9,0),COLORFF00FF;
波浪底:条件函数(T2,B,B),COLOR80FF00,点状线,LINETHICK4;
VAR3:=最低值(最高价,240);
VAR4:=100*(收盘价-VAR3)/VAR3;
VAR5:=(收盘价-最低值(最低价,528))/(最高值(最高价,528)-最低值(最低价,528))*100;
VAR6:=(收盘价-最低值(收盘价,530))/(最高值(收盘价,530)-最低值(收盘价,530))*100;
VAR7:=0;
VAR8:=简单移动平均(最高值(收盘价-向前引用(收盘价,1),0),34)/简单移动平均(绝对值(收盘价-向前引用(收盘价,1)),7)*100;
VAR9:=简单移动平均(最高值(收盘价-向前引用(收盘价,1),0),13)/简单移动平均(绝对值(收盘价-向前引用(收盘价,1)),13)*100;
VARA:=有效值周期数(收盘价);
VARB:=VAR8<20 AND VAR9<23 AND VARA>35;
VARC:=VARB AND 统计总数(VARB,1)=1;
VARD:=指数平滑移动平均(收盘价,21)-指数平滑移动平均(收盘价,8);
VARE:=指数平滑移动平均(VARD,5);
VARF:=前M个波谷值(3,6,1)<4 AND 交叉函数(VARD,VARE);
VAR10:=条件函数(前M个波谷值(3,16,1)=0 AND 最高价>最低价+0.04,4,0);
VAR11:=之字转向(3,6)>向前引用(之字转向(3,6),1) AND 向前引用(之字转向(3,6),1)<=向前引用(之字转向(3,6),2) AND 向前引用(之字转向(3,6),2)<=向前引用(之字转向(3,6),3);
VAR12:=之字转向(3,6)<向前引用(之字转向(3,6),1) AND 向前引用(之字转向(3,6),1)>=向前引用(之字转向(3,6),2) AND 向前引用(之字转向(3,6),2)>=向前引用(之字转向(3,6),3);
VAR13:=之字转向(3,22)>向前引用(之字转向(3,22),1) AND 向前引用(之字转向(3,22),1)<=向前引用(之字转向(3,22),2) AND 向前引用(之字转向(3,22),2)<=向前引用(之字转向(3,22),3);
VAR14:=之字转向(3,22)<向前引用 (之字转向(3,22),1) AND 向前引用(之字转向(3,22),1)>=向前引用(之字转向(3,22),2) AND 向前引用(之字转向(3,22),2)>=向前引用(之字转向(3,22),3);
VAR15:=之字转向(3,51)>向前引用 (之字转向(3,51),1) AND 向前引用(之字转向(3,51),1)<=向前引用(之字转向(3,51),2) AND 向前引用(之字转向(3,51),2)<=向前引用(之字转向(3,51),3);
VAR16:=之字转向(3,51)<向前引用 (之字转向(3,51),1) AND 向前引用(之字转向(3,51),1)>=向前引用(之字转向(3,51),2) AND 向前引用(之字转向(3,51),2)>=向前引用(之字转向(3,51),3);
VAR17:=之字转向(3,72)>向前引用 (之字转向(3,72),1) AND 向前引用(之字转向(3,72),1)<=向前引用(之字转向(3,72),2) AND 向前引用(之字转向(3,72),2)<=向前引用(之字转向(3,72),3);
VAR18:=之字转向(3,72)<向前引用 (之字转向(3,72),1) AND 向前引用(之字转向(3,72),1)>=向前引用(之字转向(3,72),2) AND 向前引用(之字转向(3,72),2)>=向前引用(之字转向(3,72),3);
VAR19:=指数平滑移动平均(收盘价,2)-指数平滑移动平均(收盘价,150);
VAR1A:=指数平滑移动平均(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=乘幂(VAR1B,3)*0.1+乘幂(VAR1B,1);
VAR1D:=开平方(开平方(最低价*最高价*开盘价*收盘价));
VAR1E:=指数平滑移动平均(VAR1D*0.97,3);
VAR1F:=(最高价+最低价+收盘价)/3;
VAR20:=(VAR1F-简单移动平均(VAR1F,14))/(0.015*平均绝对偏差(VAR1F,14));
VAR21:=交叉函数(VAR1E,最低价);
买点1:=VAR10;
买点2:=(VAR11+VAR13+VAR15+VAR17);
卖点1:=(VAR12+VAR14+VAR16+VAR18),LINETHICK2;
VAR22:=买点1 AND VARF AND VARC AND VAR21 AND VAR4<0 AND VAR5=0 AND VAR6=0 AND VAR20<(-110);
VAR1:=简单移动平均(收盘价,6);
VAR2:=简单移动平均(收盘价,18);
VAR31:=简单移动平均(收盘价,30);
VARB1:=求和(收盘价*成交量*100,28)/求和(成交量*100,28);
VARC1:=取整(VARB1*100)/100;
VARD1:=指数平滑移动平均(收盘价,5)-指数平滑移动平均(收盘价,10);
VARE1:=指数平滑移动平均(VARD1,9);
VAR131:=向前引用(VARE1,1);
VAR141:=VARE1;
VAR151:=VAR141-VAR131;
VAR161:=向前引用(VARD1,1);
VAR171:=VARD1;
VAR181:=VAR171-VAR161;
VAR191:=开盘价;
VAR1A1:=收盘价;
显示文字(买点1>0,最低价-0.01,'▲买!'),COLORRED;
显示文字(买点2>0,最低价-0.01,'▲要涨'),COLORYELLOW;
显示文字(卖点1>0,最高价+0.1,'▼快卖'), COLORWHITE;
a:=有效值周期数(收盘价);
ah:=最高值(最高价,72);
al:=最低值(最低价,72);
a0:=(ah-al)/21;
b1:=最低价-a0;
显示文字((a+0)/15=向下舍入((a+0)/15),b1-2.5*a0,'▲时窗'),COLORWHITE;
var31:=上一高点位置(之字转向(3, 19)>向前引用(之字转向(3,19),1)
and 向前引用(之字转向(3,19), 1)<向前引用(之字转向(3,19), 2),0);
画柱线(var31=2,最低价*0.95,最低价*0.98,8,0),color0000ff;
显示文字(var31=2,最低价*0.95,'3天'),COLORWHITE;
画柱线(var31=4,最高价*1.05,最高价*1.02,8,0),color9966ff;
显示文字(var31=4,最高价*1.06,'5天'),COLORWHITE;
画柱线(var31=7,最低价*0.95,最低价*0.98,8,0),color00ffff;
显示文字(var31=7,最低价*0.95,'8天'),COLORWHITE;
画柱线(var31=12,最高价*1.05,最高价*1.02,8,0),colorff33ff;
显示文字(var31=12,最高价*1.06,'13天'),COLORWHITE;
画柱线(var31=20,最低价*0.95,最低价*0.98,8,0),color0066ff;
显示文字(var31=20,最低价*0.95,'21天'),COLORWHITE;
画柱线(var31=33,最高价*1.05,最高价*1.02,8,0),colorffff00;
显示文字(var31=33,最高价*1.06,'34天'),COLORWHITE;
画柱线(var31=54,最低价*0.95,最低价*0.98,8,0),COLORWHITE;
显示文字(var31=54,最低价*0.95,'55天'),COLORWHITE;
画柱线(var31=88,最高价*1.05,最高价*1.02,8,0),color00ff00;
显示文字(var31=88,最高价*1.06,'89天'),COLORWHITE;
画柱线(var31=143,最低价*0.95,最低价*0.98,8,0),colorccffff;
显示文字(var31=143,最低价*0.95,'144天'),COLORWHITE;
画柱线(var31=232 ,最高价*1.05,最高价*1.02,8,0),colorff0033;
显示文字(var31=232,最高价*1.06,'233天'),COLORWHITE;
画柱线(var31=376,最低价*0.95,最低价*0.98,8,0),colorff9966;
显示文字(var31=376,最低价*0.95,'377天'),COLORWHITE;
立春:=信号过滤(月份=2 AND (日期=3 OR 日期=5 ),2);
雨水:=信号过滤(月份=2 AND (日期=18 OR 日期=20),2);
惊蛰:=信号过滤(月份=3 AND (日期=5 OR 日期=7 ),2);
春分:=信号过滤(月份=3 AND (日期=20 OR 日期=22),2);
清明:=信号过滤(月份=4 AND (日期=3 OR 日期=6 ),2);
谷雨:=信号过滤(月份=4 AND (日期=19 OR 日期=21),2);
立夏:=信号过滤(月份=5 AND (日期=6 OR 日期=8 ),2);
小满:=信号过滤(月份=5 AND (日期=20 OR 日期=22),2);
芒种:=信号过滤(月份=6 AND (日期=5 OR 日期=7 ),2);
夏至:=信号过滤(月份=6 AND (日期=20 OR 日期=22),2);
小暑:=信号过滤(月份=7 AND (日期=6 OR 日期=8 ),2);
大署:=信号过滤(月份=7 AND (日期=22 OR 日期=24),2);
立秋:=信号过滤(月份=8 AND (日期=7 OR 日期=9 ),2);
处暑:=信号过滤(月份=8 AND (日期=22 OR 日期=24),2);
白露:=信号过滤(月份=9 AND (日期=7 OR 日期=9 ),2);
秋分:=信号过滤(月份=9 AND (日期=22 OR 日期=24),2);
寒露:=信号过滤(月份=10 AND (日期=7 OR 日期=9 ),2);
霜降:=信号过滤(月份=10 AND (日期=22 OR 日期=24),2);
立冬:=信号过滤(月份=11 AND (日期=7 OR 日期=9 ),2);
小雪:=信号过滤(月份=11 AND (日期=22 OR 日期=24),2);
大雪:=信号过滤(月份=12 AND (日期=6 OR 日期=8 ),2);
冬至:=信号过滤(月份=12 AND (日期=21 OR 日期=23),2);
小寒:=信号过滤(月份=1 AND (日期=5 OR 日期=7 ),2);
大寒:=信号过滤(月份=1 AND (日期=19 OR 日期=21),2);
{www.gUPang.com 股旁网_最新股票指标公式}
显示文字(立春,最高价*1.02,'立春'),COLORgreen,ALIGN1;
显示文字(雨水,最高价*1.02,'雨水'),COLORgreen,ALIGN1;
显示文字(惊蛰,最高价*1.02,'惊蛰'),COLORgreen,ALIGN1;
显示文字(春分,最高价*1.02,'春分'),COLORgreen,ALIGN1;
显示文字(清明,最高价*1.02,'清明'),COLORgreen,ALIGN1;
显示文字(谷雨,最高价*1.02,'谷雨'),COLORgreen,ALIGN1;
显示文字(立夏,最高价*1.02,'立夏'),COLORMAGENTA,ALIGN1;
显示文字(小满,最高价*1.02,'小满'),COLORMAGENTA,ALIGN1;
显示文字(芒种,最高价*1.02,'芒种'),COLORMAGENTA,ALIGN1;
显示文字(夏至,最高价*1.02,'夏至'),COLORMAGENTA,ALIGN1;
显示文字(小暑,最高价*1.02,'小暑'),COLORMAGENTA,ALIGN1;
显示文字(大署,最高价*1.02,'大署'),COLORMAGENTA,ALIGN1;
显示文字(立秋,最高价*1.02,'立秋'),COLORYELLOW,ALIGN1;
显示文字(处暑,最高价*1.02,'处暑'),COLORYELLOW,ALIGN1;
显示文字(白露,最高价*1.02,'白露'),COLORYELLOW,ALIGN1;
显示文字(秋分,最高价*1.02,'秋分'),COLORYELLOW,ALIGN1;
显示文字(寒露,最高价*1.02,'寒露'),COLORYELLOW,ALIGN1;
显示文字(霜降,最高价*1.02,'霜降'),COLORYELLOW,ALIGN1;
显示文字(立冬,最高价*1.02,'立冬'),COLORWHITE,ALIGN1;
显示文字(小雪,最高价*1.02,'小雪'),COLORWHITE,ALIGN1;
显示文字(大雪,最高价*1.02,'大雪'),COLORWHITE,ALIGN1;
显示文字(冬至,最高价*1.02,'冬至'),COLORWHITE,ALIGN1;
显示文字(小寒,最高价*1.02,'小寒'),COLORWHITE,ALIGN1;
显示文字(大寒,最高价*1.02,'大寒'),COLORWHITE,ALIGN1;
GET:ZIG(3,5)COLORWHITE,LINETHICK2;
{开盘既知今天高低价}
高:=MA(REF(H,1)/REF(C,2),27)*REF(C,1);
低:=MA(REF(L,1)/REF(C,2),27)*REF(C,1);
A5:=低[SYSPARAM(1)];
RA5:=低[SYSPARAM(1)-1];
A10:=高[SYSPARAM(1)];
RA10:=高[SYSPARAM(1)-1];
jt5:=if(A5>RA5,'↑','↓');
jt10:=if(A10>RA10,'↑','↓');
SZ1:='开盘预测最高价:'+NUMTOSTR(高[SYSPARAM(1)],2)+jt10;
DRAWTEXT(BARPOS=SYSPARAM(2),c,SZ1),align4,COLORMAGENTA;
SZ:='\n \n开盘预测最低价:'+NUMTOSTR(低[SYSPARAM(1)],2)+jt5;
DRAWTEXT(BARPOS=SYSPARAM(2),c,SZ),align4,COLORGREEN;

飞狐波浪与波神主图指标公式

 

相关文章