在线检测未来函数

飞狐黑马全息彩虹版主图指标公式

来源:Internet,编辑:股旁网,2011-07-29

上:=SMA(HIGH,21,2)*1.05;
DRAWTEXT(FILTER(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>上 AND CLOSE<上,5),HIGH+0.05,'-减仓'),colorFFFFFF;
下轨道:SMA(LOW,21,2)*0.969,POINTDOT,colorFFFF;
BMA:=MA(CLOSE,118);
阻挡:=SMA(HIGH,21,2)*1.05;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=3*K12-2*D12;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
支撑位:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24))));
压力位:IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J)))),colorFF00;
U2L:=IF(CLOSE>=MA(CLOSE,20),80,50);
L2L:=IF(CLOSE>=MA(CLOSE,20),50,20);
RH1:=IF(J<U2L AND REF(J,1)>=U2L,HHV(REF(HIGH,1),(BARSLAST(J>=U2L AND REF(J,1)<U2L))-1),REF(HHV(REF(HIGH,1),(BARSLAST(J>=U2L AND REF(J,1)<U2L))-1),BARSLAST(J<U2L AND REF(J,1))));
RH4:=IF(HIGH>RH1,LOW,REF(LOW,BARSLAST(HIGH>RH1)));
RH42:=IF(HIGH>RH1,J,REF(J,BARSLAST(HIGH>RH1)));
RH5:=IF(HIGH>RH4 AND J<RH42 AND J<J24,HIGH,REF(HIGH,BARSLAST(HIGH>RH4 AND J<RH42 AND J<J24)));
RL1:=IF(J>L2L AND REF(J,1)<=L2L,LLV(REF(LOW,1),(BARSLAST(J<=L2L AND REF(J,1)>L2L))-1),REF(LLV(REF(LOW,1),(BARSLAST(J<=L2L AND REF(J,1)>L2L))-1),BARSLAST(J>L2L AND REF(J,1))));
RL4:=IF(LOW<RL1,HIGH,REF(HIGH,BARSLAST(LOW<RL1)));
RL42:=IF(LOW<RL1,J,REF(J,BARSLAST(LOW<RL1)));
RL5:=IF(LOW<RL4 AND J>RL42 AND J>J24,LOW,REF(LOW,BARSLAST(LOW<RL4 AND J>RL42 AND J>J24)));
CB:=AMOUNT/VOL/100;
CD:=CB>HIGH OR CB<LOW;
黑马趋势:=MA(CLOSE,3);
MAP:=MA(CLOSE,8);
AA5:=MA(CLOSE,21);
AA10:MA(CLOSE,8),colorFF;
AA12:MA(CLOSE,12),colorFF;
BB10:=(ATAN(AA10-REF(AA10,1)))*3.1416*10;
BB12:=(ATAN(AA12-REF(AA12,1)))*3.1416*10;
MA13:=MA(CLOSE,13);
DRAWTEXT(FILTER(CLOSE/OPEN>1.04 AND CLOSE-REF(CLOSE,1)>0 AND CLOSE>下轨道 AND AA10-REF(AA10,1)>0 AND CLOSE<上,3),LOW-0.07,'追击'),colorD1E768;
FILLRGN(AA12<=AA10 AND BB12>=1 AND BB10>=1,AA10,AA12),colorFF;
FILLRGN(AA12>=AA10 AND BB10<=1 AND BB10<=1,AA10,AA12),colorFF00;
VARD:=(OPEN+LOW+HIGH+CLOSE)/4;
支撑:=EMA(VARD,5);
短期底部:=LLV(OPEN,30);
DRAWTEXT(CROSS(黑马趋势,短期底部) AND RL5-REF(RL5,1)>0 AND 黑马趋势-REF(黑马趋势,1)>0 AND 黑马趋势>1 AND LOW<=支撑位 AND CLOSE>支撑位 AND HIGH<压力位,LOW-0.15,'←黑马发现'),colorFFFF;
DRAWTEXT(CROSS(黑马趋势,RL5) AND 黑马趋势-REF(黑马趋势,1)>0 AND HIGH<压力位 AND LOW<=短期底部 AND CLOSE>支撑位 AND CD<1 AND CLOSE>OPEN AND CLOSE>RL5,LOW,'←短买'),colorFF00;
DRAWTEXT(FILTER(LOW<=短期底部 AND CLOSE-REF(CLOSE,1)>CLOSE AND MA(CLOSE,10)-REF(MA(CLOSE,10),1)>0 AND WINNER(CLOSE)<0.05 AND 短期底部=RL5 AND LOW<=RL5 AND HIGH<压力位,3),LOW,'★机会难得'),colorFFFFFF;
历史大底:DRAWTEXT(FILTER(LLV(LOW,0) AND WINNER(CLOSE)<0.08 AND LOW<=短期底部 AND CLOSE>短期底部 AND J<80 AND CLOSE/OPEN>1.08,20),LOW-0.45,'★★历史大底');
DRAWTEXT(FILTER(LOW<=短期底部 AND CLOSE>压力位 AND AA5-REF(AA5,1)>0 AND J<80 AND CLOSE>支撑位 AND 黑马趋势-REF(黑马趋势,1)>0 AND WINNER(CLOSE)<0.1 AND CLOSE>OPEN,5),LOW-0.15,'★黑马登天'),colorCDEEC5;
X1:=(3*CLOSE+HIGH+LOW+OPEN)/6;
X2:=EMA(X1,10);
X3:=REF(X2,1);
X4:=(REF(HIGH,1)+REF(LOW,1))/2;
X5:=MA(CLOSE,21)+2*STD(CLOSE,21);
X6:=REF(CLOSE,1);
X7:=(SMA(MAX(CLOSE-X6,0),7,1))/(SMA(ABS(CLOSE-X6),7,1))*100;
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
MAP1:=MA(CLOSE,60);
均线30:=MA(CLOSE,30);
均线89:=MA(CLOSE,89);
均线:=MA(CLOSE,16);
均线34:=MA(CLOSE,34);
均线55:=MA(CLOSE,55);
VAR1:=EMA(CLOSE,8);
VAR2:=EMA(VAR1,20);
VAR3:=CROSS(VAR1,VAR2);
VAR4:=VAR1<MA(CLOSE,60);
VAR5:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR6:=SMA(VAR5,5,1);
VAR7:=SMA(VAR6,8,1);
VAR8:=CROSS(VAR6,VAR7) AND VAR7<16;
VAR9:=CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR8;
VARA:=IF(CLOSE>1000,VAR8,VAR9);
黑马起步:=VAR3 AND VAR4;
逃遁:=VARA;
均线20:=MA(CLOSE,20);
均线120:=MA(CLOSE,120);
牛熊线:=MA(CLOSE,250);
VA:=CROSS(MA(CLOSE,19),MA(CLOSE,120));
VB:=MA(CLOSE,20)>MA(CLOSE,120);
VC:=CROSS(MA(CLOSE,120),MA(CLOSE,89));
VD:=MA(CLOSE,20)<MA(CLOSE,120);
VE:=CROSS(MA(CLOSE,20),MA(CLOSE,250));
VF:=MA(CLOSE,20)>MA(CLOSE,250);
VG:=CROSS(MA(CLOSE,250),MA(CLOSE,20));
DRAWTEXT(FILTER(OPEN>均线120 AND 均线20<均线120 AND LOW<=均线120 AND 均线20-REF(均线20,1)>0 AND CLOSE>OPEN AND 均线120-REF(均线120,1)>0 AND HIGH<RH5 AND CLOSE>=均线120,15),LOW,'★120跳马'),color89E0;
DRAWTEXT(VA AND 均线120-REF(均线120,1)>0 AND HIGH<RH5 AND CLOSE>OPEN,LOW,'★宝马望月'),colorFFFFFF;
DRAWTEXT(均线-REF(均线,1)>0 AND CROSS(均线20,均线120) AND LOW<=均线120 AND CLOSE>=均线120,LOW,'三线开花'),colorFFFFFF;
短期底部2:LLV(HIGH,30),LINETHICK2,colorFF;
上轨:SMA(HIGH,21,2)*1.092,POINTDOT,colorFFFFFF;
中轨道:SMA(HIGH,21,2)*1.017,POINTDOT,colorFFFFFF;
DRAWTEXT(FILTER(LOW<下轨道 AND CLOSE>MA(CLOSE,15) AND CLOSE>短期底部2 AND HIGH<压力位,10),LOW,'★短线5%'),color9DC522;
DRAWTEXT(HIGH>=均线120 AND CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>上 AND CLOSE<上 AND CLOSE<均线120,HIGH+0.05,'减仓'),colorFF00;
DRAWTEXT(FILTER(HIGH>阻挡 AND CLOSE<阻挡,5),HIGH+0.15,'←逃命');
DRAWTEXT(VE>VG AND HIGH<阻挡,LOW-0.65,'★黑马短线'),colorFFFF;
DRAWTEXT(FILTER(OPEN<X2 AND CLOSE>X2 AND 支撑-REF(支撑,1)>0 AND 支撑-REF(支撑,1)>0 AND CLOSE<阻挡 AND 均线-REF(均线,1)>0 AND CLOSE>=均线 AND HIGH<阻挡 AND AA10-REF(AA10,1)>0 AND 阻挡-REF(阻挡,2)>0,11),LOW-0.11,'★快马加鞭'),colorFF;
DRAWTEXT(FILTER(OPEN<X2 AND WINNER(CLOSE)<0.2 AND CLOSE>X2 AND X2-REF(X2,1)>0 AND HIGH<阻挡 AND CLOSE-REF(CLOSE,1)>0.35,4),LOW-0.05,'★黑马狂奔'),colorD18073;
DRAWTEXT(CROSS(支撑,均线) AND HIGH<中轨道 AND WINNER(CLOSE)<0.2 AND CLOSE<阻挡 AND CLOSE>OPEN AND LOW<=X2 AND CLOSE>=X2 AND CROSS(支撑,X2),LOW,'★黑马起步'),colorFFFF;
DRAWTEXT(CROSS(X4,X5),HIGH,'●减仓'),colorB4FF;
DRAWTEXT(X9,HIGH*1.03,'出货'),color9000F5;
DRAWTEXT(黑马起步>0 AND LOW<=X2 AND 均线-REF(均线,1)>0,LOW-0.11,'★黑马起步'),colorFF00;
DRAWTEXT(逃遁>0,HIGH*1.14,'●逃命'),colorFF;
RDV:=SMA(LOW,8,1);
DRAWTEXT(CROSS(K,D) AND CLOSE>=OPEN AND X2-REF(X2,1)>0 AND RDV-REF(RDV,1)>0 AND K<=33,LOW-0.08,'★黑马初现'),color8500DE;
DRAWTEXT(FILTER(LOW<=短期底部 AND WINNER(CLOSE)<0.2 AND CLOSE<牛熊线 AND HIGH<阻挡 AND X2-REF(X2,1)>0 AND CLOSE>OPEN AND HIGH>=X3,5),LOW-0.03,'←黑马筑底'),color85B256;
RCK:=SMA(LOW,21,2)*0.95;
趋势线:=SMA(LOW,5,1);
大胆买入:DRAWTEXT(CROSS(趋势线,RCK) AND LOW<=X2 AND X2-REF(X2,1)>0,LOW,'←★大胆买入'),colorE50000;
B1:=(HIGH+LOW+CLOSE)/3;
B6:=HHV(B1,4*15);
B7:=LLV(B1,4*15);
B8:=B6-B7;
飞龙顶底线:=MA((B1-B7)/B8,2)*80;
DRAWTEXT(FILTER(飞龙顶底线<=1 AND WINNER(CLOSE)<0.02 AND HIGH<趋势线 AND CLOSE>OPEN AND LOW<=短期底部 AND CLOSE>短期底部,8),LOW-0.02,'←黑马寻底'),colorE7DD1F;
DRAWTEXT(FILTER(LOW<=短期底部 AND WINNER(CLOSE)<0.015 AND OPEN/CLOSE>0.99 AND J-REF(J,1)>0 AND CLOSE>OPEN AND HIGH<支撑位 AND CLOSE>短期底部,25),LOW-0.09,'←开始建仓'),colorFFFF;
DRAWTEXT(FILTER(LOW<=均线30 AND AA10-REF(AA10,1)>0 AND 均线-REF(均线20,1)>0 AND 趋势线-REF(趋势线,1)>0 AND CLOSE>=均线30 AND WINNER(CLOSE)<0.15 AND CLOSE/OPEN>1.01,3),LOW,'★天马奔月'),color76B0FC;
DRAWTEXT(OPEN<=均线 AND 均线30-REF(均线30,1)>0 AND CLOSE>均线89 AND BB10>1 AND CLOSE/OPEN>1.04,LOW,'★天马过桥'),colorCC99FF;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,9,0),colorFF5B00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,8,0),colorFF6C00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,7,0),colorFF7B00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,6,0),colorFF9C00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,5,0),colorFFBE00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.5,0),colorFFCC00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),colorFFFF00;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,9,0),color70084;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,8,0),colorA3;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7,0),colorB7;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6,0),colorCD;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,5,0),colorE9;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),color754E9;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1.5,0),color76EF3;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1,0),color77BF3;
STICKLINE(CLOSE>OPEN,OPEN,LOW,1,0),color726CA;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,1,0),color726CA;
STICKLINE(OPEN>CLOSE,CLOSE,LOW,1,0),colorDE9100;
STICKLINE(OPEN>CLOSE,OPEN,HIGH,1,0),colorDE9100;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,CLOSE,OPEN,9,0),color90FF;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,CLOSE,OPEN,8,0),color9FFF;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,CLOSE,OPEN,4,0),colorB5FF;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,CLOSE,OPEN,2,0),colorE4FF;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,OPEN,LOW,0.7,0),colorFFFF;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,CLOSE,HIGH,0.7,0),colorFFFF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,OPEN,LOW,0.7,0),colorFF76FF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,CLOSE,HIGH,0.7,0),colorFF76FF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,CLOSE,OPEN,9,0),colorFF00FF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,CLOSE,OPEN,6,0),colorFF62FF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,CLOSE,OPEN,4,0),colorFF76FF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,CLOSE,OPEN,2,0),colorFFA8FF;
MRZY:=ROUND(((REF(HIGH,1)-REF(LOW,1))*8/10+CLOSE)*100)/100;
MRZS:=ROUND((CLOSE-(REF(HIGH,1)-REF(LOW,1))*8/20)*100)/100;
VERTLINE(CLOSE>0 AND ISLASTBAR),POINTDOT,SHIFT1,colorFFFF;
STICKLINE(CLOSE>OPEN AND ISLASTBAR,MRZY,MRZS,8,1),SHIFT2,colorFF00FF;
STICKLINE(CLOSE<=OPEN AND ISLASTBAR,MRZY,MRZS,8,1),SHIFT2,colorFFFF00;
EXPLAIN(1=1,' 【技术分析彩虹版】'),colorFFFF;
DIFF:=EMA(CLOSE,3)-EMA(CLOSE,13);
DEA:=EMA(DIFF,9);
TJ:=DIFF>DEA;
TJ1:=DIFF>-0.1;
MACD:=2*(DIFF-DEA);
JC:=CROSS(DIFF,DEA);
SC:=CROSS(DEA,DIFF);
DCJC:=JC AND DEA>0;
EXPLAIN(JC AND DEA>0,'MACD在0轴上金叉提示加仓;'),colorFF;
EXPLAIN(JC AND DEA<0,'MACD在0轴下金叉酌情买入;'),colorFF;
EXPLAIN(SC AND DEA>0,'MACD在0轴上多次死叉;'),colorFF00;
EXPLAIN(SC AND DEA<0,'MACD在0轴下多次死叉;'),colorFF00;
EXPLAIN(MACD<0 AND ABS(MACD)>REF(ABS(MACD),1),'MACD绿柱增长提示卖出;'),colorFF00;
EXPLAIN(MACD<0 AND ABS(MACD)<REF(ABS(MACD),1),'MACD绿柱缩短提示买入;'),colorFF;
EXPLAIN(LLV(LOW,60)=LOW AND NOT(LLV("MACD.DEA",60)="MACD.DEA"),'MACD底背离提示示买入;'),colorFF;
EXPLAIN(HHV(HIGH,60)=HIGH AND NOT(HHV("MACD.DEA",60)="MACD.DEA"),'MACD顶背离提示卖出;'),colorFF00;
EXPLAIN(CROSS("MACD.DIFF","MACD.DEA") AND BARSLAST(CROSS("MACD.DIFF","MACD.DEA"))>=3,'MACD二次金叉提示买入,股价上涨幅度会较大。'),colorFF;
EXPLAIN(CROSS("MACD.DEA","MACD.DIFF") AND BARSLAST(CROSS("MACD.DEA","MACD.DIFF"))>=3,'MACD二次死叉提示卖出,股价下跌幅度会较大。'),colorFF00;
EXPLAIN((COUNT(CLOSE<REF(CLOSE,1),30))>18 AND (COUNT(CLOSE<REF(CLOSE,1),3))=3 AND (COUNT("MACD.MACD">REF("MACD.MACD",1),30))>18,'MACD反转--股价将可能反转向上。'),colorFF;
EXPLAIN((COUNT(CLOSE>REF(CLOSE,1),30))>18 AND (COUNT(CLOSE>REF(CLOSE,1),3))=3 AND (COUNT("MACD.MACD"<REF("MACD.MACD",1),30))>18,'MACD反转--股价将可能反转向下。'),colorFF00;
EXPLAIN(COUNT(DCJC,20)=2 AND JC AND DEA>0,'MACD在0轴上2金叉;'),color1;
EXPLAIN(COUNT(DCJC,20)=3 AND JC AND DEA>0,'MACD在0轴上3金叉;');
EXPLAIN(COUNT(DCJC,20)=4 AND JC AND DEA>0,'MACD在轴上4金叉;');
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),7,1))/(SMA(ABS(CLOSE-LC),7,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),14,1))/(SMA(ABS(CLOSE-LC),14,1))*100;
EXPLAIN("RSI.RSI1"<15 AND (BARSLAST("RSI.RSI1"<15))>=1,'RSI相对强弱指标超卖,属买入信号。'),colorFF;
EXPLAIN("RSI.RSI1">85 AND (BARSLAST("RSI.RSI1">85))>=1,'RSI相对强弱指标超买,属卖出信号。'),colorFF00;
EXPLAIN((LLV(LOW,20)=LOW AND NOT(LLV("RSI.RSI1",20)="RSI.RSI1") OR (COUNT(CLOSE<REF(CLOSE,1),30))>18 AND (COUNT("RSI.RSI1">REF("RSI.RSI1",1),30))>18) AND "RSI.RSI1"<20,'RSI相对强弱指标底背离,股价在低位时属买入信号。'),colorFF;
EXPLAIN((HHV(HIGH,20)=HIGH AND NOT(HHV("RSI.RSI1",20)="RSI.RSI1") OR (COUNT(CLOSE>REF(CLOSE,1),30))>18 AND (COUNT("RSI.RSI1"<REF("RSI.RSI1",1),30))>18) AND "RSI.RSI1">80,'RSI相对强弱指标顶背离,股价在高位时属卖出信号。'),colorFF00;
EXPLAIN(CROSS("RSI.RSI1","RSI.RSI2") AND "RSI.RSI1"<50,'RSI相对强弱指标金叉属买入信号。'),colorFF;
EXPLAIN(CROSS("RSI.RSI2","RSI.RSI1") AND "RSI.RSI1">50,'RSI相对强弱指标死叉,属卖出信号。'),colorFF00;
EXPLAIN("RSI.RSI1"<5,'RSI相对强弱指标极低位,强烈买入信号。'),colorFF;
EXPLAIN("RSI.RSI1">93,'RSI相对强弱指标极高位,强烈卖出信号。'),colorFF00;
EXPLAIN(RSI1<35,'RSI顶背离提示买入;'),colorFF;
EXPLAIN(CROSS(74,RSI1),'RSI顶背离提示卖出;'),colorFF00;
EXPLAIN("KDJ.K"<=20 AND "KDJ.D"<=20,'KD超卖指示买入;'),colorFF;
EXPLAIN("KDJ.K">=80 AND "KDJ.D">=80,'KD超买逢高卖出;'),colorFF00;
EXPLAIN(CROSS("KDJ.K","KDJ.D") AND (COUNT(VOL>REF(VOL,1),30))>3 AND VOL/CAPITAL<=10/100 AND "KDJ.K"<=20 AND "KDJ.D"<=20,'KD金叉买入,低市值或成交清淡个股应忽略此信号。'),colorFF;
EXPLAIN(CROSS("KDJ.D","KDJ.K") AND "KDJ.K">=60 AND "KDJ.D">=60 AND (BARSLAST(CROSS("KDJ.D","KDJ.K") AND "KDJ.K">=60 AND "KDJ.D">=60))>=1 AND (BARSLAST(CROSS("KDJ.D","KDJ.K") AND "KDJ.K">=60 AND "KDJ.D">=60))<=7,'KD二次死叉提示卖出;'),colorFF00;
EXPLAIN("KDJ.J"<0,'KDJ异常逢低买入'),colorFF;
EXPLAIN(HHV(HIGH,20)=HIGH AND (NOT(HHV("KDJ.K",20)="KDJ.K" OR HHV("KDJ.D",20)="KDJ.D")) OR (COUNT(CLOSE>REF(CLOSE,1),30))>18 AND ((COUNT("KDJ.K"<REF("KDJ.K",1),30))>18 OR (COUNT("KDJ.D"<REF("KDJ.D",1),30))>18),'KD顶背离提示卖出;'),colorFF00;
EXPLAIN(LLV(LOW,20)=LOW AND (NOT(LLV("KDJ.K",20)="KDJ.K" OR LLV("KDJ.D",20)="KDJ.D")) OR (COUNT(CLOSE<REF(CLOSE,1),30))>18 AND ((COUNT("KDJ.K">REF("KDJ.K",1),30))>18 OR (COUNT("KDJ.D">REF("KDJ.D",1),30))>18),'KD底背离提示买入;'),colorFF;
日K:="KDJ.K#day"(20,5,5);
日D:="KDJ.D#day"(20,5,5);
周K:="KDJ.K#week"(9,3,3);
周D:="KDJ.D#week"(9,3,3);
EXPLAIN(CROSS(日K,日D),'日KD金叉且底背离买入;'),colorFF;
EXPLAIN(CROSS(日D,日K),'日KD死叉且顶背离必须卖出;'),colorFF00;
EXPLAIN(CROSS(周K,周D),'周KD金叉且底背离买入;'),colorFF;
EXPLAIN(CROSS(周D,周K),'周KD死叉且顶背离必须卖出;'),colorFF00;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
UPR:=BBI+3*STD(BBI,10);
DWN:=BBI-3*STD(BBI,10);
VAR55:=(UPR-DWN)/UPR<0.03;
VAR56:=(UPR-DWN)/UPR>0.18;
VAR57:=(MA(CLOSE,60)-MA(CLOSE,5))/MA(CLOSE,60)>0.15;
VAR58:=(MA(CLOSE,5)-MA(CLOSE,60))/MA(CLOSE,5)>0.15;
EXPLAIN(VAR55,'布林线收窄可能变盘;'),colorFF00FF;
EXPLAIN(VAR57 AND VAR56 AND CLOSE>OPEN,'布林上下乖离太大可能反弹;'),colorFF00FF;
EXPLAIN(VAR58 AND VAR56 AND CLOSE<OPEN,'布林上下乖离太大可能回落;'),colorFF00;
EXPLAIN(CROSS(CLOSE,"SAR") AND (ABS(CLOSE-"SAR"))/CLOSE>=0.01,'SAR向上突破提示买入;'),colorFF;
EXPLAIN(CROSS("SAR",CLOSE) AND (ABS(CLOSE-"SAR"))/CLOSE>=0.01,'SAR向下突破提示卖出;'),colorFF00;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
EXPLAIN(CCI<-100,'CCI指标底位,买入机会。'),colorFF;
EXPLAIN(CCI>100,'CCI指标高位,卖出机会。'),colorFF00;
EXPLAIN(VOL/CAPITAL>0.075,'换手过大,小心主力出逃,短期头部。'),colorFFFF;
WR:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
EXPLAIN(WR>-20,'W&R超买,即将见顶,应及时卖出。'),colorFF00;
EXPLAIN(WR<-80,'W&R超卖,即将见底,应伺机买进。'),colorFF;
MTM:=CLOSE-REF(CLOSE,6);
MTMMA:=MA(MTM,6);
EXPLAIN(CROSS(MTM,MTMMA),'MTM从下向上突破MTMMA,买入信号。'),colorFF;
EXPLAIN(CROSS(MTMMA,MTM),'MTM从上向下跌破MTMMA,卖出信号。'),colorFF00;
EXPLAIN("ARBR.AR"<50,'ARBR人气指标超卖,属买入信号。'),colorFF;
EXPLAIN("ARBR.AR">200,'ARBR人气指标超买,属卖出信号。'),colorFF00;
EXPLAIN((HHV("ARBR.AR",10)-"ARBR.AR")/HHV("ARBR.AR",10)>=0.5,'ARBR人气指标异常,若股价从高价下跌,属买入信号。'),colorFF;
EXPLAIN(("ARBR.AR"-LLV("ARBR.AR",10))/LLV("ARBR.AR",10)>=0.5,'ARBR人气指标异常,若股价从低价上升,属卖出信号。'),colorFF00;
EXPLAIN("ARBR.BR"<50,'ARBR意愿指标显示股价随时反弹考虑买入。'),colorFF;
EXPLAIN("ARBR.BR">300,'ARBR意愿指标显示股价随时下挫考虑卖出。'),colorFF00FF;
EXPLAIN(CROSS("ARBR.AR","ARBR.BR") AND ("ARBR.AR"<50 OR "ARBR.BR"<50),'ARBR人气意愿指标金叉,属买入信号。'),colorFF;
EXPLAIN(CROSS("ARBR.BR","ARBR.AR") AND ("ARBR.AR">180 OR "ARBR.BR">300),'ARBR人气意愿指标死叉,属卖出信号。'),colorFF00;
EXPLAIN((COUNT(CLOSE<REF(CLOSE,1),30))>18 AND (COUNT(CLOSE<REF(CLOSE,1),3))=3 AND (COUNT("OBV.OBV">REF("OBV.OBV",1),30))>18 AND (COUNT("OBV.OBV">REF("OBV.OBV",1),3))=3 AND (COUNT(VOL>REF(VOL,1),30))>3 AND VOL/CAPITAL<=10/100,'OBV能量潮显示买盘较强属买入信号。'),colorFF;
EXPLAIN((COUNT(CLOSE>REF(CLOSE,1),30))>18 AND (COUNT(CLOSE>REF(CLOSE,1),3))=3 AND (COUNT("OBV.OBV">REF("OBV.OBV",1),30))>18 AND (COUNT("OBV.OBV">REF("OBV.OBV",1),3))=3 AND (COUNT(VOL>REF(VOL,1),30))>3 AND VOL/CAPITAL<=10/100,'OBV能量潮显示买盘逐渐加强属买入信号。'),colorFF;
EXPLAIN((COUNT(CLOSE>REF(CLOSE,1),30))>18 AND (COUNT(CLOSE>REF(CLOSE,1),3))=3 AND ((COUNT("OBV.OBV"<REF("OBV.OBV",1),30))>18 OR (COUNT("OBV.OBV"<REF("OBV.OBV",1),3))=3),'OBV能量潮显示买盘无力属卖出信号。'),colorFF00;
EXPLAIN(CROSS("OBV.OBV",0) AND (COUNT(REF("OBV.OBV",1)<0,3))=3,'OBV能量潮由负转正属买入信号。'),colorFF;
EXPLAIN(CROSS(0,"OBV.OBV") AND (COUNT(REF("OBV.OBV",1)>0,3))=3,'OBV能量潮由正转负属卖出信号。'),colorFF00;
EXPLAIN(HHV(HIGH,20)=HIGH AND NOT(HHV("OBV.OBV",20)="OBV.OBV"),'OBV能量潮顶背离属卖出信号。'),colorFF00;
EXPLAIN(LLV(LOW,20)=LOW AND NOT(LLV("OBV.OBV",20)="OBV.OBV"),'OBV能量潮底背离属买入信号。'),colorFF;
EXPLAIN((ABS("OBV.OBV"-REF("OBV.OBV",1)))/ABS(MA("OBV.OBV",5))>0.07 AND "OBV.OBV">REF("OBV.OBV",1),'OBV能量潮异常。若股价在高位属卖出信号,若OBV能量线在低位长时间横向整理后出现,属买入信号。'),colorFF00FF;
EXPLAIN("CR.CR"<40,'CR能量指标超卖,提示股价形成底部,属买入信号。'),colorFF;
EXPLAIN("CR.CR"<=400 AND "CR.CR">=300,'CR能量指标超买,属卖出信号。'),colorFF00;
EXPLAIN(LLV(LOW,20)=LOW AND NOT(LLV("CR.CR",20)="CR.CR"),'CR能量指标底背离,属买入信号。'),colorFF;
EXPLAIN(HHV(HIGH,20)=HIGH AND NOT(HHV("CR.CR",20)="CR.CR"),'CR能量指标顶背离,属卖出信号。'),colorFF00;
EXPLAIN(ABS("CR.MA1"-"CR.MA2")<5 AND ABS("CR.MA1"-"CR.MA3")<5 AND ABS("CR.MA2"-"CR.MA3")<5 OR ABS("CR.MA1"-"CR.CR")<5 AND ABS("CR.MA1"-"CR.MA3")<5 AND ABS("CR.CR"-"CR.MA3")<5,'CR能量指标异常,一波或长或短的上升或下跌行情即将展开。'),colorFF00FF;
EXPLAIN("PSY"<10,'PSY心理线指标低位超卖区,属买入信号。'),colorFF;
EXPLAIN(BETWEEN("PSY","PSY">10,"PSY"<25),'PSY心理线指标超卖,属买入信号。'),colorFF;
EXPLAIN("PSY">75,'PSY心理线指标超买,属卖出信号。'),colorFF00;
EXPLAIN(CROSS("ROC.ROC",0),'ROC变动速率指标向上突破,属买入信号。'),colorFF;
EXPLAIN(CROSS(0,"ROC.ROC"),'ROC变动速率指标向下突破,属卖出信号。'),colorFF00;
EXPLAIN(LLV(LOW,20)=LOW AND NOT((COUNT("ROC.ROC"<REF("ROC.ROC",1),30))>18 AND (COUNT("ROC.ROC"<REF("ROC.ROC",1),3))=3),'ROC变动速率指标,显示下跌动力减弱,属买入信号。'),colorFF;
EXPLAIN(HHV(HIGH,20)=HIGH AND NOT((COUNT("ROC.ROC">REF("ROC.ROC",1),30))>18 AND (COUNT("ROC.ROC">REF("ROC.ROC",1),3))=3),'ROC变动速率指标,显示上涨动力减弱,属卖出信号。'),colorFF00;
EXPLAIN((COUNT(CLOSE>REF(CLOSE,1),30))>18 AND (COUNT(CLOSE>REF(CLOSE,1),3))=3 AND (COUNT("ROC.ROC">REF("ROC.ROC",1),30))>18 AND (COUNT("ROC.ROC">REF("ROC.ROC",1),3))=3,'ROC变动速率指标显示短期反弹有望,属买入信号。'),colorFF;
EXPLAIN((COUNT(CLOSE<REF(CLOSE,1),30))>18 AND (COUNT(CLOSE<REF(CLOSE,1),3))=3 AND (COUNT("ROC.ROC"<REF("ROC.ROC",1),30))>18 AND (COUNT("ROC.ROC"<REF("ROC.ROC",1),3))=3,'ROC变动速率指标显示短期警惕回落,属卖出信号。'),colorFF00;
EXPLAIN("VR"<20,'VR容量比率指标显示股价即将涨升,建议积极买入。'),colorFF;
EXPLAIN("VR">400,'VR容量比率指标显示后续资金枯竭,股价将可能高位下跌,属卖出信号。'),colorFF00;
EXPLAIN(("VR"/REF("VR",1)>=2 OR "VR"/REF("VR",2)>=2) AND (COUNT(CLOSE<=REF(CLOSE,1),5))>=3,'VR容量比率指标异常,显示股价即将涨升,属买入信号。'),colorFF;
EXPLAIN("VR">300 AND (COUNT("VR"<REF("VR",1),5))>=3 AND (COUNT(CLOSE>REF(CLOSE,1),5))>=3,'VR容量比率指标显示涨势耗尽,建议卖出。'),colorFF00;
VV6:=(2*CLOSE+HIGH+LOW)/4;
VV7:=LLV(LOW,27);
VV8:=HHV(HIGH,27);
攀:=EMA((VV6-VV7)/(VV8-VV7)*100,13)-50;
金:=EMA(0.618*REF(攀,1)+0.382*攀,3);
起攀:=CROSS(攀,金) AND CLOSE>OPEN;
EXPLAIN(CROSS(攀,金) AND CLOSE>OPEN,'起攀指标发出起攀买入信号。'),colorFF;
EXPLAIN(1=1,' 【均线系统分析】'),colorFFFF;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
MA125:=MA(CLOSE,125);
MA250:=MA(CLOSE,250);
EXPLAIN(MA5>MA10 AND MA10>MA30 AND MA5>MA30,'短期均线多头排列;'),colorFF;
EXPLAIN(MA5<MA10 AND MA10<MA30 AND MA5<MA30,'短期均线空头排列;'),colorFF00;
EXPLAIN(MA30>MA60 AND MA30>MA125 AND MA60>MA125,'中期均线多头排列;'),colorFF;
EXPLAIN(MA30<MA60 AND MA30<MA125 AND MA60<MA125,'中期均线空头列排;'),colorFF00;
EXPLAIN(MA60>MA125 AND MA125>MA250 AND MA60>MA250,'长期均线多头排列;'),colorFF;
EXPLAIN(MA60<MA125 AND MA125<MA250 AND MA60<MA250,'长期均线空头排列;'),colorFF00;
EXPLAIN(CROSS(MA5,MA10),'短期5日10日均线金叉;'),colorFF;
EXPLAIN(CROSS(MA10,MA5),'短期5日10日均线死叉;'),colorFF00;
EXPLAIN(CROSS(CLOSE,MA125),'今日股价上穿半年线;'),colorFF00FF;
EXPLAIN(CROSS(MA125,CLOSE),'今日股价跌破半年线;'),colorFF00;
EXPLAIN(CROSS(CLOSE,MA250),'今日股价上穿一年线;'),colorFF00FF;
EXPLAIN(CROSS(MA250,CLOSE),'今日股价跌破一年线;'),colorFF00;
EXPLAIN(CROSS(CLOSE,MA60) AND CROSS(CLOSE,MA125) AND CROSS(CLOSE,MA250),'股价一阳穿三线;'),colorFF;
EXPLAIN(MA30>REF(MA30,1),'30日均线趋势向上;'),colorFF;
EXPLAIN(MA30>REF(MA30,1) AND MA30<REF(MA30,1)*1.001,'30日均线趋势走平;'),colorFFCC66;
EXPLAIN(MA30<REF(MA30,1),'30日均线趋势向下;'),colorFF00;
EXPLAIN(MA5>REF(MA5,1)*1.015,'5日均线强劲向上;'),colorFF;
EXPLAIN(MA5>REF(MA5,1) AND MA5<REF(MA5,1)*1.005,'5日均线方向不明;'),colorFFFF;
EXPLAIN(MA5<REF(MA5,1)*0.985,'5日均线快速向下;'),colorFF00;
EXPLAIN(1=1,' 【形态分析】'),colorFFFF;
早晨之星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND (ABS(REF(OPEN,1)-REF(CLOSE,1)))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2)>1.03 AND REF(OPEN,1)>REF(CLOSE,2) AND (ABS(REF(OPEN,1)-REF(CLOSE,1)))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW>1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE>MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);
锤头:=HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE<MA(CLOSE,5);
吊颈:=HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1) OR REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1);
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
身怀六甲:=(ABS(REF(CLOSE,1)-REF(OPEN,1)))/REF(CLOSE,1)>0.04 AND (ABS(CLOSE-OPEN))/CLOSE<0.005 AND MAX(CLOSE,OPEN)<MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)>MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=(ABS(REF(CLOSE,1)-REF(OPEN,1)))/REF(CLOSE,1)>0.04 AND CLOSE=OPEN AND CLOSE<MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE>MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=(ABS(HIGH-REF(HIGH,1)))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1)))/LOW<0.001 AND (ABS(REF(LOW,1)-REF(LOW,2)))/REF(LOW,1)<=0.001;
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW<CLOSE/OPEN+0.018;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND CLOSE>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(CLOSE,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(CLOSE,20) OR OPEN<EMA(CLOSE,40) OR OPEN<EMA(CLOSE,60)) AND CLOSE>MAX(EMA(CLOSE,20),MAX(EMA(CLOSE,40),EMA(CLOSE,60))) AND VOL/MA(VOL,30)>1.2 AND CLOSE/REF(CLOSE,1)>1.049;
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:=REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE>1.05 AND HIGH/LOW<OPEN/CLOSE+0.018;
好友反攻:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND (ABS(CLOSE-REF(CLOSE,1)))/CLOSE<0.002 OR REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND (ABS(CLOSE-REF(CLOSE,1)))/CLOSE<0.002;
倾盆大雨:=REF(CLOSE,1)/REF(OPEN,1)>=1.03 AND OPEN<REF(CLOSE,1) AND OPEN>REF(OPEN,1) AND CLOSE<REF(OPEN,1);
EXPLAIN(倾盆大雨,'倾盆大雨,见顶信号;'),colorFFFF00;
EXPLAIN(大阴烛,'大阴烛,后市向淡,发生逆转;'),colorFFFF00;
EXPLAIN(好友反攻,'好友反攻,跌势已尽,要展开一段反弹行情;'),colorFF;
EXPLAIN(跳空缺口,'跳空缺口,突破长期盘整,向上跳空,上涨行情开始;向下跳空,下跌行情开始;'),colorFFFFFF;
EXPLAIN(光脚阴线,'光脚阴线,下跌信号;'),colorFFFF00;
EXPLAIN(光头阳线,'光头阳线,多方积极上攻态势,后市看涨;'),colorFF;
EXPLAIN(三只乌鸦,'三只乌鸦站枝头,可能见顶回落;'),colorFFFF00;
EXPLAIN(分离,'分离,注意看涨分离和看跌分离;'),colorFFFFFF;
EXPLAIN(长下影,'长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意;'),colorFF;
EXPLAIN(长上影,'长上影,表明行情上档压力沉重,升势受阻;'),colorFFFF00;
EXPLAIN(下跌三部曲,'下跌三部曲,下跌信号;'),colorFF;
EXPLAIN(上升三部曲,'上升三部曲,上涨信号;'),colorFFFF00;
EXPLAIN(早晨之星,'早晨之星,见底回升;'),colorFF;
EXPLAIN(黄昏之星,'黄昏之星,见顶回落;'),colorFFFF00;
EXPLAIN(十字星,'十字星,重要的警告信号,原趋势停顿或反转;'),colorFFFFFF;
{www.gUPang.com 股旁网_最新股票指标公式}
EXPLAIN(长十字,'长十字,重要的警告信号,原趋势停顿或反转;'),colorFFFFFF;
EXPLAIN(垂死十字,'垂死十字,下跌信号;'),colorFFFF00;
EXPLAIN(早晨十字星,'早晨十字星,上涨信号,见底回升;'),colorFF;
EXPLAIN(黄昏十字星,'黄昏十字星,趋势停顿或反转,下跌信号,见顶回落;'),colorFFFF00;
EXPLAIN(射击之星,'射击之星,出现在短期的上升趋势,表明市场顶部就在眼前,可能见顶回落,可靠性低;'),colorFFFF00;
EXPLAIN(倒转锤头,'倒转锤头构成一个看涨信号,可能见底回升;'),colorFF;
EXPLAIN(锤头,'锤头,可能见底回升,如有量配合,信号强烈;'),colorFF;
EXPLAIN(吊颈,'吊颈,上升行情中见顶回落,顶部出现,见顶信号;'),colorFFFF00;
EXPLAIN(平顶,'平顶,意味行情摸高见顶,股价行将反转。但反转下跌力度较小;'),colorFFFF00;
EXPLAIN(穿头破脚,'穿头破脚,顶部出现,见顶回落信号;'),colorFFFF00;
EXPLAIN(乌云盖顶,'乌云盖顶,见顶回落信号;'),colorFFFF00;
EXPLAIN(曙光初现,'曙光初现,行情将演化为V型反转或止跌横盘趋势。后市见底回升;'),colorFF;
EXPLAIN(身怀六甲,'身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信号;'),colorFF;
EXPLAIN(十字胎,'十字胎;'),colorFF;
EXPLAIN(平底,'平底,行情探低见底,股价行将反转上升,但力度较小;'),colorFF;
EXPLAIN(大阳烛,'大阳烛,在上升行情中出现,则意味着行情剧烈地向上攀升。在下跌行情中出现,则意味着行情剧烈地向上反弹;'),colorFF;
EXPLAIN(三个白武士,'三个白武士,每日收盘价上移,表示可能见底回升;'),colorFF;
EXPLAIN(双飞乌鸦,'双飞乌鸦,行情开始疲软将见顶回落;'),colorFFFF00;
EXPLAIN(孕育线,'孕育线,注意股价位置;'),colorFFFFFF;
EXPLAIN(多方炮,'多方炮,在底部出现有上涨可能,在中间出现有可能是上涨中继,顶部出现是复合见顶信号;'),colorFF;
EXPLAIN(出水芙蓉,'出水芙蓉,阳线穿过20、40、60日季均线,上攻势头初现;'),colorFF;
EXPLAIN(1=1,' 【资金面分析】'),colorFFFF;
VAR11:=MA(VOL/(HIGH-LOW),4);
VAR33:=ABS(CLOSE-OPEN);
VAR44:=VOL/(HIGH-LOW);
EXPLAIN(VAR44<VAR11 AND VAR33<MA(VAR33,4),'资金无入场意愿,萎缩中;'),colorFF00;
EXPLAIN(VAR44<VAR11 AND VAR33>MA(VAR33,4),'场内资金运作行为;'),colorFFCC66;
EXPLAIN(VAR44>VAR11 AND VAR33<MA(VAR33,4),'多空双方激烈争夺中;'),colorFF00FF;
EXPLAIN(VAR44>VAR11 AND VAR33>MA(VAR33,4),'场外资金介入(或出局)意愿强烈;'),colorFF;
EXPLAINEX(1=1,'该股五日换手%=',SUM(VOL/CAPITAL*100,5),2,0);
EXPLAINEX(1=1,'十日换手%=',SUM(VOL/CAPITAL*100,10),2,0);
EXPLAINEX(1=1,'二十日换手%=',SUM(VOL/CAPITAL*100,20),2,0);
EXPLAINEX(1=1,'百日换手%=',SUM(VOL/CAPITAL*100,100),2,0);
EXPLAINEX(1=1,'获利盘比例=',WINNER(CLOSE)*100,2,0);
EXPLAINEX(1=1,'套牢盘比例=',100-WINNER(CLOSE)*100,2,0);

飞狐黑马全息彩虹版主图指标公式

 

相关文章