在线检测未来函数

飞狐看牛骑牛主图指标公式

来源:Internet,编辑:股旁网,2011-07-29

HZ:HHV((H+L)/2,120);
AA:=(2*C+H+L)/4;
Var1:=IF(DATE=10301201,0,1);
Var2:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
Var3:=EMA(CLOSE,3);
Var4:=(2*CLOSE+LOW+HIGH)/4*Var1;
Var5:=Var2-Var3;
VAR6:=CLOSE*VOL;
VAR7:=EMA((EMA(VAR6,3)/EMA(VOL,3)+EMA(VAR6,6)/EMA(VOL,6)+EMA(VAR6,12)/EMA(VOL,12)+EMA(VAR6,24)/EMA(VOL,24))/4,13);
VAR8:=EMA(CLOSE,9);
VAR9:=(CLOSE+OPEN)/2;
VAR11:=MA(CLOSE,3);
VAR12:=MA(CLOSE,2*3);
VAR13:=MA(CLOSE,3*3);
VAR14:=MA(CLOSE,4*3);
VAR15:=MA((VAR11+VAR12+VAR13+VAR14)/4,5);
上轨1:EMA(VAR8*1.14,5),COLORGREEN,LINETHICK1;
上轨2:=VAR15*1.08,COLORWHITE,LINETHICK1;
操作线:MA(AA,5),COLORMAGENTA,LINETHICK2;
风险线:=MA(CLOSE,13);
黄线:(EMA(VAR9,3)+EMA(VAR9,6)+EMA(VAR9,12)+EMA(VAR9,24))/4,COLORYELLOW,linethick3;
精品1:=EMA(EMA(EMA(CLOSE,2),2),2);
精品2:(MA(精品1,13) * 0.999),COLORWHITE,linethick2;
道2:=6*HHV(精品2,3)-5*精品2;
PARTLINE(精品2=道2,精品2),LINETHICK3,COLORRED;
PARTLINE(精品2<道2,精品2),LINETHICK3,COLORWHITE;
青线:EMA(Var4,45)*1.15,COLORCYAN,linethick2;
绿线:EMA(Var4,55),COLORGREEN,linethick3;
牛股:=CROSS((100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8))),99);
攻:=ref(c,ref(hhvbars(v,21),0));
进攻:=ma(close,1);
指挥:=V>1*ref(V,1) and (c/ref(C,1)-1)*100>9.5 and 进攻>=攻;
DK:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;
组合:=牛股 and 指挥 and (CROSS(DK,5) or CROSS(DK,10));
基础0:=DK>ref(DK,1) and ref(DK,1)>ref(DK,2) and ref(DK,2)>ref(DK,3);
基础1:=绿线>ref(绿线,1) and ref(绿线,1)>ref(绿线,2) and ref(绿线,2)>ref(绿线,3);
基础2:=精品2>ref(精品2,1) and ref(精品2,1)>ref(精品2,2) and ref(精品2,2)>ref(精品2,3);
基础3:=黄线>ref(黄线,1) and ref(黄线,1)>ref(黄线,2) and ref(黄线,2)>ref(黄线,3);
基础4:=操作线>ref(操作线,1) and ref(操作线,1)>ref(操作线,2) and ref(操作线,2)>ref(操作线,3);
三角1:=基础0 and CROSS(DK,0);
三角2:=基础0 and CROSS(DK,5);
三角3:=基础0 and CROSS(DK,10);
{www.gUPang.com 股旁网_最新股票指标公式}
买1:=基础1 and 基础2 and 基础3 and 基础4 and CROSS(黄线,绿线);
买2:=基础1 and 基础2 and 基础3 and 基础4 and CROSS(精品2,绿线);
买3:=基础1 and 基础2 and 基础3 and 基础4 and CROSS(c,青线);
买4:=基础1 and 基础2 and 基础3 and 基础4 and CROSS(黄线,青线);
DRAWICON(组合,l*0.99,1),ALIGN1;
DRAWTEXT(三角1,l*0.96,'▲'),ALIGN0,PXDN20,COLORWHITE;
DRAWTEXT(三角2,l*0.96,'▲'),ALIGN0,PXDN20,COLORMAGENTA;
DRAWTEXT(三角3,l*0.96,'▲'),ALIGN0,PXDN20,COLORYELLOW;
DRAWTEXT(买1 or 买2 or 买3 or 买4,h*1.07,'买'),ALIGN0,PXDN20,COLORYELLOW;
DRAWTEXT(买1,h*1.04,'1'),ALIGN0,PXDN20,COLORYELLOW;
DRAWTEXT(买2,h*1.04,'2'),ALIGN0,PXDN20,COLORYELLOW;
DRAWTEXT(买3,h*1.04,'3'),ALIGN0,PXDN20,COLORYELLOW;
DRAWTEXT(买4,h*1.04,'4'),ALIGN0,PXDN20,COLORYELLOW;

飞狐看牛骑牛主图指标公式

 

相关文章