在线检测未来函数

飞狐实用成交量指标公式

来源:Internet,编辑:股旁网,2011-07-29

{龙聚首}
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));
HSL:=(XVL/20)/1.15; 攻击:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22)); LLJX:=EMA(攻击,3);
a1:=SUM(LLJX,1);a2:=SUM(LLJX,2);a3:=SUM(LLJX,3);a4:=SUM(LLJX,4);a5:=SUM(LLJX,5);
a6:=SUM(LLJX,6);a7:=SUM(LLJX,7);a8:=SUM(LLJX,8);a9:=SUM(LLJX,9);a10:=SUM(LLJX,10);
龙高1:=MAX(MAX(a1,a2),MAX(a2,a3));龙高2:=MAX(MAX(a4,a5),MAX(a5,a6));
龙高3:=MAX(MAX(a7,a8),MAX(龙高1,龙高2));龙最高:=MAX(MAX(a9,a10),龙高3),linethick0;
龙低1:=MIN(MIN(a1,a2),MIN(a2,a3));龙低2:=MIN(MIN(a4,a5),MIN(a5,a6));
龙低3:=MIN(MIN(a7,a8),MIN(龙低1,龙低2));龙最低:=MIN(MIN(a9,a10),龙低3),linethick0;
画面起点:=SYSPARAM(2);
画面终点:=SYSPARAM(3);
画面K线数:=画面终点-画面起点+1;
最低:=LLV(龙最低,画面K线数);
视低:=最低[画面终点],COLORFF2200;
最高:=HHV(龙最高,画面K线数);视高:=最高[画面终点];
成交量最高:=HHV(VOL,画面K线数);成交量视高:=成交量最高[画面终点];
合成成交量:=VOL*((视高-视低)/成交量视高)+视低;
虚量:=IF(BARSTATUS=2,合成成交量/INDEXV*MA(INDEXV,2),合成成交量);
STICKLINE(ISLASTBAR,视低,IF(ABS(虚量)>视高,视高,ABS(虚量)),8,1),COLORYELLOW;
STICKLINE(C>REF(C,1),视低,合成成交量,8,0),Color000066;
STICKLINE(C>REF(C,1),视低,合成成交量,6,0),Color000088;
STICKLINE(C>REF(C,1),视低,合成成交量,3,0),Color0000AA;
STICKLINE(C>REF(C,1),视低,合成成交量,1,0),Color0000CC;
STICKLINE(C<=REF(C,1),视低,合成成交量,8,0),COLORFF2200;
STICKLINE(C<=REF(C,1),视低,合成成交量,6,0),COLORFF4400;
STICKLINE(C<=REF(C,1),视低,合成成交量,3,0),COLORFF6600;
STICKLINE(C<=REF(C,1),视低,合成成交量,1,0),COLORFF8800;
空跌幅度:if(100*(c-cost(10))/cost(10)<0,100*(c-cost(10))/cost(10),0),COLOR008800,linethick0;
空跌:=视高+空跌幅度*视高/20,linethick0,COLOR008800;
FILLRGN(空跌<视高,if(空跌<视高*0.6,视高*0.6,空跌),视高*0.999),COLOR005000;
{资金}
VAR20:=POW(2*(EMA(CLOSE,2)-EMA(CLOSE,89)-EMA(EMA(CLOSE,2)-EMA(CLOSE,89),30))*10,3)*0.1+POW(2*(EMA(CLOSE,2)-EMA(CLOSE,89)-EMA(EMA(CLOSE,2)-EMA(CLOSE,89),30))*10,2);
VAR28:=2*(EMA(CLOSE,2)-EMA(CLOSE,150)-EMA(EMA(CLOSE,2)-EMA(CLOSE,150),100));
主力资金:IF(VAR28>0.1,POW(VAR28,3)*0.1+POW(VAR28,1),0)*5,COLORFF33FF,LINETHICK0;
主资增:(主力资金-REF(主力资金,1)),COLORFF33FF,LINETHICK0;
拉升资金:IF(2*(EMA(CLOSE,2)-EMA(CLOSE,89)-EMA(EMA(CLOSE,2)-EMA(CLOSE,89),30))*10>0.015,VAR20,0)/45,,COLOR00EEFF,LINETHICK0;
拉资增:(拉升资金-REF(拉升资金,1)),,COLOR00EEFF,LINETHICK0;
最高资:=HHV(IF(拉升资金>主力资金,拉升资金,主力资金),画面K线数);
视高资:=最高资[画面终点];
PARTLINE(C,主力资金*((视高-视低)/视高资)+视低),COLORff00ff,LINETHICK2;
PARTLINE(C,拉升资金*((视高-视低)/视高资)+视低),COLOR00EEFF,LINETHICK2;
{龙聚首显示}
partline(a1,a1),COLORff8888; partline(a2,a2),COLORff8888;
partline(a3,a3),COLORff8888; partline(a4,a4),COLORff8888;
partline(a5,a5),COLORff8888; partline(a6,a6),COLORff8888;
partline(a7,a7),COLORff8888; partline(a8,a8),COLORff8888;
partline(a9,a9),COLORff8888; partline(a10,a10),COLORff8888;
partline(a1>REF(a1,1),a1),COLOR0000ff;partline(a2>REF(a2,1),a2),COLOR0000ff;
partline(a3>REF(a3,1),a3),COLOR0000ff;partline(a4>REF(a4,1),a4),COLOR0000ff;
partline(a5>REF(a5,1),a5),COLOR0000ff;partline(a6>REF(a6,1),a6),COLOR0000ff;
partline(a7>REF(a7,1),a7),COLOR0000ff;partline(a8>REF(a8,1),a8),COLOR0000ff;
partline(a9>REF(a9,1),a9),COLOR0000ff;partline(a10>REF(a10,1),a10),COLOR0000ff;
地量:LLV(0.0001*AMOUNT,100)=0.0001*AMOUNT,STICK,COLORRED,LINETHICK0;
DRAWTEXT(地量,0.45*视高,'地量'),COLOR00CCDD;

买盘:=IF((CLOSE > OPEN),((VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN)))) * (HIGH - LOW)),IF((CLOSE < OPEN),((VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN)))) * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - ((VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN)))) * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - ((VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN)))) * (HIGH - LOW))),(0 - (VOL / 2))));
买卖差:=(买盘 + 卖盘);
STICKLINE((VOL > 0),合成成交量,视低,4,1),colorFFFFFF;
STICKLINE((买卖差 > 0),视低,买卖差/VOL*(合成成交量-视低)+视低,4,0),colorFF;
STICKLINE((买卖差 < 0),视低,买卖差/VOL*(合成成交量-视低)+视低,4,0),LINETHICK3,color33FF33;
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR6:=((ABS((OPEN - CLOSE)) / (HIGH - LOW)) * VOL);
VAR7:=(((HIGH - IF((CLOSE > OPEN),CLOSE,OPEN)) / (HIGH - LOW)) * VOL);
VAR8:=(((IF((CLOSE > OPEN),OPEN,CLOSE) - LOW) / (HIGH - LOW)) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60))); VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
DRAWTEXT( CROSS(84,((SMA(MAX((CLOSE - REF(CLOSE,1) ),0),6,1) / SMA(ABS((CLOSE - REF(CLOSE,1) )),6,1)) * 100)),合成成交量,'■卖出'),colorF2A3A4;
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,买盘) + 买盘) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,买盘) + 买盘) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,买盘) + 买盘) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,VAR20 ) + VAR20 ) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
多头:STICKLINE((CLOSE > MA(CLOSE,30)),视低,合成成交量,8,1),colorFF;
空头:STICKLINE((CLOSE < MA(CLOSE,30)),视低,合成成交量,8,1),colorFF00;
{www.gUPang.com 股旁网_最新股票指标公式}
加仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),视低,VAR6/VOL*(合成成交量-视低)+视低,6,0),colorFFFF;
减仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),视低,VAR6/VOL*(合成成交量-视低)+视低,6,0),colorFF0000;
洗盘:STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),视低,VAR8/VOL*(合成成交量-视低)+视低,6,0),colorFFFFFF;
高卖:STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),视低,VAR7/VOL*(合成成交量-视低)+视低,6,0),colorFF00FF;
相对地量:STICKLINE(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),视低,合成成交量,3,0);
地量2:DRAWTEXT(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),合成成交量,'地量');
放量:STICKLINE((VOL > (MA(VOL,5) * 2.5)),视低,合成成交量,3,0);
STICKLINE((买盘 > 0),买盘/VOL*(合成成交量-视低)+视低,视低,1.5,0),colorFF;
上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
下攻:=MA(VAR50,JY2);
上攻均量:=MA(买盘,JY1);
下攻均量:=MA(VAR20,JY1);
逢高出货:DRAWTEXT(((((((((VAR7 > VAR6) AND (VARA > 2)) AND (VAR9 > VAR8)) AND (CLOSE > MA(CLOSE,5))) AND (CLOSE > MA(CLOSE,30))) AND (HIGH > MA(CLOSE,60))) AND (VOL > MA(VOL,5))) AND (VAR7 >= MA(VOL,5))),合成成交量,'▼出货');
逢低跟进:DRAWTEXT(((((((VAR8 > VAR6) AND (VAR8 > VAR7)) AND (VARA < (0 - 2))) AND (CLOSE < MA(CLOSE,30))) AND (VAR8 < (MA(VOL,5) / 2))) AND (MA(VOL,5) < MA(VOL,10))),合成成交量,'●低进');
强势参与:DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)),合成成交量,'◆强势');
DRAWTEXT(((((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)) AND ((VAR6 / VOL) > 0.7)) AND VARC) AND (VAR6 > MA(VOL,5))),(VAR6 * 2)/VOL*(合成成交量-视低)+视低,'▼空头'),colorFF00;
DRAWTEXT(((((((VOL / MA(VOL,5)) > 1) AND ((买盘 / 三日上攻) > 1.58)) AND IF((三日上攻 > 上攻均量),(三日上攻 > 三日下攻),(三日上攻 > REF(三日上攻,1)))) AND (三日下攻 < REF(三日下攻,1))) AND ((((CLOSE - REF(CLOSE,3)) / REF(CLOSE,3)) * 100) < 14)),(买盘 * 1.3)/VOL*(合成成交量-视低)+视低,'★参与'),color99FF;
MFI:=(((HIGH - LOW) * 1000000) / VOL);
换手率:((VOL / CAPITAL) * 100),PRECISION2;
DRAWTEXT((((VOL / REF((SUM(VOL,5) / 5),1)) >= 2) AND (换手率 > 1)),(合成成交量 * 1.1),'●量变'),colorFFFF;
量:IF((CLOSE > 200),(VOL / 1000000),(VOL/ 100)),LINETHICK0;
振幅:(((HIGH - LOW) / LOW) * 100),LINETHICK0,PRECISION2;
STICKLINE((((CLOSE >= OPEN) AND (换手率 >= 3)) AND (换手率 < 5)),视低,量/VOL*(合成成交量-视低)+视低,80,1),color33AAFF;

飞狐实用成交量指标公式

 

相关文章