在线检测未来函数

同花顺天狼剑顶底指标公式

来源:Internet,编辑:股旁网,2011-07-30

IF(DATE>20080715) XXX:=0 ;
ELSE XXX:=1;
VAR1:=HHV(HIGH,3);
VAR2Q:=REF(LOW,1);
VAR3Q:=((SMA(ABS((LOW - VAR2Q)),3,1) / SMA(MAX((LOW - VAR2Q),0),3,1)) * 100);
VAR4Q:=EMA(IF((CLOSE * 1.3),(VAR3Q * 10),(VAR3Q / 10)),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=((EMA(IF((LOW <= VAR5Q),((VAR4Q + (VAR6Q * 2)) / 2),0),3) / 618) * VAR7Q);
VAR9Q:=IF((VAR8Q > 100),100,VAR8Q);
STICKLINE((VAR9Q > (0 - 120)),0,VAR9Q,8,1),colorbrown;
VAR2:=((IF((WINNER((1.1 * CLOSE)) < 0),0,WINNER((1.1 * CLOSE))) - IF((WINNER((0.9 * CLOSE)) < 0),0,WINNER((0.9 * CLOSE)))) * 100);
VAR3:=IF((VAR1 < 0),0,VAR1);
VAR4:=IF((VAR2 < 0),0,VAR2);
Var1d:=REF(CLOSE,1);
Var12d:=SMA(MAX(CLOSE-Var1d,0),6,1)/SMA(ABS(CLOSE-Var1d),6,1)*100;
卖出A:=IF( CROSS(80,Var12d),1.5,0);
VTD1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
SHD:=VTD1>9 AND FILTER(VTD1<REF(VTD1,1),5);
LDD:=VTD1>20 AND FILTER(VTD1<REF(VTD1,1),5);
VTD2:=HHV(VTD1>20,10);
WEIX:= VTD2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),Linethick0;
红色警报A:STICKLINE(VTD2 AND FILTER(VTD1< REF(VTD1,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VTD1+6,0,2,0);
VTDTJ:=SHD AND LDD AND WEIX;
STICKLINE(卖出A,60,100,2,0),LINETHICK2,color0000FF;
V1:=LLV(LOW,10);
V2:=HHV(HIGH,25);
价位线:=EMA((((CLOSE - V1) / (V2 - V1)) * 4),4);
STICKLINE(CROSS(价位线,0.3),50,5,2,0),color00CCFF;
STICKLINE(CROSS(价位线,0.3),30,5,2,0),color0000FF;
卖出:STICKLINE(VTDTJ,60,100,2,0),color0000FF;
STICKLINE(红色警报A,60,100,2,0),color00FFFF;
STICKLINE(CROSS(3.5,价位线),80,100,2,0),colorFF9900;
AA3:=((((HHV(HIGH,21) - CLOSE) / (HHV(HIGH,21) - LLV(LOW,21))) * 100) - 10);
AA4:=(((CLOSE - LLV(LOW,21)) / (HHV(HIGH,21) - LLV(LOW,21))) * 100);
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8)*xxx;
STICKLINE(VTDTJ,60,100,5,0),colorgreen;
STICKLINE(VTDTJ,60,100,5,0),colorgreen;
JY0:=(3*C+H+L)/5;
流通盘:=IF(C<300,CAPITAL*xxx,1200000000);
JZ0:=xxx*V/流通盘*100;
JA1:=HHVBARS(H,55)*xxx;
JA2:=SUM(JY0,JA1);
JA3:=SUM(JY0,2*JA1);
顶A1:=(JA2-JA3)/C;
JA4:=HHVBARS(H,55);
JA5:=SUM(JZ0,JA4);
JA6:=SUM(JZ0,2*JA4);
顶A2:=(JA5-JA6);
顶A3:= (顶A1+顶A2)/2;
顶A4:= MA(顶A3,1)+25;
JB1:=HHVBARS(H,120);
JB2:=SUM(JY0,JB1);
JB3:=SUM(JY0,2*JB1);
顶B1:=(JB2-JB3)/C;
JB4:=HHVBARS(H,120);
JB5:=SUM(JZ0,JB4);
JB6:=SUM(JZ0,2*JB4);
顶B2:=(JB5-JB6);
顶B3:= (顶B1+顶B2)/2;
顶B4:= MA(顶B3,5)+25;
DA1:=LLVBARS(L,65);
DA2:=SUM(JY0,DA1);
DA3:=SUM(JY0,2*DA1);
底A1:=(DA3-DA2)/C;
DA4:=LLVBARS(L,65);
DA5:=SUM(JZ0,DA4);
DA6:=SUM(JZ0,2*DA4);
底A2:=(DA6-DA5);
底A3:= (底A1+底A2)/2;
底A4:= EMA(底A3,1)-3;
DB1:=LLVBARS(L,850);
DB2:=SUM(JY0,DB1);
DB3:=SUM(JY0,2*DB1);
底B1:=(DB3-DB2)/C;
DB4:=LLVBARS(L,850);
DB5:=SUM(JZ0,DB4);
DB6:=SUM(JZ0,2*DB4);
底B2:=(DB6-DB5);
底B3:= (底B1+底B2)/2;
底B4:= MA(底B3,5)-3;
小顶:=IF(顶A4>-3,顶A4,-3);
大顶:= IF(顶B4>22,顶B4,22);
t9h:=IF(顶A4>22,顶A4,22);
小底:= IF(底A4<25,底A4,25);
t9l:=IF(底a4<0,底A4,0)*5;
大底:= IF(底B4<0,底B4,0);
t9h1:=FILTER(顶B4>22 AND 顶A4>22,10)*xxx;
DRAWTEXT(t9h1*xxx,80,'SELL');
STICKLINE(((走势 - AA6) > 85) OR "天狼剑_9.t9h"*5*xxx>110,98,90,15,1),color00aaaa;

同花顺天狼剑顶底指标公式

 

相关文章